summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-06-30 10:54:26 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-06-30 10:54:26 +0000
commit4fed0a7507fb8f4beb50728ab4349b272bcce3b3 (patch)
tree68d6eee5b0f10d20e5b0fae810ac3648d1f7af19 /games-strategy
parentVersion bump. Add tremor use flag. (diff)
downloadgentoo-2-4fed0a7507fb8f4beb50728ab4349b272bcce3b3.tar.gz
gentoo-2-4fed0a7507fb8f4beb50728ab4349b272bcce3b3.tar.bz2
gentoo-2-4fed0a7507fb8f4beb50728ab4349b272bcce3b3.zip
old
(Portage version: 2.2.0_alpha113/cvs/Linux x86_64)
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/naev/ChangeLog6
-rw-r--r--games-strategy/naev/files/naev-0.5.0-libpng15.patch15
-rw-r--r--games-strategy/naev/naev-0.5.0.ebuild82
3 files changed, 5 insertions, 98 deletions
diff --git a/games-strategy/naev/ChangeLog b/games-strategy/naev/ChangeLog
index f4c597333ac8..817e889e661c 100644
--- a/games-strategy/naev/ChangeLog
+++ b/games-strategy/naev/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-strategy/naev
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/naev/ChangeLog,v 1.15 2012/06/08 11:42:13 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/naev/ChangeLog,v 1.16 2012/06/30 10:54:26 ssuominen Exp $
+
+ 30 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> -naev-0.5.0.ebuild,
+ -files/naev-0.5.0-libpng15.patch:
+ old
08 Jun 2012; Pawel Hajdan jr <phajdan.jr@gentoo.org> naev-0.5.3.ebuild:
x86 stable wrt bug #418993
diff --git a/games-strategy/naev/files/naev-0.5.0-libpng15.patch b/games-strategy/naev/files/naev-0.5.0-libpng15.patch
deleted file mode 100644
index 1d144af45c5a..000000000000
--- a/games-strategy/naev/files/naev-0.5.0-libpng15.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-http://code.google.com/p/naev/issues/detail?id=129
-
-opengl.c: In function ‘write_png’:
-opengl.c:820:39: error: ‘Z_DEFAULT_COMPRESSION’ undeclared (first use in this function)
-
---- src/opengl.c
-+++ src/opengl.c
-@@ -39,6 +39,7 @@
- #include <string.h>
- #include <stdarg.h> /* va_list for gl_print */
-
-+#include <zlib.h> /* Z_DEFAULT_COMPRESSION */
- #include <png.h>
-
- #include "SDL.h"
diff --git a/games-strategy/naev/naev-0.5.0.ebuild b/games-strategy/naev/naev-0.5.0.ebuild
deleted file mode 100644
index bd44a7451a02..000000000000
--- a/games-strategy/naev/naev-0.5.0.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/naev/naev-0.5.0.ebuild,v 1.4 2012/05/04 04:51:08 jdhore Exp $
-
-EAPI=2
-inherit eutils gnome2-utils games
-
-DESCRIPTION="A 2D space trading and combat game, in a similar vein to Escape Velocity"
-HOMEPAGE="http://code.google.com/p/naev/"
-SRC_URI="mirror://sourceforge/naev/${P}.tar.bz2
- mirror://sourceforge/naev/ndata-${PV}"
-
-LICENSE="GPL-2 GPL-3 public-domain CCPL-Attribution-3.0 CCPL-Attribution-ShareAlike-3.0"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="debug +mixer +openal"
-
-RDEPEND="media-libs/libsdl[X,audio,video]
- dev-libs/libxml2
- >=media-libs/freetype-2
- >=media-libs/libvorbis-1.2.1
- >=media-libs/libpng-1.4
- media-libs/sdl-image[png]
- virtual/glu
- virtual/opengl
- mixer? ( media-libs/sdl-mixer )
- openal? ( media-libs/openal )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-src_unpack() {
- unpack ${P}.tar.bz2
-}
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-libpng15.patch
-}
-
-src_configure() {
- egamesconf \
- --docdir=/usr/share/doc/${PF} \
- --disable-dependency-tracking \
- $(use_enable debug) \
- $(use_with openal) \
- $(use_with mixer sdlmixer)
-}
-
-src_install() {
- emake \
- DESTDIR="${D}" \
- appicondir=/usr/share/icons/hicolor/32x32/apps \
- Graphicsdir=/usr/share/applications \
- install || die
-
- insinto "${GAMES_DATADIR}"/${PN}
- newins "${DISTDIR}"/ndata-${PV} ndata || die
-
- local res
- for res in 16 64 128 256; do
- insinto /usr/share/icons/hicolor/${res}x${res}/apps
- newins extras/logos/logo${res}.png naev.png || die
- done
-
- rm -f "${D}"/usr/share/doc/${PF}/LICENSE
- prepalldocs
-
- prepgamesdirs
-}
-
-pkg_preinst() {
- games_pkg_preinst
- gnome2_icon_savelist
-}
-
-pkg_postinst() {
- games_pkg_postinst
- gnome2_icon_cache_update
-}
-
-pkg_postrm() {
- gnome2_icon_cache_update
-}