summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2010-11-24 13:00:01 +0000
committerAlfredo Tupone <tupone@gentoo.org>2010-11-24 13:00:01 +0000
commit5eca0064d6d9fe6ab597a99cee1699f0d48867fa (patch)
tree8024b365cb732c7e15fec9c39b5aba5251630372 /games-strategy
parentSkip the rfc2045 test since it requires the en_US.utf-8 locale. Remove old pa... (diff)
downloadgentoo-2-5eca0064d6d9fe6ab597a99cee1699f0d48867fa.tar.gz
gentoo-2-5eca0064d6d9fe6ab597a99cee1699f0d48867fa.tar.bz2
gentoo-2-5eca0064d6d9fe6ab597a99cee1699f0d48867fa.zip
Fix buld with gcc-4.5 Bug #346543
(Portage version: 2.1.9.24/cvs/Linux i686)
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/widelands/ChangeLog6
-rw-r--r--games-strategy/widelands/files/widelands-0.15-gcc45.patch49
-rw-r--r--games-strategy/widelands/widelands-0.15.ebuild5
3 files changed, 57 insertions, 3 deletions
diff --git a/games-strategy/widelands/ChangeLog b/games-strategy/widelands/ChangeLog
index 2f69c44a210f..e70936a4911d 100644
--- a/games-strategy/widelands/ChangeLog
+++ b/games-strategy/widelands/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-strategy/widelands
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/widelands/ChangeLog,v 1.27 2010/11/20 17:48:59 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/widelands/ChangeLog,v 1.28 2010/11/24 13:00:01 tupone Exp $
+
+ 24 Nov 2010; Tupone Alfredo <tupone@gentoo.org> widelands-0.15.ebuild,
+ +files/widelands-0.15-gcc45.patch:
+ Fix buld with gcc-4.5 Bug #346543 by tobias muser
20 Nov 2010; Michael Sterrett <mr_bones_@gentoo.org>
widelands-0.15.ebuild, +files/widelands-0.15-locale.patch:
diff --git a/games-strategy/widelands/files/widelands-0.15-gcc45.patch b/games-strategy/widelands/files/widelands-0.15-gcc45.patch
new file mode 100644
index 000000000000..efd42a8b95e4
--- /dev/null
+++ b/games-strategy/widelands/files/widelands-0.15-gcc45.patch
@@ -0,0 +1,49 @@
+--- src/editor/ui_menus/editor_main_menu_random_map.cc.old 2010-05-18 17:17:15.000000000 +0200
++++ src/editor/ui_menus/editor_main_menu_random_map.cc 2010-05-18 17:18:29.000000000 +0200
+@@ -251,7 +251,7 @@
+ posx, posy, width, height,
+ g_gr->get_picture(PicMod_UI, "pics/but1.png"),
+ &Main_Menu_New_Random_Map::button_clicked, *this, 8,
+- Widelands::World::World(m_worlds[m_currentworld].c_str()).get_name());
++ Widelands::World(m_worlds[m_currentworld].c_str()).get_name());
+
+ posy += height + spacing + spacing + spacing;
+
+@@ -322,7 +322,7 @@
+ if (m_currentworld == m_worlds.size())
+ m_currentworld = 0;
+ m_world->set_title
+- (Widelands::World::World(m_worlds[m_currentworld].c_str()).get_name());
++ (Widelands::World(m_worlds[m_currentworld].c_str()).get_name());
+ break;
+ case 9:
+ break;
+@@ -476,7 +476,7 @@
+ (strcmp(mapInfo.worldName.c_str(), m_worlds[m_currentworld].c_str()))
+ ++m_currentworld;
+ m_world->set_title
+- (Widelands::World::World(m_worlds[m_currentworld].c_str()).get_name());
++ (Widelands::World(m_worlds[m_currentworld].c_str()).get_name());
+
+ button_clicked(-1); // Update other values in UI as well
+
+--- src/editor/ui_menus/editor_main_menu_new_map.cc.old 2010-05-18 17:38:29.000000000 +0200
++++ src/editor/ui_menus/editor_main_menu_new_map.cc 2010-05-18 17:38:55.000000000 +0200
+@@ -113,7 +113,7 @@
+ posx, posy, width, height,
+ g_gr->get_picture(PicMod_UI, "pics/but1.png"),
+ &Main_Menu_New_Map::button_clicked, *this, 4,
+- Widelands::World::World(m_worlds[m_currentworld].c_str()).get_name());
++ Widelands::World(m_worlds[m_currentworld].c_str()).get_name());
+
+ posy += height + spacing + spacing + spacing;
+
+@@ -142,7 +142,7 @@
+ if (m_currentworld == m_worlds.size())
+ m_currentworld = 0;
+ m_world->set_title
+- (Widelands::World::World(m_worlds[m_currentworld].c_str()).get_name
++ (Widelands::World(m_worlds[m_currentworld].c_str()).get_name
+ ());
+ break;
+ }
diff --git a/games-strategy/widelands/widelands-0.15.ebuild b/games-strategy/widelands/widelands-0.15.ebuild
index 7e0a987073af..16a7a73bc071 100644
--- a/games-strategy/widelands/widelands-0.15.ebuild
+++ b/games-strategy/widelands/widelands-0.15.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/widelands/widelands-0.15.ebuild,v 1.2 2010/11/20 17:48:59 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/widelands/widelands-0.15.ebuild,v 1.3 2010/11/24 13:00:01 tupone Exp $
EAPI=2
inherit eutils versionator cmake-utils games
@@ -35,7 +35,8 @@ S=${WORKDIR}/${MY_P}
src_prepare() {
epatch \
"${FILESDIR}"/${P}-build.patch \
- "${FILESDIR}"/${P}-locale.patch
+ "${FILESDIR}"/${P}-locale.patch \
+ "${FILESDIR}"/${P}-gcc45.patch
sed -i \
-e 's:__ppc__:__PPC__:' src/s2map.cc \