summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-06-25 17:10:07 +0000
committerMichał Górny <mgorny@gentoo.org>2014-06-25 17:10:07 +0000
commit79f26158e6bcae97b47c8d36dbc98638b6e54fcd (patch)
treed3eff9b85c1b223c782592f9035886a6e2cea39e /games-strategy
parentSupport multilib dependencies aside to emul-linux-x86. (diff)
downloadgentoo-2-79f26158e6bcae97b47c8d36dbc98638b6e54fcd.tar.gz
gentoo-2-79f26158e6bcae97b47c8d36dbc98638b6e54fcd.tar.bz2
gentoo-2-79f26158e6bcae97b47c8d36dbc98638b6e54fcd.zip
Support multilib dependencies aside to emul-linux-x86.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/savage-bin/ChangeLog7
-rw-r--r--games-strategy/savage-bin/savage-bin-2.00e-r1.ebuild94
2 files changed, 100 insertions, 1 deletions
diff --git a/games-strategy/savage-bin/ChangeLog b/games-strategy/savage-bin/ChangeLog
index c0969ca988cf..1dcb58e7f7ae 100644
--- a/games-strategy/savage-bin/ChangeLog
+++ b/games-strategy/savage-bin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-strategy/savage-bin
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/savage-bin/ChangeLog,v 1.17 2014/04/26 09:48:06 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/savage-bin/ChangeLog,v 1.18 2014/06/25 17:10:07 mgorny Exp $
+
+*savage-bin-2.00e-r1 (25 Jun 2014)
+
+ 25 Jun 2014; Michał Górny <mgorny@gentoo.org> +savage-bin-2.00e-r1.ebuild:
+ Support multilib dependencies aside to emul-linux-x86.
26 Apr 2014; Ulrich Müller <ulm@gentoo.org> savage-bin-2.00e.ebuild:
Fix LICENSE, add bindist restriction, bug 505778.
diff --git a/games-strategy/savage-bin/savage-bin-2.00e-r1.ebuild b/games-strategy/savage-bin/savage-bin-2.00e-r1.ebuild
new file mode 100644
index 000000000000..d5aa04fc00d5
--- /dev/null
+++ b/games-strategy/savage-bin/savage-bin-2.00e-r1.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/savage-bin/savage-bin-2.00e-r1.ebuild,v 1.1 2014/06/25 17:10:07 mgorny Exp $
+
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="Unique mix of strategy and FPS"
+HOMEPAGE="http://www.s2games.com/savage/
+ http://www.notforidiots.com/SFE/
+ http://www.newerth.com/"
+SRC_URI="http://www.newerth.com/?id=downloads&op=downloadFile&file=SFE-Standalone.tar.gz&mirrorid=1 -> SFE-Standalone.tar.gz
+ http://www.newerth.com/?id=downloads&op=downloadFile&file=SFE-Standalone.tar.gz&mirrorid=2 -> SFE-Standalone.tar.gz
+ http://www.newerth.com/?id=downloads&op=downloadFile&file=SFE-Standalone.tar.gz&mirrorid=3 -> SFE-Standalone.tar.gz
+ http://www.newerth.com/?id=downloads&op=downloadFile&file=lin-client-auth-patch.zip&mirrorid=1 -> lin-client-auth-patch.zip
+ http://www.newerth.com/?id=downloads&op=downloadFile&file=lin-client-auth-patch.zip&mirrorid=2 -> lin-client-auth-patch.zip
+ http://www.newerth.com/?id=downloads&op=downloadFile&file=lin-client-auth-patch.zip&mirrorid=3 -> lin-client-auth-patch.zip"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="mirror bindist strip"
+
+RDEPEND="
+ || (
+ (
+ >=media-libs/freetype-2[abi_x86_32(-)]
+ media-libs/libsdl[abi_x86_32(-)]
+ virtual/jpeg:62[abi_x86_32(-)]
+ virtual/opengl[abi_x86_32(-)]
+ )
+ amd64? (
+ (
+ app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)]
+ app-emulation/emul-linux-x86-opengl[-abi_x86_32(-)]
+ app-emulation/emul-linux-x86-sdl[-abi_x86_32(-)]
+ app-emulation/emul-linux-x86-xlibs[-abi_x86_32(-)]
+ )
+ )
+ )"
+DEPEND="app-arch/unzip"
+
+S=${WORKDIR}
+
+dir=${GAMES_PREFIX_OPT}/savage
+
+QA_TEXTRELS="${dir:1}/libs/libfmod.so
+ ${dir:1}/libs/libfmod-3.75.so
+ ${dir:1}/game/game.so"
+QA_EXECSTACK="${dir:1}/libs/libfmod.so
+ ${dir:1}/libs/libfmod-3.75.so"
+
+src_prepare() {
+ cp -f lin-client-auth-patch/silverback.bin .
+ cp -f lin-client-auth-patch/game/game.so game/.
+ cp -f lin-client-auth-patch/libs/libpng12.so.0 libs/.
+ rm -rf lin-client-auth-patch/
+ rm -f graveyard/game.dll *.sh
+ sed -e "s:%GAMES_PREFIX_OPT%:${GAMES_PREFIX_OPT}:" \
+ -e 's/^exec /__GL_ExtensionStringVersion=17700 exec /' \
+ "${FILESDIR}"/savage > "${T}"/savage || die
+ # Here, we default to the best resolution
+ sed -i \
+ -e 's/setsave vid_mode -1/setsave vid_mode 1/' \
+ game/settings/default.cfg || die
+}
+
+src_install() {
+ insinto "${dir}"
+ doins -r *
+ fperms g+x "${dir}"/silverback.bin
+ dosym /dev/null "${dir}"/scripts.log
+
+ dogamesbin "${T}"/savage
+ make_desktop_entry savage "Savage: The Battle For Newerth"
+
+ games_make_wrapper savage-graveyard "./silverback.bin set mod graveyard" \
+ "${dir}" "${dir}"/libs
+ sed -i \
+ -e 's/^exec /__GL_ExtensionStringVersion=17700 exec /' \
+ "${D}/${GAMES_BINDIR}/savage-graveyard" || die
+ make_desktop_entry savage-graveyard "Savage: Graveyard"
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ elog "In order to play \"Savage: The Battle For Newerth\", use:"
+ elog "savage"
+ elog "In order to start Editor, use:"
+ elog "savage-graveyard"
+}