summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2005-02-23 02:54:50 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2005-02-23 02:54:50 +0000
commit8f6ac17f114426de78fecb3b99e0e9cca3c67b64 (patch)
tree036db349ad7fca87a0b5287d55bc4d545fd6280e /games-strategy
parentInitial import. Ebuild by Alex Linke <incubation.11@freenet.de> and submitte... (diff)
downloadgentoo-2-8f6ac17f114426de78fecb3b99e0e9cca3c67b64.tar.gz
gentoo-2-8f6ac17f114426de78fecb3b99e0e9cca3c67b64.tar.bz2
gentoo-2-8f6ac17f114426de78fecb3b99e0e9cca3c67b64.zip
Updated to use lib-compat-loki. Ebuild by Alex Linke <incubation.11@freenet.de> and submitted to bug #71044.
(Portage version: 2.0.51-r15)
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/heroes3/ChangeLog11
-rw-r--r--games-strategy/heroes3/files/digest-heroes3-1.3.1a-r12
-rw-r--r--games-strategy/heroes3/heroes3-1.3.1a-r1.ebuild105
-rw-r--r--games-strategy/heroes3/heroes3-1.3.1a.ebuild4
4 files changed, 118 insertions, 4 deletions
diff --git a/games-strategy/heroes3/ChangeLog b/games-strategy/heroes3/ChangeLog
index 1e6edfd239bf..b8ae6106ffc3 100644
--- a/games-strategy/heroes3/ChangeLog
+++ b/games-strategy/heroes3/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for games-strategy/heroes3
-# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/heroes3/ChangeLog,v 1.1 2004/09/29 23:43:45 wolf31o2 Exp $
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/heroes3/ChangeLog,v 1.2 2005/02/23 02:54:50 wolf31o2 Exp $
+
+*heroes3-1.3.1a-r1 (22 Feb 2005)
+
+ 22 Feb 2005; Chris Gianelloni <wolf31o2@gentoo.org>
+ +heroes3-1.3.1a-r1.ebuild:
+ Updated to use lib-compat-loki. Ebuild by Alex Linke
+ <incubation.11@freenet.de> and submitted to bug #71044.
*heroes3-1.3.1a (29 Sep 2004)
diff --git a/games-strategy/heroes3/files/digest-heroes3-1.3.1a-r1 b/games-strategy/heroes3/files/digest-heroes3-1.3.1a-r1
new file mode 100644
index 000000000000..a34593c46c90
--- /dev/null
+++ b/games-strategy/heroes3/files/digest-heroes3-1.3.1a-r1
@@ -0,0 +1,2 @@
+MD5 be8d44e9bc808019011161f7605c9ba1 heroes3-1.3.1a-cdrom-x86.run 3012188
+MD5 32b2749e8097df6cde0a529c99e4d620 heroes3-1.3.1a-ppc.run 2643068
diff --git a/games-strategy/heroes3/heroes3-1.3.1a-r1.ebuild b/games-strategy/heroes3/heroes3-1.3.1a-r1.ebuild
new file mode 100644
index 000000000000..06106dbf39a2
--- /dev/null
+++ b/games-strategy/heroes3/heroes3-1.3.1a-r1.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/heroes3/heroes3-1.3.1a-r1.ebuild,v 1.1 2005/02/23 02:54:50 wolf31o2 Exp $
+
+# [x] Base Install Required (+4 MB)
+# [x] Scenarios (+7 MB)
+# [x] Sounds and Graphics (+118 MB)
+# [x] Music (+65 MB)
+# [x] Videos (+147 MB)
+# --------------------
+# Total 341 MB
+
+inherit games
+IUSE="nocd maps music sounds videos"
+DESCRIPTION="Heroes of Might and Magic III : The Restoration of Erathia - turn-based 2-D medieval combat"
+HOMEPAGE="http://www.lokigames.com/products/heroes3/"
+KEYWORDS="~x86"
+
+# Since I do not have a PPC machine to test with, I will leave the PPC stuff in
+# here so someone else can stabilize loki_setupdb and loki_patch for PPC and
+# then KEYWORD this appropriately.
+SRC_URI="x86? ( ftp://ftp.planetmirror.com/pub/lokigames/updates/${PN}/${P}-cdrom-x86.run
+ ftp://snuffleupagus.animearchive.org/loki/updates/${PN}/${P}-cdrom-x86.run )
+ ppc? ( ftp://ftp.planetmirror.com/pub/lokigames/updates/${PN}/${P}-ppc.run
+ ftp://snuffleupagus.animearchive.org/loki/updates/${PN}/${P}-ppc.run )"
+
+LICENSE="LOKI-EULA"
+SLOT="0"
+RESTRICT="nostrip"
+
+DEPEND="virtual/libc
+ games-util/loki_patch"
+RDEPEND="sys-libs/lib-compat-loki"
+
+S=${WORKDIR}
+
+dir=${GAMES_PREFIX_OPT}/${PN}
+Ddir=${D}/${dir}
+
+pkg_setup() {
+ check_license || die "License check failed"
+ use nocd && ewarn "The full installation takes about 341 MB of space!"
+ games_pkg_setup
+}
+
+src_unpack() {
+ unpack_makeself
+}
+
+src_install() {
+ cdrom_get_cds hiscore.tar.gz
+ einfo "Copying files... this may take a while..."
+ exeinto ${dir}
+ doexe ${CDROM_ROOT}/bin/x86/${PN}
+ insinto ${dir}
+ doins ${CDROM_ROOT}/{Heroes_III_Tutorial.pdf,README,icon.{bmp,xpm}}
+
+ if use nocd; then
+ dodir ${dir}/{maps,mp3,data} ${dir}/data/video
+ cp -r ${CDROM_ROOT}/{data,maps,mp3} ${Ddir} || die "copying data"
+ else
+ dodir ${dir}/data
+ use maps && insinto ${dir}/maps && dodir ${dir}/maps && doins ${CDROM_ROOT}/maps/*
+ use music && insinto ${dir}/mp3 && dodir ${dir}/mp3 && doins ${CDROM_ROOT}/mp3/*
+ use sounds && insinto ${dir}/data && doins ${CDROM_ROOT}/data/{*.lod,*.snd}
+ use videos && insinto ${dir}/data/video && dodir ${dir}/data/video && doins ${CDROM_ROOT}/data/video/*
+ fi
+
+ cd ${Ddir}
+ tar xf ${CDROM_ROOT}/hiscore.tar.gz || die "unpacking hiscore"
+
+ cd ${S}
+ loki_patch --verify patch.dat
+ loki_patch patch.dat ${Ddir} >& /dev/null || die "patching"
+
+ games_make_wrapper heroes3 ./heroes3 ${dir}
+
+ # now, since these files are coming off a cd, the times/sizes/md5sums wont
+ # be different ... that means portage will try to unmerge some files (!)
+ # we run touch on ${D} so as to make sure portage doesnt do any such thing
+ find ${Ddir} -exec touch '{}' \;
+
+ cp ${CDROM_ROOT}/icon.xpm ${S}/heroes3.xpm
+ doicon ${S}/heroes3.xpm
+
+ prepgamesdirs
+ make_desktop_entry heroes3 "Heroes of Might and Magic III" "heroes3.xpm"
+
+ if [ "${ARCH}" = "x86" ]; then
+ einfo "Linking libs provided by 'sys-libs/lib-compat-loki' to '${dir}'."
+ dosym /lib/loki_ld-linux.so.2 ${dir}/ld-linux.so.2 && \
+ dosym /usr/lib/loki_libc.so.6 ${dir}/libc.so.6 && \
+ dosym /usr/lib/loki_libnss_files.so.2 ${dir}/libnss_files.so.2 || die "dosym failed"
+ fi
+
+ einfo "Changing 'hiscore.dat' to be writeable for group 'games'."
+ fperms g+w ${Ddir}/data/hiscore.dat || die "fperms failed"
+}
+
+pkg_postinst() {
+ einfo "To play the game run:"
+ einfo " heroes3"
+
+ games_pkg_postinst
+}
diff --git a/games-strategy/heroes3/heroes3-1.3.1a.ebuild b/games-strategy/heroes3/heroes3-1.3.1a.ebuild
index 3002f3228b44..d7f2b54b4aa7 100644
--- a/games-strategy/heroes3/heroes3-1.3.1a.ebuild
+++ b/games-strategy/heroes3/heroes3-1.3.1a.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/heroes3/heroes3-1.3.1a.ebuild,v 1.1 2004/09/29 23:43:45 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/heroes3/heroes3-1.3.1a.ebuild,v 1.2 2005/02/23 02:54:50 wolf31o2 Exp $
# [x] Base Install Required (+4 MB)
# [x] Scenarios (+7 MB)