summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2012-07-11 17:31:41 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2012-07-11 17:31:41 +0000
commit924dfca00aefc127e9fe1fb642ffd877bc5947bf (patch)
tree4ede6a63b75d429aee136b863af3cbbc54b82179 /games-strategy
parentgpl for init script bug #425942 (diff)
downloadgentoo-2-924dfca00aefc127e9fe1fb642ffd877bc5947bf.tar.gz
gentoo-2-924dfca00aefc127e9fe1fb642ffd877bc5947bf.tar.bz2
gentoo-2-924dfca00aefc127e9fe1fb642ffd877bc5947bf.zip
old
(Portage version: 2.1.10.65/cvs/Linux x86_64)
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/wesnoth/ChangeLog6
-rw-r--r--games-strategy/wesnoth/files/wesnoth-1.10-xdg-path-fix.patch54
-rw-r--r--games-strategy/wesnoth/wesnoth-1.10.ebuild119
3 files changed, 5 insertions, 174 deletions
diff --git a/games-strategy/wesnoth/ChangeLog b/games-strategy/wesnoth/ChangeLog
index a14fe8da9b5b..f8b2b8ee66e1 100644
--- a/games-strategy/wesnoth/ChangeLog
+++ b/games-strategy/wesnoth/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-strategy/wesnoth
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/ChangeLog,v 1.209 2012/06/29 12:51:11 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/ChangeLog,v 1.210 2012/07/11 17:31:41 mr_bones_ Exp $
+
+ 11 Jul 2012; Michael Sterrett <mr_bones_@gentoo.org>
+ -files/wesnoth-1.10-xdg-path-fix.patch, -wesnoth-1.10.ebuild:
+ old
29 Jun 2012; Brent Baude <ranger@gentoo.org> wesnoth-1.10.3.ebuild:
Marking wesnoth-1.10.3 ppc for bug 422109
diff --git a/games-strategy/wesnoth/files/wesnoth-1.10-xdg-path-fix.patch b/games-strategy/wesnoth/files/wesnoth-1.10-xdg-path-fix.patch
deleted file mode 100644
index 965195a5c699..000000000000
--- a/games-strategy/wesnoth/files/wesnoth-1.10-xdg-path-fix.patch
+++ /dev/null
@@ -1,54 +0,0 @@
-Index: src/filesystem.cpp
-===================================================================
---- src/filesystem.cpp (Revision 52751)
-+++ src/filesystem.cpp (Revision 52752)
-@@ -63,6 +63,7 @@
- #include "loadscreen.hpp"
- #include "scoped_resource.hpp"
- #include "serialization/string_utils.hpp"
-+#include "version.hpp"
-
- static lg::log_domain log_filesystem("filesystem");
- #define DBG_FS LOG_STREAM(debug, log_filesystem)
-@@ -501,6 +502,23 @@
-
- static void setup_user_data_dir();
-
-+static const std::string& get_version_path_suffix()
-+{
-+ static std::string suffix;
-+
-+ // We only really need to generate this once since
-+ // the version number cannot change during runtime.
-+
-+ if(suffix.empty()) {
-+ std::ostringstream s;
-+ s << game_config::wesnoth_version.major_version() << '.'
-+ << game_config::wesnoth_version.minor_version();
-+ suffix = s.str();
-+ }
-+
-+ return suffix;
-+}
-+
- void set_preferences_dir(std::string path)
- {
- #ifdef _WIN32
-@@ -537,7 +555,7 @@
- if (path.empty()) path = PREFERENCES_DIR;
- #endif
-
-- std::string path2 = ".wesnoth" + game_config::version.substr(0,3);
-+ std::string path2 = ".wesnoth" + get_version_path_suffix();
-
- #ifdef _X11
- const char *home_str = getenv("HOME");
-@@ -553,7 +571,7 @@
- user_data_dir += "/.local/share";
- } else user_data_dir = xdg_data;
- user_data_dir += "/wesnoth/";
-- user_data_dir += game_config::version.substr(0,3);
-+ user_data_dir += get_version_path_suffix();
- create_directory_if_missing_recursive(user_data_dir);
- game_config::preferences_dir = user_data_dir;
- } else {
diff --git a/games-strategy/wesnoth/wesnoth-1.10.ebuild b/games-strategy/wesnoth/wesnoth-1.10.ebuild
deleted file mode 100644
index 29d6d892a98a..000000000000
--- a/games-strategy/wesnoth/wesnoth-1.10.ebuild
+++ /dev/null
@@ -1,119 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/wesnoth-1.10.ebuild,v 1.5 2012/05/04 04:51:07 jdhore Exp $
-
-EAPI=2
-inherit cmake-utils eutils multilib toolchain-funcs flag-o-matic games
-
-DESCRIPTION="Battle for Wesnoth - A fantasy turn-based strategy game"
-HOMEPAGE="http://www.wesnoth.org/"
-SRC_URI="mirror://sourceforge/wesnoth/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc ~ppc64 x86 ~x86-fbsd"
-IUSE="dbus dedicated doc nls server"
-
-RDEPEND=">=media-libs/libsdl-1.2.7[video,X]
- media-libs/sdl-net
- >=media-libs/sdl-ttf-2.0.8
- >=media-libs/sdl-mixer-1.2[vorbis]
- >=media-libs/sdl-image-1.2[jpeg,png]
- !dedicated? (
- dbus? ( sys-apps/dbus )
- )
- >=dev-libs/boost-1.36
- sys-libs/zlib
- x11-libs/pango
- dev-lang/lua
- media-libs/fontconfig
- virtual/libintl"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- sys-devel/gettext"
-
-src_prepare() {
- if use dedicated || use server ; then
- sed \
- -e "s:GAMES_BINDIR:${GAMES_BINDIR}:" \
- -e "s:GAMES_STATEDIR:${GAMES_STATEDIR}:" \
- -e "s/GAMES_USER_DED/${GAMES_USER_DED}/" \
- -e "s/GAMES_GROUP/${GAMES_GROUP}/" "${FILESDIR}"/wesnothd.rc \
- > "${T}"/wesnothd \
- || die "sed failed"
- fi
- if ! use doc ; then
- sed -i \
- -e '/manual/d' \
- doc/CMakeLists.txt \
- || die "sed failed"
- fi
- # how do I hate boost? Let me count the ways...
- local boost_ver=$(best_version ">=dev-libs/boost-1.36")
-
- boost_ver=${boost_ver/*boost-/}
- boost_ver=${boost_ver%.*}
- boost_ver=${boost_ver/./_}
-
- einfo "Using boost version ${boost_ver}"
- append-cxxflags \
- -I/usr/include/boost-${boost_ver}
- append-ldflags \
- -L/usr/$(get_libdir)/boost-${boost_ver}
- export BOOST_INCLUDEDIR="/usr/include/boost-${boost_ver}"
- export BOOST_LIBRARYDIR="/usr/$(get_libdir)/boost-${boost_ver}"
-
- epatch "${FILESDIR}"/${P}-xdg-path-fix.patch
-}
-
-src_configure() {
- filter-flags -ftracer -fomit-frame-pointer
- if [[ $(gcc-major-version) -eq 3 ]] ; then
- filter-flags -fstack-protector
- append-flags -fno-stack-protector
- fi
- if use dedicated || use server ; then
- mycmakeargs=(
- "-DENABLE_CAMPAIGN_SERVER=TRUE"
- "-DENABLE_SERVER=TRUE"
- "-DSERVER_UID=${GAMES_USER_DED}"
- "-DSERVER_GID=${GAMES_GROUP}"
- "-DFIFO_DIR=${GAMES_STATEDIR}/run/wesnothd"
- )
- else
- mycmakeargs=(
- "-DENABLE_CAMPAIGN_SERVER=FALSE"
- "-DENABLE_SERVER=FALSE"
- )
- fi
- mycmakeargs+=(
- $(cmake-utils_use_enable !dedicated GAME)
- $(cmake-utils_use_enable !dedicated ENABLE_DESKTOP_ENTRY)
- $(cmake-utils_use_enable nls NLS)
- $(cmake-utils_use_enable dbus NOTIFICATIONS)
- "-DCMAKE_VERBOSE_MAKEFILE=TRUE"
- "-DENABLE_FRIBIDI=FALSE"
- "-DENABLE_STRICT_COMPILATION=FALSE"
- "-DCMAKE_INSTALL_PREFIX=${GAMES_PREFIX}"
- "-DDATAROOTDIR=${GAMES_DATADIR}"
- "-DBINDIR=${GAMES_BINDIR}"
- "-DICONDIR=/usr/share/pixmaps"
- "-DDESKTOPDIR=/usr/share/applications"
- "-DMANDIR=/usr/share/man"
- "-DDOCDIR=/usr/share/doc/${PF}"
- )
- cmake-utils_src_configure
-}
-
-src_compile() {
- cmake-utils_src_compile
-}
-
-src_install() {
- DOCS="README changelog players_changelog" cmake-utils_src_install
- if use dedicated || use server; then
- keepdir "${GAMES_STATEDIR}/run/wesnothd"
- doinitd "${T}"/wesnothd || die "doinitd failed"
- fi
- prepgamesdirs
-}