summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2014-06-09 15:10:10 +0000
committerJulian Ospald <hasufell@gentoo.org>2014-06-09 15:10:10 +0000
commita2b8ac1a3e3119196cd39daa63f2a9de5358df39 (patch)
tree9b3aacf810bbad4b52d04be8170b044516b29130 /games-strategy
parentVersion bump. (diff)
downloadgentoo-2-a2b8ac1a3e3119196cd39daa63f2a9de5358df39.tar.gz
gentoo-2-a2b8ac1a3e3119196cd39daa63f2a9de5358df39.tar.bz2
gentoo-2-a2b8ac1a3e3119196cd39daa63f2a9de5358df39.zip
version bump
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key BDEED020)
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/openra/ChangeLog11
-rw-r--r--games-strategy/openra/metadata.xml5
-rw-r--r--games-strategy/openra/openra-20140608.ebuild96
3 files changed, 106 insertions, 6 deletions
diff --git a/games-strategy/openra/ChangeLog b/games-strategy/openra/ChangeLog
index 6ad29b5293e3..d2347f745853 100644
--- a/games-strategy/openra/ChangeLog
+++ b/games-strategy/openra/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for games-strategy/openra
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/openra/ChangeLog,v 1.28 2014/03/04 19:55:40 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/openra/ChangeLog,v 1.29 2014/06/09 15:10:10 hasufell Exp $
+
+*openra-20140608 (09 Jun 2014)
+
+ 09 Jun 2014; Julian Ospald <hasufell@gentoo.org> +openra-20140608.ebuild,
+ metadata.xml:
+ version bump
+
+ 08 Jun 2014; Julian Ospald <hasufell@gentoo.org> metadata.xml:
+ remove proxy maintainer
04 Mar 2014; Agostino Sarubbo <ago@gentoo.org> openra-20131223-r1.ebuild:
Stable for x86, wrt bug #502360
diff --git a/games-strategy/openra/metadata.xml b/games-strategy/openra/metadata.xml
index c49b86241916..a31fbadfe797 100644
--- a/games-strategy/openra/metadata.xml
+++ b/games-strategy/openra/metadata.xml
@@ -1,17 +1,12 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>proxy-maintainers</herd>
<herd>games</herd>
<maintainer>
<email>hasufell@gentoo.org</email>
<name>Julian Ospald</name>
<description>Maintainer, assign bugs to him</description>
</maintainer>
- <maintainer>
- <email>diamond@hi-net.ru</email>
- <description>Proxy maintainer. CC him on bugs</description>
- </maintainer>
<upstream>
<changelog>http://openra.res0l.net/news/</changelog>
<doc lang="en">https://github.com/OpenRA/OpenRA/wiki</doc>
diff --git a/games-strategy/openra/openra-20140608.ebuild b/games-strategy/openra/openra-20140608.ebuild
new file mode 100644
index 000000000000..b2201022cf16
--- /dev/null
+++ b/games-strategy/openra/openra-20140608.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/openra/openra-20140608.ebuild,v 1.1 2014/06/09 15:10:10 hasufell Exp $
+
+EAPI=5
+
+inherit eutils mono-env gnome2-utils vcs-snapshot games
+
+DESCRIPTION="A free RTS engine supporting games like Command & Conquer and Red Alert"
+HOMEPAGE="http://open-ra.org/"
+SRC_URI="https://github.com/OpenRA/OpenRA/tarball/release-${PV} -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="tools"
+
+QA_PREBUILT="$(games_get_libdir)/openra/liblua*"
+
+DEPEND="dev-dotnet/libgdiplus
+ dev-lang/mono
+ media-libs/freetype:2[X]
+ media-libs/libsdl2[X,opengl,video]
+ media-libs/openal
+ virtual/jpeg
+ virtual/opengl"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ mono-env_pkg_setup
+ games_pkg_setup
+}
+
+src_unpack() {
+ vcs-snapshot_src_unpack
+}
+
+src_configure() { :; }
+
+src_prepare() {
+ # register game-version
+ sed \
+ -e "/Version/s/{DEV_VERSION}/release-${PV}/" \
+ -i mods/{ra,cnc,d2k}/mod.yaml || die
+}
+
+src_compile() {
+ emake $(usex tools "all" "")
+ emake native-dependencies
+ emake docs
+}
+
+src_install() {
+ emake \
+ datadir="/usr/share" \
+ bindir="${GAMES_BINDIR}" \
+ libdir="$(games_get_libdir)" \
+ DESTDIR="${D}" \
+ $(usex tools "install-all" "install") install-linux-scripts
+
+ exeinto "$(games_get_libdir)/openra"
+ doexe Eluant.dll.config liblua$(usex amd64 "64" "32")*
+
+ # icons
+ insinto /usr/share/icons/
+ doins -r packaging/linux/hicolor
+
+ # desktop entries
+ make_desktop_entry "${PN} Game.Mods=cnc" "OpenRA CNC" ${PN}
+ make_desktop_entry "${PN} Game.Mods=ra" "OpenRA RA" ${PN}
+ make_desktop_entry "${PN} Game.Mods=d2k" "OpenRA Dune2k" ${PN}
+ make_desktop_entry "${PN}-editor" "OpenRA Map Editor" ${PN}
+
+ dodoc "${FILESDIR}"/README.gentoo README.md CONTRIBUTING.md AUTHORS \
+ DOCUMENTATION.md Lua-API.md
+
+ # file permissions
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+
+ elog "optional dependencies:"
+ elog " media-gfx/nvidia-cg-toolkit (fallback renderer if OpenGL fails)"
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}