summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-06-25 17:18:13 +0000
committerMichał Górny <mgorny@gentoo.org>2014-06-25 17:18:13 +0000
commitfca54818f914b0a54020df1cee9a5ce3cfced0c2 (patch)
tree422f8a5c59d99a92739bb9a4eb6f2bd00a6b95c7 /games-strategy
parentSupport multilib dependencies aside to emul-linux-x86. (diff)
downloadgentoo-2-fca54818f914b0a54020df1cee9a5ce3cfced0c2.tar.gz
gentoo-2-fca54818f914b0a54020df1cee9a5ce3cfced0c2.tar.bz2
gentoo-2-fca54818f914b0a54020df1cee9a5ce3cfced0c2.zip
Support multilib dependencies aside to emul-linux-x86.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/gorky17-demo/ChangeLog9
-rw-r--r--games-strategy/gorky17-demo/gorky17-demo-1.0.1.0.1-r1.ebuild90
2 files changed, 97 insertions, 2 deletions
diff --git a/games-strategy/gorky17-demo/ChangeLog b/games-strategy/gorky17-demo/ChangeLog
index 1d1c79cccd27..d56058ac37ea 100644
--- a/games-strategy/gorky17-demo/ChangeLog
+++ b/games-strategy/gorky17-demo/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-strategy/gorky17-demo
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/gorky17-demo/ChangeLog,v 1.8 2014/05/06 16:03:49 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/gorky17-demo/ChangeLog,v 1.9 2014/06/25 17:18:13 mgorny Exp $
+
+*gorky17-demo-1.0.1.0.1-r1 (25 Jun 2014)
+
+ 25 Jun 2014; Michał Górny <mgorny@gentoo.org>
+ +gorky17-demo-1.0.1.0.1-r1.ebuild:
+ Support multilib dependencies aside to emul-linux-x86.
06 May 2014; Ulrich Müller <ulm@gentoo.org> gorky17-demo-1.0.1.0.1.ebuild:
Fix LICENSE, add mirror and bindist restrictions, bug 505766.
@@ -38,4 +44,3 @@
+gorky17-demo-1.0.0.ebuild:
Initial import. Ebuild by Paul Bredbury <brebs@sent.com> and modified by me.
Closing bug #135958.
-
diff --git a/games-strategy/gorky17-demo/gorky17-demo-1.0.1.0.1-r1.ebuild b/games-strategy/gorky17-demo/gorky17-demo-1.0.1.0.1-r1.ebuild
new file mode 100644
index 000000000000..f8cbdd720af3
--- /dev/null
+++ b/games-strategy/gorky17-demo/gorky17-demo-1.0.1.0.1-r1.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/gorky17-demo/gorky17-demo-1.0.1.0.1-r1.ebuild,v 1.1 2014/06/25 17:18:13 mgorny Exp $
+
+EAPI=5
+
+inherit eutils unpacker versionator games
+
+MY_PN="gorky17"
+MY_PV=$(replace_version_separator 2 '-')
+
+DESCRIPTION="Horror conspiracy game mixing elements of strategy and role-playing"
+HOMEPAGE="http://www.linuxgamepublishing.com/info.php?id=gorky17"
+SRC_URI="http://demofiles.linuxgamepublishing.com/${MY_PN}/${MY_PN}_demo.run
+ http://updatefiles.linuxgamepublishing.com/gorky17-demo/${PN}-${MY_PV}-x86.run"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+RESTRICT="mirror bindist strip"
+
+RDEPEND="
+ || (
+ (
+ media-libs/alsa-lib[abi_x86_32(-)]
+ media-libs/libsdl[abi_x86_32(-)]
+ sys-libs/zlib[abi_x86_32(-)]
+ x11-libs/libX11[abi_x86_32(-)]
+ x11-libs/libXau[abi_x86_32(-)]
+ x11-libs/libXdmcp[abi_x86_32(-)]
+ x11-libs/libXext[abi_x86_32(-)]
+ )
+ amd64? (
+ (
+ app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)]
+ app-emulation/emul-linux-x86-sdl[-abi_x86_32(-)]
+ app-emulation/emul-linux-x86-soundlibs[-abi_x86_32(-)]
+ app-emulation/emul-linux-x86-xlibs[-abi_x86_32(-)]
+ )
+ )
+ )"
+
+S=${WORKDIR}
+
+dir=${GAMES_PREFIX_OPT}/${PN}
+Ddir=${D}/${dir}
+
+QA_EXECSTACK="${dir:1}/gorky17_demo ${dir:1}/gorky17_demo.dynamic"
+
+src_unpack() {
+ unpack_makeself ${MY_PN}_demo.run
+ unpack ./data/data.tar.gz
+
+ mkdir patch
+ cd patch
+ unpack_makeself ${PN}-${MY_PV}-x86.run
+ cd "${S}"
+
+ # Apply patch
+ mv bin/Linux/x86/* .
+ mv patch/*.sh .
+ ./patch/bin/Linux/x86/loki_patch patch/patch.dat . \
+ || die "loki_patch failed"
+
+ rm -r update.sh *patch.sh data lgp_* patch setup* bin
+}
+
+src_install() {
+ insinto "${dir}"
+ doins -r *
+ rm "${Ddir}"/${MY_PN}*
+
+ exeinto "${dir}"
+ doexe ${MY_PN}*
+
+ games_make_wrapper ${PN} ./${MY_PN}_demo "${dir}" "${dir}"
+ newicon icon.xpm ${PN}.xpm
+ make_desktop_entry ${PN} "Gorky 17 (Demo)" ${PN}
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+
+ elog "The instruction manual is available as:"
+ elog " http://demofiles.linuxgamepublishing.com/gorky17/manual.pdf"
+ echo
+}