summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2007-03-12 14:23:31 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2007-03-12 14:23:31 +0000
commit108f53e8dcc19c8c72b4ec1250b3f10516e37da6 (patch)
tree4dfd8560a1f7cb5de051337b8281edad9e40428b /games-util/biounzip
parentKeyworded ~sparc wrt #170430 (diff)
downloadgentoo-2-108f53e8dcc19c8c72b4ec1250b3f10516e37da6.tar.gz
gentoo-2-108f53e8dcc19c8c72b4ec1250b3f10516e37da6.tar.bz2
gentoo-2-108f53e8dcc19c8c72b4ec1250b3f10516e37da6.zip
Added a patch from Andrei Slavoiu <ansla80@yahoo.com> to fix biounzip on 64-bit machines and closing bug #169867.
(Portage version: 2.1.2.1)
Diffstat (limited to 'games-util/biounzip')
-rw-r--r--games-util/biounzip/ChangeLog9
-rw-r--r--games-util/biounzip/biounzip-1.1a.ebuild10
-rw-r--r--games-util/biounzip/files/biounzip-1.1a-64bit.patch11
3 files changed, 26 insertions, 4 deletions
diff --git a/games-util/biounzip/ChangeLog b/games-util/biounzip/ChangeLog
index 6125a71b1b4d..a533a629e6bf 100644
--- a/games-util/biounzip/ChangeLog
+++ b/games-util/biounzip/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-util/biounzip
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-util/biounzip/ChangeLog,v 1.1 2006/01/09 23:29:05 wolf31o2 Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-util/biounzip/ChangeLog,v 1.2 2007/03/12 14:23:31 wolf31o2 Exp $
+
+ 12 Mar 2007; Chris Gianelloni <wolf31o2@gentoo.org>
+ +files/biounzip-1.1a-64bit.patch, biounzip-1.1a.ebuild:
+ Added a patch from Andrei Slavoiu <ansla80@yahoo.com> to fix biounzip on
+ 64-bit machines and closing bug #169867.
*biounzip-1.1a (09 Jan 2006)
diff --git a/games-util/biounzip/biounzip-1.1a.ebuild b/games-util/biounzip/biounzip-1.1a.ebuild
index 75da80343110..de85606264e0 100644
--- a/games-util/biounzip/biounzip-1.1a.ebuild
+++ b/games-util/biounzip/biounzip-1.1a.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-util/biounzip/biounzip-1.1a.ebuild,v 1.2 2007/01/26 19:11:46 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-util/biounzip/biounzip-1.1a.ebuild,v 1.3 2007/03/12 14:23:31 wolf31o2 Exp $
inherit eutils
@@ -17,6 +17,12 @@ IUSE=""
RDEPEND="virtual/libc sys-libs/zlib"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-64bit.patch
+}
+
src_compile() {
sed -i -e "s#-march=athlon-xp#${CFLAGS}#" Makefile || die
emake || die
diff --git a/games-util/biounzip/files/biounzip-1.1a-64bit.patch b/games-util/biounzip/files/biounzip-1.1a-64bit.patch
new file mode 100644
index 000000000000..8e106542d49a
--- /dev/null
+++ b/games-util/biounzip/files/biounzip-1.1a-64bit.patch
@@ -0,0 +1,11 @@
+--- /var/tmp/portage/games-util/biounzip-1.1a/work/biounzip-1.1-old/biounzip.c 2007-03-08 02:06:16.000000000 +0200
++++ /var/tmp/portage/games-util/biounzip-1.1a/work/biounzip-1.1/biounzip.c 2007-03-08 02:06:50.000000000 +0200
+@@ -127,7 +127,7 @@
+ void writefile(bzfile *ptr, FILE *fp, char *destdir)
+ {
+ int startpos,returnval,n,debug=0;
+- unsigned long size_uncompressed,size_compressed;
++ unsigned long size_uncompressed = 0, size_compressed = 0;
+ char *fname,*dirname,*fullname,*fullpath;
+ unsigned char *srcbuffer,*dstbuffer;
+ FILE *outfile;