summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-01-29 08:24:46 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-01-29 08:24:46 +0000
commit96cbc13c023c2c2030a23659f5a68a26b0500f35 (patch)
tree0748f264af30cdd546913cb0a15c6ace5808bb15 /games-util/joystick
parentEAPI=2; add use-based dep for qt (bug #247344) (diff)
downloadgentoo-2-96cbc13c023c2c2030a23659f5a68a26b0500f35.tar.gz
gentoo-2-96cbc13c023c2c2030a23659f5a68a26b0500f35.tar.bz2
gentoo-2-96cbc13c023c2c2030a23659f5a68a26b0500f35.zip
EAPI=2; respect CC
(Portage version: 2.1.6.4/cvs/Linux 2.6.28.1 i686)
Diffstat (limited to 'games-util/joystick')
-rw-r--r--games-util/joystick/ChangeLog8
-rw-r--r--games-util/joystick/joystick-20060731.ebuild16
2 files changed, 16 insertions, 8 deletions
diff --git a/games-util/joystick/ChangeLog b/games-util/joystick/ChangeLog
index 141bb1698d52..8cc6c5caa6b7 100644
--- a/games-util/joystick/ChangeLog
+++ b/games-util/joystick/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-util/joystick
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-util/joystick/ChangeLog,v 1.5 2006/10/10 04:20:39 dberkholz Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-util/joystick/ChangeLog,v 1.6 2009/01/29 08:24:46 mr_bones_ Exp $
+
+ 29 Jan 2009; Michael Sterrett <mr_bones_@gentoo.org>
+ joystick-20060731.ebuild:
+ EAPI=2; respect CC
10 Oct 2006; Donnie Berkholz <dberkholz@gentoo.org>;
joystick-20060731.ebuild:
diff --git a/games-util/joystick/joystick-20060731.ebuild b/games-util/joystick/joystick-20060731.ebuild
index f67521de7d00..140b4d30bb17 100644
--- a/games-util/joystick/joystick-20060731.ebuild
+++ b/games-util/joystick/joystick-20060731.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-util/joystick/joystick-20060731.ebuild,v 1.3 2007/04/19 22:32:10 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-util/joystick/joystick-20060731.ebuild,v 1.4 2009/01/29 08:24:46 mr_bones_ Exp $
-inherit eutils
+EAPI=2
+inherit eutils toolchain-funcs
DESCRIPTION="joystick testing utilities"
HOMEPAGE="http://atrey.karlin.mff.cuni.cz/~vojtech/input/"
@@ -17,16 +18,19 @@ DEPEND="sdl? ( media-libs/libsdl )"
S=${WORKDIR}/utils
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
epatch \
"${FILESDIR}"/joystick-MCS-defines.patch \
"${FILESDIR}"/joystick-jstest-segv.patch
+ sed -i \
+ -e '/^CC/d' \
+ Makefile \
+ || die 'sed failed'
}
src_compile() {
local SDL
+ tc-export CC
use sdl && SDL=1 || SDL=0
emake SDL=${SDL} || die "emake failed"
emake inputattach || die "inputattach failed"