summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2012-05-19 20:27:17 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2012-05-19 20:27:17 +0000
commit46083b1d4d145e647f2c587216534c0be561c515 (patch)
tree5231aef435e1579ad193aa282072a166bd1883ad /games-util
parentUpdate HOMEPAGE and SRC_URI. #402045 by Florian Berger. (diff)
downloadgentoo-2-46083b1d4d145e647f2c587216534c0be561c515.tar.gz
gentoo-2-46083b1d4d145e647f2c587216534c0be561c515.tar.bz2
gentoo-2-46083b1d4d145e647f2c587216534c0be561c515.zip
build with gcc47 with patch from Nicolas Schlumberger via bug #413861
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'games-util')
-rw-r--r--games-util/catcodec/ChangeLog8
-rw-r--r--games-util/catcodec/catcodec-1.0.3.ebuild7
-rw-r--r--games-util/catcodec/files/catcodec-1.0.3-gcc47.patch24
3 files changed, 34 insertions, 5 deletions
diff --git a/games-util/catcodec/ChangeLog b/games-util/catcodec/ChangeLog
index 551fd0389f8c..9e916994ac51 100644
--- a/games-util/catcodec/ChangeLog
+++ b/games-util/catcodec/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-util/catcodec
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-util/catcodec/ChangeLog,v 1.9 2011/07/23 16:50:09 xarthisius Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-util/catcodec/ChangeLog,v 1.10 2012/05/19 20:27:17 mr_bones_ Exp $
+
+ 19 May 2012; Michael Sterrett <mr_bones_@gentoo.org> catcodec-1.0.3.ebuild,
+ +files/catcodec-1.0.3-gcc47.patch:
+ build with gcc47 with patch from Nicolas Schlumberger via bug #413861
23 Jul 2011; Kacper Kowalik <xarthisius@gentoo.org> catcodec-1.0.3.ebuild:
ppc/ppc64 stable wrt #375389
diff --git a/games-util/catcodec/catcodec-1.0.3.ebuild b/games-util/catcodec/catcodec-1.0.3.ebuild
index 993263948838..f91bc512fb97 100644
--- a/games-util/catcodec/catcodec-1.0.3.ebuild
+++ b/games-util/catcodec/catcodec-1.0.3.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-util/catcodec/catcodec-1.0.3.ebuild,v 1.4 2011/07/23 16:50:09 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-util/catcodec/catcodec-1.0.3.ebuild,v 1.5 2012/05/19 20:27:17 mr_bones_ Exp $
EAPI=2
-inherit toolchain-funcs
+inherit eutils toolchain-funcs
DESCRIPTION="Decodes and encodes sample catalogues for OpenTTD"
HOMEPAGE="http://www.openttd.org/en/download-catcodec"
@@ -16,6 +16,7 @@ IUSE=""
src_prepare() {
tc-export CXX
+ epatch "${FILESDIR}"/${P}-gcc47.patch
}
src_compile() {
diff --git a/games-util/catcodec/files/catcodec-1.0.3-gcc47.patch b/games-util/catcodec/files/catcodec-1.0.3-gcc47.patch
new file mode 100644
index 000000000000..a36546a43aab
--- /dev/null
+++ b/games-util/catcodec/files/catcodec-1.0.3-gcc47.patch
@@ -0,0 +1,24 @@
+diff -ruN src/io.cpp.orig src/io.cpp
+--- src/io.cpp.orig 2012-05-19 20:48:05.930777509 +0200
++++ src/io.cpp 2012-05-19 20:49:04.303822711 +0200
+@@ -20,6 +20,8 @@
+
+ /** @file io.cpp Implementation of reading/writing to files */
+
++#include <unistd.h>
++
+ #include "stdafx.h"
+ #include "io.hpp"
+
+diff -ruN src/catcodec.cpp.orig src/catcodec.cpp
+--- src/catcodec.cpp.orig 2012-05-19 20:47:55.847255343 +0200
++++ src/catcodec.cpp 2012-05-19 20:48:38.937144091 +0200
+@@ -22,6 +22,7 @@
+
+ #include <stdlib.h>
+ #include <string.h>
++#include <unistd.h>
+
+ #include "stdafx.h"
+ #include "io.hpp"
+