summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2007-12-26 00:12:19 +0000
committerAlfredo Tupone <tupone@gentoo.org>2007-12-26 00:12:19 +0000
commit98d4a11db259f339a7d7606a394941d6f4590dfa (patch)
tree739673e8585480698eeeee4dee6bfc4ebc83aeeb /games-util
parentRemoved orphaned ebuilds (diff)
downloadgentoo-2-98d4a11db259f339a7d7606a394941d6f4590dfa.tar.gz
gentoo-2-98d4a11db259f339a7d7606a394941d6f4590dfa.tar.bz2
gentoo-2-98d4a11db259f339a7d7606a394941d6f4590dfa.zip
Fix building with simgear 1.0.0 Bug #203303
(Portage version: 2.1.3.19)
Diffstat (limited to 'games-util')
-rw-r--r--games-util/atlas/ChangeLog6
-rw-r--r--games-util/atlas/atlas-0.3.1.ebuild11
-rw-r--r--games-util/atlas/files/atlas-0.3.1-simgearNew.patch31
3 files changed, 45 insertions, 3 deletions
diff --git a/games-util/atlas/ChangeLog b/games-util/atlas/ChangeLog
index 930add45e6db..48fc8f232ca5 100644
--- a/games-util/atlas/ChangeLog
+++ b/games-util/atlas/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-util/atlas
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-util/atlas/ChangeLog,v 1.13 2007/03/12 18:20:22 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-util/atlas/ChangeLog,v 1.14 2007/12/26 00:12:19 tupone Exp $
+
+ 26 Dec 2007; Tupone Alfredo <tupone@gentoo.org>
+ +files/atlas-0.3.1-simgearNew.patch, atlas-0.3.1.ebuild:
+ Fix building with simgear 1.0.0 Bug #203303 by Thomas Witt
12 Mar 2007; Marius Mauch <genone@gentoo.org> atlas-0.2.2-r1.ebuild,
atlas-0.3.0.ebuild, atlas-0.3.1.ebuild:
diff --git a/games-util/atlas/atlas-0.3.1.ebuild b/games-util/atlas/atlas-0.3.1.ebuild
index d90e2b7adc80..7f624fd9393c 100644
--- a/games-util/atlas/atlas-0.3.1.ebuild
+++ b/games-util/atlas/atlas-0.3.1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-util/atlas/atlas-0.3.1.ebuild,v 1.3 2007/04/06 04:31:18 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-util/atlas/atlas-0.3.1.ebuild,v 1.4 2007/12/26 00:12:19 tupone Exp $
-inherit eutils games
+inherit eutils autotools games
MY_P="Atlas-${PV}"
DESCRIPTION="Chart Program to use with Flightgear Flight Simulator"
@@ -22,6 +22,13 @@ DEPEND="games-simulation/flightgear
S=${WORKDIR}/${MY_P}
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-simgearNew.patch
+ eautoreconf
+}
+
src_compile() {
egamesconf --with-fgbase="${GAMES_DATADIR}"/FlightGear || die
emake || die "emake failed"
diff --git a/games-util/atlas/files/atlas-0.3.1-simgearNew.patch b/games-util/atlas/files/atlas-0.3.1-simgearNew.patch
new file mode 100644
index 000000000000..1f0492780f25
--- /dev/null
+++ b/games-util/atlas/files/atlas-0.3.1-simgearNew.patch
@@ -0,0 +1,31 @@
+--- src/Makefile.am.old 2007-12-26 00:41:52.000000000 +0100
++++ src/Makefile.am 2007-12-26 00:42:10.000000000 +0100
+@@ -23,7 +23,7 @@
+ Projection.cxx Projection.hxx
+
+ Atlas_LDADD = \
+- -lsgmagvar -lsgtiming -lsgmisc -lsgio -lsgserial -lsgdebug -lsgbucket\
++ -lsgmagvar -lsgtiming -lsgstructure -lsgmisc -lsgio -lsgserial -lsgdebug -lsgbucket\
+ -lsgxml -lplibsg -lplibpu -lplibul -lplibfnt -lplibnet \
+ $(opengl_LIBS) \
+ -lpng -lz -lpthread -ljpeg
+--- src/Makefile.am.old 2007-12-26 00:51:56.000000000 +0100
++++ src/Makefile.am 2007-12-26 00:52:37.000000000 +0100
+@@ -40,7 +40,7 @@
+ fg_mkdir.cxx fg_mkdir.hxx
+
+ Map_LDADD = \
+- -lsgmagvar -lsgtiming -lsgmisc -lsgio -lsgdebug \
++ -lsgmagvar -lsgtiming -lsgstructure -lsgmisc -lsgio -lsgdebug \
+ -lplibsg -lplibpu -lplibul -lplibfnt -lsgbucket -lsgscreen \
+ $(opengl_LIBS) \
+ -lpng -lz -ljpeg
+@@ -56,7 +56,7 @@
+ Scenery.cxx Scenery.hxx
+
+ MapPS_LDADD = \
+- -lsgmagvar -lsgtiming -lsgmisc -lsgio -lsgdebug \
++ -lsgmagvar -lsgtiming -lsgstructure -lsgmisc -lsgio -lsgdebug \
+ -lplibsg -lsgbucket \
+ -lpng -lz
+