summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorD.M.D. Ljungmark <spider@gentoo.org>2002-12-23 03:02:15 +0000
committerD.M.D. Ljungmark <spider@gentoo.org>2002-12-23 03:02:15 +0000
commit4aa788cf8b9b66183c64d191cec4d07f00737693 (patch)
tree3e8aa2113950e8815abce836b605d0c2458d3d97 /gnome-base/bonobo/bonobo-1.0.22.ebuild
parentRemoved sparc64 keyword (diff)
downloadgentoo-2-4aa788cf8b9b66183c64d191cec4d07f00737693.tar.gz
gentoo-2-4aa788cf8b9b66183c64d191cec4d07f00737693.tar.bz2
gentoo-2-4aa788cf8b9b66183c64d191cec4d07f00737693.zip
The most horrible xmas ever.... gives you bonobo
Diffstat (limited to 'gnome-base/bonobo/bonobo-1.0.22.ebuild')
-rw-r--r--gnome-base/bonobo/bonobo-1.0.22.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/gnome-base/bonobo/bonobo-1.0.22.ebuild b/gnome-base/bonobo/bonobo-1.0.22.ebuild
new file mode 100644
index 000000000000..18d78b60d738
--- /dev/null
+++ b/gnome-base/bonobo/bonobo-1.0.22.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/bonobo/bonobo-1.0.22.ebuild,v 1.1 2002/12/23 03:02:15 spider Exp $
+
+IUSE="nls"
+
+inherit gnome.org libtool
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="A set of language and system independant CORBA interfaces"
+HOMEPAGE="http://www.gnome.org/"
+
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~sparc64"
+LICENSE="GPL-2"
+
+RDEPEND=">=gnome-base/oaf-0.6.8
+ >=gnome-base/ORBit-0.5.13
+ >=gnome-base/gnome-print-0.30"
+
+DEPEND="${RDEPEND}
+ sys-devel/perl
+ nls? ( sys-devel/gettext
+ >=dev-util/intltool-0.11 )"
+
+src_compile() {
+ #libtoolize to fix relink bug
+ elibtoolize
+
+ local myconf=""
+ use nls || myconf="${myconf} --disable-nls"
+
+ econf ${myconf} || die
+
+ make || die # make -j 4 didn't work
+}
+
+src_install() {
+ einstall || die
+
+ dodoc AUTHORS COPYING* ChangeLog README NEWS TODO
+}
+