summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Gryniewicz <dang@gentoo.org>2006-07-10 01:30:00 +0000
committerDaniel Gryniewicz <dang@gentoo.org>2006-07-10 01:30:00 +0000
commit84c922151d28a0017017f0c770e46bbea8158df5 (patch)
treeb985e17df83b43343ffc739c1c12c39c5fc10a98 /gnome-base/control-center
parentMask >=media-sound/bmpx-0.20 until bug #139488 can be sorted out. (diff)
downloadgentoo-2-84c922151d28a0017017f0c770e46bbea8158df5.tar.gz
gentoo-2-84c922151d28a0017017f0c770e46bbea8158df5.tar.bz2
gentoo-2-84c922151d28a0017017f0c770e46bbea8158df5.zip
Backport of fix from 2.14 for bug #139413
(Portage version: 2.1.1_pre2-r4)
Diffstat (limited to 'gnome-base/control-center')
-rw-r--r--gnome-base/control-center/ChangeLog9
-rw-r--r--gnome-base/control-center/control-center-2.12.3-r1.ebuild99
-rw-r--r--gnome-base/control-center/files/control-center-2.12.3-buttons.patch69
-rw-r--r--gnome-base/control-center/files/digest-control-center-2.12.3-r13
4 files changed, 179 insertions, 1 deletions
diff --git a/gnome-base/control-center/ChangeLog b/gnome-base/control-center/ChangeLog
index c1ed616d73ad..5528611e8f52 100644
--- a/gnome-base/control-center/ChangeLog
+++ b/gnome-base/control-center/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for gnome-base/control-center
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/control-center/ChangeLog,v 1.184 2006/06/30 18:08:47 allanonjl Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/control-center/ChangeLog,v 1.185 2006/07/10 01:30:00 dang Exp $
+
+*control-center-2.12.3-r1 (10 Jul 2006)
+
+ 10 Jul 2006; Daniel Gryniewicz <dang@gentoo.org>
+ +files/control-center-2.12.3-buttons.patch,
+ +control-center-2.12.3-r1.ebuild:
+ Backport of fix from 2.14 for bug #139413
*control-center-2.14.2 (30 Jun 2006)
diff --git a/gnome-base/control-center/control-center-2.12.3-r1.ebuild b/gnome-base/control-center/control-center-2.12.3-r1.ebuild
new file mode 100644
index 000000000000..6fd1ddc319a9
--- /dev/null
+++ b/gnome-base/control-center/control-center-2.12.3-r1.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/control-center/control-center-2.12.3-r1.ebuild,v 1.1 2006/07/10 01:30:00 dang Exp $
+
+inherit eutils gnome2 autotools
+
+DESCRIPTION="The gnome2 Desktop configuration tool"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="alpha amd64 ~arm hppa ia64 ~mips ppc ppc64 sparc x86"
+IUSE="alsa eds gstreamer"
+
+RDEPEND=">=gnome-base/gnome-vfs-2.2
+ >=media-libs/fontconfig-1
+ virtual/xft
+ || ( ( x11-libs/libXxf86misc
+ x11-apps/xinit
+ x11-apps/xset )
+ virtual/x11 )
+ >=x11-libs/gtk+-2.6
+ >=gnome-base/libbonobo-2
+ >=gnome-base/libgnomeui-2.2
+ >=gnome-base/nautilus-2.6
+ >=gnome-base/gconf-2
+ >=gnome-base/libglade-2
+ >=gnome-base/libbonoboui-2.2
+ >=gnome-base/gnome-desktop-2.2
+ >=gnome-base/gnome-menus-2.11.1
+ media-sound/esound
+ >=x11-wm/metacity-2.8.6-r1
+ >=x11-libs/libxklavier-1.14
+ >=dev-libs/glib-2.5
+ >=gnome-base/libgnome-2.2
+ media-libs/freetype
+ >=gnome-base/orbit-2.12.4
+ eds? ( >=gnome-extra/evolution-data-server-1.3 )
+ !arm? ( alsa? ( >=media-libs/alsa-lib-0.9 ) )
+ gstreamer? ( =media-libs/gst-plugins-0.8* )"
+
+DEPEND="${RDEPEND}
+ || ( (
+ x11-libs/libxkbfile
+ x11-proto/xf86miscproto
+ x11-proto/scrnsaverproto )
+ virtual/x11 )
+ app-text/scrollkeeper
+ >=dev-util/pkgconfig-0.9
+ >=dev-util/intltool-0.28
+ >=app-text/gnome-doc-utils-0.3.2
+ dev-util/desktop-file-utils"
+
+DOCS="AUTHORS ChangeLog NEWS README TODO"
+USE_DESTDIR="1"
+
+MAKEOPTS="${MAKEOPTS} -j1"
+
+
+pkg_setup() {
+ G2CONF="--disable-schemas-install \
+ --disable-scrollkeeper \
+ --enable-vfs-methods \
+ $(use_enable alsa) \
+ $(use_enable gstreamer) \
+ $(use_enable eds aboutme)"
+}
+
+src_unpack() {
+ unpack "${A}"
+ cd "${S}"
+
+ # Temporary workaround for a problematic behaviour with acme.
+ epatch ${FILESDIR}/${PN}-2.6.0-remove-pmu.patch
+
+ # Fix the logout keyboard shortcut by moving it out of
+ # the control-center here, and into metacity, bug #52034
+ epatch ${FILESDIR}/${PN}-2.9-logout.patch
+
+ # Fix the hardcoding of tar, bzip2, and gzip paths in
+ # gnome-theme-installer. bug #84977
+ epatch ${FILESDIR}/${PN}-2.12.2-pathfix.patch
+
+ # Gentoo-specific support for xcursor themes. See bug #103638.
+ epatch ${FILESDIR}/${PN}-2.11-gentoo_xcursor.patch
+
+ # Fix for -Wextra gcc error #114533
+ epatch ${FILESDIR}/${PN}-2.12.2-gcc-Wextra.patch
+
+ # Fix for buttons. Bug #139413
+ epatch ${FILESDIR}/${P}-buttons.patch
+
+ aclocal || die
+ _elibtoolize --force --copy || die
+ eautoheader || die
+ eautomake || die
+ intltoolize --force || die
+ eautoconf || die
+}
diff --git a/gnome-base/control-center/files/control-center-2.12.3-buttons.patch b/gnome-base/control-center/files/control-center-2.12.3-buttons.patch
new file mode 100644
index 000000000000..624a15861a69
--- /dev/null
+++ b/gnome-base/control-center/files/control-center-2.12.3-buttons.patch
@@ -0,0 +1,69 @@
+diff --exclude-from=/home/dang/.diffrc -u -ruN control-center-2.12.3.orig/gnome-settings-daemon/gnome-settings-mouse.c control-center-2.12.3/gnome-settings-daemon/gnome-settings-mouse.c
+--- control-center-2.12.3.orig/gnome-settings-daemon/gnome-settings-mouse.c 2005-11-02 06:49:32.000000000 -0500
++++ control-center-2.12.3/gnome-settings-daemon/gnome-settings-mouse.c 2006-07-06 20:57:23.000000000 -0400
+@@ -33,24 +33,57 @@
+ gint n_buttons,
+ gboolean left_handed)
+ {
+- const gint left_button = 0;
++ const gint left_button = 1;
+ gint right_button;
++ gint i;
+
+ /* if the button is higher than 2 (3rd button) then it's
+ * probably one direction of a scroll wheel or something else
+ * uninteresting
+ */
+- right_button = MIN (n_buttons - 1, 2);
++ right_button = MIN (n_buttons, 3);
++
++ /* If we change things we need to make sure we only swap buttons.
++ * If we end up with multiple physical buttons assigned to the same
++ * logical button the server will complain. This code assumes physical
++ * button 0 is the physical left mouse button, and that the physical
++ * button other than 0 currently assigned left_button or right_button
++ * is the physical right mouse button.
++ */
++
++ /* check if the current mapping satisfies the above assumptions */
++ if (buttons[left_button - 1] != left_button &&
++ buttons[left_button - 1] != right_button)
++ /* The current mapping is weird. Swapping buttons is probably not a
++ * good idea.
++ */
++ return;
+
+- if (left_handed)
++ /* check if we are left_handed and currently not swapped */
++ if (left_handed && buttons[left_button - 1] == left_button)
+ {
+- buttons[left_button] = right_button + 1;
+- buttons[right_button] = left_button + 1;
++ /* find the right button */
++ for (i = 0; i < n_buttons; i++)
++ {
++ if (buttons[i] == right_button)
++ break;
++ }
++ /* swap the buttons */
++ buttons[left_button - 1] = right_button;
++ buttons[i] = left_button;
+ }
+- else
++ /* check if we are not left_handed but are swapped */
++ else if (!left_handed && buttons[left_button - 1] == right_button)
+ {
+- buttons[left_button] = left_button + 1;
+- buttons[right_button] = right_button + 1;
++ /* find the right button */
++ for (i = 0; i < n_buttons; i++)
++ {
++ if (buttons[i] == left_button)
++ break;
++ }
++ /* swap the buttons */
++ buttons[i] = right_button;
++ buttons[left_button - 1] = left_button;
+ }
+ }
+
diff --git a/gnome-base/control-center/files/digest-control-center-2.12.3-r1 b/gnome-base/control-center/files/digest-control-center-2.12.3-r1
new file mode 100644
index 000000000000..9c0a9841aa8a
--- /dev/null
+++ b/gnome-base/control-center/files/digest-control-center-2.12.3-r1
@@ -0,0 +1,3 @@
+MD5 e8f57ec1852d08d421016732b605a615 control-center-2.12.3.tar.bz2 1787009
+RMD160 615d843d1050570a7a7ba54abfa8888608c983d9 control-center-2.12.3.tar.bz2 1787009
+SHA256 c25fd622f737037aa71c44dc9cdc3a1e9248408938e7fdfbbb60eba18c1192d8 control-center-2.12.3.tar.bz2 1787009