summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRomain Perier <mrpouet@gentoo.org>2010-04-03 13:45:02 +0000
committerRomain Perier <mrpouet@gentoo.org>2010-04-03 13:45:02 +0000
commitd12ab90d482beb20bfae33ba6044e06753da574c (patch)
tree1f93065c562684c5cbb32e0b33cade4595e8f83b /gnome-base/gconf
parentVersion bump with many changes and deprecations. (diff)
downloadgentoo-2-d12ab90d482beb20bfae33ba6044e06753da574c.tar.gz
gentoo-2-d12ab90d482beb20bfae33ba6044e06753da574c.tar.bz2
gentoo-2-d12ab90d482beb20bfae33ba6044e06753da574c.zip
Version bump, bugsfixes + translations updated.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'gnome-base/gconf')
-rw-r--r--gnome-base/gconf/ChangeLog7
-rw-r--r--gnome-base/gconf/gconf-2.28.1.ebuild107
2 files changed, 113 insertions, 1 deletions
diff --git a/gnome-base/gconf/ChangeLog b/gnome-base/gconf/ChangeLog
index dfdcf4d93065..94c67214e681 100644
--- a/gnome-base/gconf/ChangeLog
+++ b/gnome-base/gconf/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for gnome-base/gconf
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gconf/ChangeLog,v 1.223 2010/03/10 08:54:12 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gconf/ChangeLog,v 1.224 2010/04/03 13:45:02 mrpouet Exp $
+
+*gconf-2.28.1 (03 Apr 2010)
+
+ 03 Apr 2010; Romain Perier <mrpouet@gentoo.org> +gconf-2.28.1.ebuild:
+ Version bump, bugsfixes + translations updated.
10 Mar 2010; Joseph Jezak <josejx@gentoo.org> gconf-2.28.0-r1.ebuild:
Marked ~ppc/~ppc64 for bug #296548.
diff --git a/gnome-base/gconf/gconf-2.28.1.ebuild b/gnome-base/gconf/gconf-2.28.1.ebuild
new file mode 100644
index 000000000000..627ebbf81299
--- /dev/null
+++ b/gnome-base/gconf/gconf-2.28.1.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gconf/gconf-2.28.1.ebuild,v 1.1 2010/04/03 13:45:02 mrpouet Exp $
+
+EAPI="2"
+
+inherit eutils gnome2
+
+MY_PN=GConf
+MY_P=${MY_PN}-${PV}
+PVP=(${PV//[-\._]/ })
+
+DESCRIPTION="Gnome Configuration System and Daemon"
+HOMEPAGE="http://www.gnome.org/"
+SRC_URI="mirror://gnome/sources/${MY_PN}/${PVP[0]}.${PVP[1]}/${MY_P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug doc ldap policykit"
+
+RDEPEND=">=dev-libs/glib-2.14
+ >=x11-libs/gtk+-2.14
+ >=dev-libs/dbus-glib-0.74
+ >=sys-apps/dbus-1
+ >=gnome-base/orbit-2.4
+ >=dev-libs/libxml2-2
+ ldap? ( net-nds/openldap )
+ policykit? ( sys-auth/polkit )"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.35
+ >=dev-util/pkgconfig-0.9
+ >=dev-util/gtk-doc-am-1.10
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+DOCS="AUTHORS ChangeLog NEWS README TODO"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --enable-gtk
+ --disable-static
+ $(use_with ldap openldap)
+ $(use_enable policykit defaults-service)"
+ kill_gconf
+
+ # Need host's IDL compiler for cross or native build, bug #262747
+ export EXTRA_EMAKE="${EXTRA_EMAKE} ORBIT_IDL=/usr/bin/orbit-idl-2"
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Do not start gconfd when installing schemas, fix bug #238276, upstream ?
+ epatch "${FILESDIR}/${PN}-2.24.0-no-gconfd.patch"
+
+ # Do not crash in gconf_entry_set_value() when entry pointer is NULL
+ epatch "${FILESDIR}/${PN}-2.28.0-entry-set-value-sigsegv.patch"
+
+ # Fix intltoolize broken file, see upstream #577133
+ sed "s:'\^\$\$lang\$\$':\^\$\$lang\$\$:g" -i po/Makefile.in.in || die "sed failed"
+}
+
+# Can't run tests, missing script.
+#src_test() {
+# emake -C tests || die "make tests failed"
+# sh "${S}"/tests/runtests.sh || die "running tests failed"
+#}
+
+src_install() {
+ gnome2_src_install
+
+ keepdir /etc/gconf/gconf.xml.mandatory
+ keepdir /etc/gconf/gconf.xml.defaults
+ # Make sure this directory exists, bug #268070, upstream #572027
+ keepdir /etc/gconf/gconf.xml.system
+
+ echo 'CONFIG_PROTECT_MASK="/etc/gconf"' > 50gconf
+ doenvd 50gconf || die "doenv failed"
+ dodir /root/.gconfd
+}
+
+pkg_preinst() {
+ kill_gconf
+}
+
+pkg_postinst() {
+ kill_gconf
+
+ # change the permissions to avoid some gconf bugs
+ einfo "changing permissions for gconf dirs"
+ find /etc/gconf/ -type d -exec chmod ugo+rx "{}" \;
+
+ einfo "changing permissions for gconf files"
+ find /etc/gconf/ -type f -exec chmod ugo+r "{}" \;
+}
+
+kill_gconf() {
+ # This function will kill all running gconfd-2 that could be causing troubles
+ if [ -x /usr/bin/gconftool-2 ]
+ then
+ /usr/bin/gconftool-2 --shutdown
+ fi
+
+ return 0
+}