summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikael Hallendal <hallski@gentoo.org>2001-08-31 21:50:33 +0000
committerMikael Hallendal <hallski@gentoo.org>2001-08-31 21:50:33 +0000
commitddfb094f50ded2e421f571756ff84520e1aa0a75 (patch)
tree7960c12a33db16850ff6447442b72f98450e63b6 /gnome-base/gconf
parentstructure cleanup (diff)
downloadgentoo-2-ddfb094f50ded2e421f571756ff84520e1aa0a75.tar.gz
gentoo-2-ddfb094f50ded2e421f571756ff84520e1aa0a75.tar.bz2
gentoo-2-ddfb094f50ded2e421f571756ff84520e1aa0a75.zip
structure cleanup
Diffstat (limited to 'gnome-base/gconf')
-rw-r--r--gnome-base/gconf/gconf-1.0.1.ebuild38
-rw-r--r--gnome-base/gconf/gconf-1.0.4.ebuild36
2 files changed, 29 insertions, 45 deletions
diff --git a/gnome-base/gconf/gconf-1.0.1.ebuild b/gnome-base/gconf/gconf-1.0.1.ebuild
index 924daf3d7194..f1b5e5452472 100644
--- a/gnome-base/gconf/gconf-1.0.1.ebuild
+++ b/gnome-base/gconf/gconf-1.0.1.ebuild
@@ -24,32 +24,30 @@ RDEPEND=">=sys-libs/db-3.2.3h
>=gnome-base/gnome-libs-1.2.10"
src_unpack() {
- unpack ${A}
- # for some reason, the GConf package doesn't come w/ an intl directory,
- # so I copied it from another package, and made a diff
- cd ${S}
- try patch -p1 < ${FILESDIR}/${PF}-gentoo-intl.diff
+ unpack ${A}
+ # for some reason, the GConf package doesn't come w/ an intl
+ # directory, so I copied it from another package, and made a diff
+
+ cd ${S}
+ patch -p1 < ${FILESDIR}/${PF}-gentoo-intl.diff || die
}
src_compile() {
+ local myconf
+
+ if [ -z "`use nls`" ]
+ then
+ myconf="--disable-nls"
+ fi
+
+ ./configure --host=${CHOST} --prefix=/opt/gnome \
+ --sysconfdir=/etc/opt/gnome ${myconf} || die
- local myconf
- if [ -z "`use nls`" ]
- then
- myconf="--disable-nls"
- fi
- try ./configure --host=${CHOST} --prefix=/opt/gnome --sysconfdir=/etc/opt/gnome ${myconf}
- try make # Doesn't work with -j 4 (hallski)
+ make || die # Doesn't work with -j 4 (hallski)
}
src_install() {
+ make DESTDIR=${D} install || die
- try make DESTDIR=${D} install
- dodoc AUTHORS COPYING ChangeLog NEWS README* TODO
-
+ dodoc AUTHORS COPYING ChangeLog NEWS README* TODO
}
-
-
-
-
-
diff --git a/gnome-base/gconf/gconf-1.0.4.ebuild b/gnome-base/gconf/gconf-1.0.4.ebuild
index 266d72b9f984..51df70fabc74 100644
--- a/gnome-base/gconf/gconf-1.0.4.ebuild
+++ b/gnome-base/gconf/gconf-1.0.4.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gconf/gconf-1.0.4.ebuild,v 1.2 2001/08/23 10:08:55 hallski Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gconf/gconf-1.0.4.ebuild,v 1.3 2001/08/31 21:50:33 hallski Exp $
P=GConf-${PV}
A=${P}.tar.gz
@@ -23,36 +23,22 @@ RDEPEND=">=sys-libs/db-3.2.3h
>=gnome-base/oaf-0.6.5
>=gnome-base/gnome-libs-1.2.10"
-#src_unpack() {
-# unpack ${A}
- # for some reason, the GConf package doesn't come w/ an intl directory,
- # so I copied it from another package, and made a diff
-# cd ${S}
-# try patch -p1 < ${FILESDIR}/${PF}-gentoo-intl.diff
-#}
-
src_compile() {
+ local myconf
- local myconf
-
- if [ -z "`use nls`" ]
- then
- myconf="--disable-nls"
- fi
+ if [ -z "`use nls`" ]
+ then
+ myconf="--disable-nls"
+ fi
- ./configure --host=${CHOST} --prefix=/opt/gnome --sysconfdir=/etc/opt/gnome ${myconf} || die
+ ./configure --host=${CHOST} --prefix=/opt/gnome \
+ --sysconfdir=/etc/opt/gnome ${myconf} || die
- make || die # Doesn't work with -j 4 (hallski)
+ make || die # Doesn't work with -j 4 (hallski)
}
src_install() {
+ make DESTDIR=${D} install || die
- make DESTDIR=${D} install || die
- dodoc AUTHORS COPYING ChangeLog NEWS README* TODO
-
+ dodoc AUTHORS COPYING ChangeLog NEWS README* TODO
}
-
-
-
-
-