summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2012-05-14 00:16:46 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2012-05-14 00:16:46 +0000
commit5a8225aceaf163e1bc6bb3c2460638d92fe72828 (patch)
treeb21a06c0593ae257251ec912d8ec846578329e5d /gnome-base/gdm/files
parentVersion bump for gnome-3.4 (diff)
downloadgentoo-2-5a8225aceaf163e1bc6bb3c2460638d92fe72828.tar.gz
gentoo-2-5a8225aceaf163e1bc6bb3c2460638d92fe72828.tar.bz2
gentoo-2-5a8225aceaf163e1bc6bb3c2460638d92fe72828.zip
Version bump for gnome-3.4. Adds optional (and untested) support for systemd session tracking and smooth transition from plymouth.
(Portage version: 2.2.0_alpha104/cvs/Linux x86_64)
Diffstat (limited to 'gnome-base/gdm/files')
-rw-r--r--gnome-base/gdm/files/gdm-3.3.92.1-disable-accessibility.patch30
-rw-r--r--gnome-base/gdm/files/gdm-3.4.1-plymouth.patch338
-rw-r--r--gnome-base/gdm/files/gdm-3.4.1-save-root-window.patch141
3 files changed, 509 insertions, 0 deletions
diff --git a/gnome-base/gdm/files/gdm-3.3.92.1-disable-accessibility.patch b/gnome-base/gdm/files/gdm-3.3.92.1-disable-accessibility.patch
new file mode 100644
index 000000000000..1df7e583e675
--- /dev/null
+++ b/gnome-base/gdm/files/gdm-3.3.92.1-disable-accessibility.patch
@@ -0,0 +1,30 @@
+diff -Naur gdm-3.3.92.1//data/00-upstream-settings gdm-3.3.92.1.new//data/00-upstream-settings
+--- gdm-3.3.92.1//data/00-upstream-settings 2012-02-08 04:50:32.000000000 +0530
++++ gdm-3.3.92.1.new//data/00-upstream-settings 2012-03-25 14:24:01.387842352 +0530
+@@ -7,7 +7,7 @@
+ #
+
+ [org/gnome/desktop/a11y/keyboard]
+-enable=true
++enable=false
+
+ [org/gnome/desktop/background]
+ show-desktop-icons=false
+@@ -16,7 +16,7 @@
+ exec='/bin/true'
+
+ [org/gnome/desktop/interface]
+-toolkit-accessibility=true
++toolkit-accessibility=false
+
+ [org/gnome/desktop/lockdown]
+ disable-application-handlers=true
+@@ -35,7 +35,7 @@
+ event-sounds=true
+
+ [org/gnome/settings-daemon/plugins/a11y-keyboard]
+-active=true
++active=false
+
+ [org/gnome/settings-daemon/plugins/a11y-settings]
+ active=false
diff --git a/gnome-base/gdm/files/gdm-3.4.1-plymouth.patch b/gnome-base/gdm/files/gdm-3.4.1-plymouth.patch
new file mode 100644
index 000000000000..edd6220c8b5b
--- /dev/null
+++ b/gnome-base/gdm/files/gdm-3.4.1-plymouth.patch
@@ -0,0 +1,338 @@
+From c56fbb65277e8a17db5e0939f0b02e41c4ec784c Mon Sep 17 00:00:00 2001
+From: Ray Strode <rstrode@redhat.com>
+Date: Fri, 27 Nov 2009 18:52:54 -0500
+Subject: [PATCH] daemon: enable smooth transition between plymouth and X
+
+This commit adds optional support for interacting with plymouth
+from gdm. This feature can be enabled by passing --with-plymouth
+to configure.
+
+Hopefully, this will enable the various distributions that use
+plymouth to drop a patch.
+
+https://bugzilla.gnome.org/show_bug.cgi?id=572173
+---
+ configure.ac | 32 +++++++++++++
+ daemon/gdm-server.c | 60 +++++++++++++++++++++++++
+ daemon/gdm-server.h | 3 +
+ daemon/gdm-simple-slave.c | 106 ++++++++++++++++++++++++++++++++++++++++++++-
+ 4 files changed, 200 insertions(+), 1 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 35e6e04..81ea23e 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -264,6 +264,10 @@ AC_ARG_WITH(systemd,
+ AS_HELP_STRING([--with-systemd],
+ [Add systemd support @<:@default=auto@:>@]),
+ [with_systemd=$withval], [with_systemd=auto])
++AC_ARG_WITH(plymouth,
++ AS_HELP_STRING([--with-plymouth],
++ [Add plymouth support @<:@default=auto@:>@]),
++ [with_plymouth=$withval], [with_plymouth=auto])
+
+ AC_ARG_WITH(at-spi-registryd-directory,
+ AS_HELP_STRING([--with-at-spi-registryd-directory],
+@@ -952,6 +956,33 @@ AC_SUBST(SYSTEMD_X_SERVER)
+ AC_DEFINE_UNQUOTED(SYSTEMD_X_SERVER,"$SYSTEMD_X_SERVER",[Path to systemd X server wrapper])
+
+ dnl ---------------------------------------------------------------------------
++dnl - Check for plymouth support
++dnl ---------------------------------------------------------------------------
++PKG_CHECK_MODULES(PLYMOUTH,
++ [ply-boot-client],
++ [have_plymouth=yes], [have_plymouth=no])
++
++if test "x$with_plymouth" = "xauto" ; then
++ if test x$have_plymouth = xno ; then
++ use_plymouth=no
++ else
++ use_plymouth=yes
++ fi
++else
++ use_plymouth="$with_plymouth"
++fi
++
++if test "x$use_plymouth" != "xno" ; then
++ if test "x$have_plymouth" = "xno"; then
++ AC_MSG_ERROR([Plymouth support explicitly required, but plymouth not found])
++ fi
++
++ AC_DEFINE(WITH_PLYMOUTH, 1, [Define to enable plymouth support])
++fi
++AC_SUBST(PLYMOUTH_CFLAGS)
++AC_SUBST(PLYMOUTH_LIBS)
++
++dnl ---------------------------------------------------------------------------
+ dnl - Check for D-Bus
+ dnl ---------------------------------------------------------------------------
+
+@@ -1537,6 +1568,7 @@ echo \
+ SELinux support: ${with_selinux}
+ ConsoleKit support: ${use_console_kit}
+ systemd support: ${use_systemd}
++ plymouth support: ${use_plymouth}
+ UPower support: ${have_upower}
+ Build with RBAC: ${msg_rbac_shutdown}
+ "
+diff --git a/daemon/gdm-server.c b/daemon/gdm-server.c
+index d0d8ff9..6f2a939 100644
+--- a/daemon/gdm-server.c
++++ b/daemon/gdm-server.c
+@@ -32,6 +32,7 @@
+ #include <pwd.h>
+ #include <grp.h>
+ #include <signal.h>
++#include <sys/ioctl.h>
+ #include <sys/resource.h>
+
+ #ifdef HAVE_SYS_PRCTL_H
+@@ -42,6 +43,10 @@
+ #include <systemd/sd-daemon.h>
+ #endif
+
++#ifdef WITH_PLYMOUTH
++#include <linux/vt.h>
++#endif
++
+ #include <glib.h>
+ #include <glib/gi18n.h>
+ #include <glib/gstdio.h>
+@@ -751,6 +756,61 @@ gdm_server_spawn (GdmServer *server,
+ return ret;
+ }
+
++#ifdef WITH_PLYMOUTH
++static int
++get_active_vt (void)
++{
++ int console_fd;
++ struct vt_stat console_state = { 0 };
++
++ console_fd = open ("/dev/tty0", O_RDONLY | O_NOCTTY);
++
++ if (console_fd < 0) {
++ goto out;
++ }
++
++ if (ioctl (console_fd, VT_GETSTATE, &console_state) < 0) {
++ goto out;
++ }
++
++out:
++ if (console_fd >= 0) {
++ close (console_fd);
++ }
++
++ return console_state.v_active;
++}
++
++static char *
++get_active_vt_as_string (void)
++{
++ int vt;
++
++ vt = get_active_vt ();
++
++ if (vt <= 0) {
++ return NULL;
++ }
++
++ return g_strdup_printf ("vt%d", vt);
++}
++
++gboolean
++gdm_server_start_on_active_vt (GdmServer *server)
++{
++ gboolean res;
++ char *vt;
++
++ g_free (server->priv->command);
++ server->priv->command = g_strdup (X_SERVER " -background none -logverbose 7");
++ vt = get_active_vt_as_string ();
++ res = gdm_server_spawn (server, vt);
++ g_free (vt);
++
++ return res;
++}
++#endif
++
+ /**
+ * gdm_server_start:
+ * @disp: Pointer to a GdmDisplay structure
+diff --git a/daemon/gdm-server.h b/daemon/gdm-server.h
+index b53d68e..827f7fa 100644
+--- a/daemon/gdm-server.h
++++ b/daemon/gdm-server.h
+@@ -57,6 +57,9 @@ GdmServer * gdm_server_new (const char *display_id,
+ const char *seat_id,
+ const char *auth_file);
+ gboolean gdm_server_start (GdmServer *server);
++#ifdef HAVE_PLYMOUTH
++gboolean gdm_server_start_on_active_vt (GdmServer *server);
++#endif
+ gboolean gdm_server_stop (GdmServer *server);
+ char * gdm_server_get_display_device (GdmServer *server);
+
+diff --git a/daemon/gdm-simple-slave.c b/daemon/gdm-simple-slave.c
+index fc8649c..7c709a6 100644
+--- a/daemon/gdm-simple-slave.c
++++ b/daemon/gdm-simple-slave.c
+@@ -93,6 +93,9 @@ struct GdmSimpleSlavePrivate
+ #ifdef HAVE_LOGINDEVPERM
+ gboolean use_logindevperm;
+ #endif
++#ifdef WITH_PLYMOUTH
++ guint plymouth_is_running : 1;
++#endif
+ };
+
+ enum {
+@@ -1204,6 +1207,74 @@ on_start_session_later (GdmGreeterServer *session,
+ slave->priv->start_session_when_ready = FALSE;
+ }
+
++#ifdef WITH_PLYMOUTH
++static gboolean
++plymouth_is_running (void)
++{
++ int status;
++ gboolean res;
++ GError *error;
++
++ error = NULL;
++ res = g_spawn_command_line_sync ("/bin/plymouth --ping",
++ NULL, NULL, &status, &error);
++ if (! res) {
++ g_debug ("Could not ping plymouth: %s", error->message);
++ g_error_free (error);
++ return FALSE;
++ }
++
++ return WIFEXITED (status) && WEXITSTATUS (status) == 0;
++}
++
++static void
++plymouth_prepare_for_transition (GdmSimpleSlave *slave)
++{
++ gboolean res;
++ GError *error;
++
++ error = NULL;
++ res = g_spawn_command_line_sync ("/bin/plymouth deactivate",
++ NULL, NULL, NULL, &error);
++ if (! res) {
++ g_warning ("Could not deactivate plymouth: %s", error->message);
++ g_error_free (error);
++ }
++}
++
++static void
++plymouth_quit_with_transition (GdmSimpleSlave *slave)
++{
++ gboolean res;
++ GError *error;
++
++ error = NULL;
++ res = g_spawn_command_line_sync ("/bin/plymouth quit --retain-splash",
++ NULL, NULL, NULL, &error);
++ if (! res) {
++ g_warning ("Could not quit plymouth: %s", error->message);
++ g_error_free (error);
++ }
++ slave->priv->plymouth_is_running = FALSE;
++}
++
++static void
++plymouth_quit_without_transition (GdmSimpleSlave *slave)
++{
++ gboolean res;
++ GError *error;
++
++ error = NULL;
++ res = g_spawn_command_line_sync ("/bin/plymouth quit",
++ NULL, NULL, NULL, &error);
++ if (! res) {
++ g_warning ("Could not quit plymouth: %s", error->message);
++ g_error_free (error);
++ }
++ slave->priv->plymouth_is_running = FALSE;
++}
++#endif
++
+ static void
+ setup_server (GdmSimpleSlave *slave)
+ {
+@@ -1223,6 +1294,12 @@ setup_server (GdmSimpleSlave *slave)
+ */
+ gdm_slave_save_root_windows (GDM_SLAVE (slave));
+
++#ifdef WITH_PLYMOUTH
++ /* Plymouth is waiting for the go-ahead to exit */
++ if (slave->priv->plymouth_is_running) {
++ plymouth_quit_with_transition (slave);
++ }
++#endif
+ }
+
+ static void
+@@ -1426,6 +1503,12 @@ on_server_exited (GdmServer *server,
+ g_debug ("GdmSimpleSlave: server exited with code %d\n", exit_code);
+
+ gdm_slave_stopped (GDM_SLAVE (slave));
++
++#ifdef WITH_PLYMOUTH
++ if (slave->priv->plymouth_is_running) {
++ plymouth_quit_without_transition (slave);
++ }
++#endif
+ }
+
+ static void
+@@ -1438,6 +1521,12 @@ on_server_died (GdmServer *server,
+ g_strsignal (signal_number));
+
+ gdm_slave_stopped (GDM_SLAVE (slave));
++
++#ifdef WITH_PLYMOUTH
++ if (slave->priv->plymouth_is_running) {
++ plymouth_quit_without_transition (slave);
++ }
++#endif
+ }
+
+ static gboolean
+@@ -1484,7 +1573,17 @@ gdm_simple_slave_run (GdmSimpleSlave *slave)
+ G_CALLBACK (on_server_ready),
+ slave);
+
+- res = gdm_server_start (slave->priv->server);
++#ifdef WITH_PLYMOUTH
++ slave->priv->plymouth_is_running = plymouth_is_running ();
++
++ if (slave->priv->plymouth_is_running) {
++ plymouth_prepare_for_transition (slave);
++ res = gdm_server_start_on_active_vt (slave->priv->server);
++ } else
++#endif
++ {
++ res = gdm_server_start (slave->priv->server);
++ }
+ if (! res) {
+ g_warning (_("Could not start the X "
+ "server (your graphical environment) "
+@@ -1494,6 +1593,11 @@ gdm_simple_slave_run (GdmSimpleSlave *slave)
+ "In the meantime this display will be "
+ "disabled. Please restart GDM when "
+ "the problem is corrected."));
++#ifdef WITH_PLYMOUTH
++ if (slave->priv->plymouth_is_running) {
++ plymouth_quit_without_transition (slave);
++ }
++#endif
+ exit (1);
+ }
+
+--
+1.7.8.6
+
diff --git a/gnome-base/gdm/files/gdm-3.4.1-save-root-window.patch b/gnome-base/gdm/files/gdm-3.4.1-save-root-window.patch
new file mode 100644
index 000000000000..2d9c3148be11
--- /dev/null
+++ b/gnome-base/gdm/files/gdm-3.4.1-save-root-window.patch
@@ -0,0 +1,141 @@
+From c93d98b646a9a4fce3052260a1f08808d62d7155 Mon Sep 17 00:00:00 2001
+From: Ray Strode <rstrode@redhat.com>
+Date: Fri, 27 Nov 2009 18:27:53 -0500
+Subject: [PATCH] daemon: save root window to pixmap at _XROOTPMAP_ID
+
+This combined with starting the X server with
+-background none will give distros using plymouth
+(or potentially other boot splashes) a a nice fade
+transition when g-s-d starts.
+
+https://bugzilla.gnome.org/show_bug.cgi?id=572173
+---
+ daemon/gdm-simple-slave.c | 8 +++++
+ daemon/gdm-slave.c | 72 +++++++++++++++++++++++++++++++++++++++++++++
+ daemon/gdm-slave.h | 1 +
+ 3 files changed, 81 insertions(+), 0 deletions(-)
+
+diff --git a/daemon/gdm-simple-slave.c b/daemon/gdm-simple-slave.c
+index 9d1347a..fc8649c 100644
+--- a/daemon/gdm-simple-slave.c
++++ b/daemon/gdm-simple-slave.c
+@@ -1215,6 +1215,14 @@ setup_server (GdmSimpleSlave *slave)
+
+ /* Set the initial keyboard layout to something reasonable */
+ gdm_slave_set_initial_keyboard_layout (GDM_SLAVE (slave));
++ /* The root window has a background that may be useful
++ * to cross fade or transition from when setting the
++ * login screen background. We read it here, and stuff
++ * it into the standard _XROOTPMAP_ID root window property,
++ * so gnome-settings-daemon can get at it.
++ */
++ gdm_slave_save_root_windows (GDM_SLAVE (slave));
++
+ }
+
+ static void
+diff --git a/daemon/gdm-slave.c b/daemon/gdm-slave.c
+index a5ce62f..53633c0 100644
+--- a/daemon/gdm-slave.c
++++ b/daemon/gdm-slave.c
+@@ -43,6 +43,7 @@
+ #include <dbus/dbus-glib-lowlevel.h>
+
+ #include <X11/Xlib.h> /* for Display */
++#include <X11/Xatom.h> /* for XA_PIXMAP */
+ #include <X11/cursorfont.h> /* for watch cursor */
+ #include <X11/extensions/Xrandr.h>
+ #include <X11/Xatom.h>
+@@ -364,6 +365,77 @@ gdm_slave_run_script (GdmSlave *slave,
+ return ret;
+ }
+
++static void
++gdm_slave_save_root_window_of_screen (GdmSlave *slave,
++ Atom id_atom,
++ int screen_number)
++{
++ Window root_window;
++ GC gc;
++ XGCValues values;
++ Pixmap pixmap;
++ int width, height, depth;
++
++ root_window = RootWindow (slave->priv->server_display,
++ screen_number);
++
++ width = DisplayWidth (slave->priv->server_display, screen_number);
++ height = DisplayHeight (slave->priv->server_display, screen_number);
++ depth = DefaultDepth (slave->priv->server_display, screen_number);
++ pixmap = XCreatePixmap (slave->priv->server_display,
++ root_window,
++ width, height, depth);
++
++ values.function = GXcopy;
++ values.plane_mask = AllPlanes;
++ values.fill_style = FillSolid;
++ values.subwindow_mode = IncludeInferiors;
++
++ gc = XCreateGC (slave->priv->server_display,
++ root_window,
++ GCFunction | GCPlaneMask | GCFillStyle | GCSubwindowMode,
++ &values);
++
++ if (XCopyArea (slave->priv->server_display,
++ root_window, pixmap, gc, 0, 0,
++ width, height, 0, 0)) {
++
++ long pixmap_as_long;
++
++ pixmap_as_long = (long) pixmap;
++
++ XChangeProperty (slave->priv->server_display,
++ root_window, id_atom, XA_PIXMAP,
++ 32, PropModeReplace, (guchar *) &pixmap_as_long,
++ 1);
++
++ }
++
++ XFreeGC (slave->priv->server_display, gc);
++}
++
++void
++gdm_slave_save_root_windows (GdmSlave *slave)
++{
++ int i, number_of_screens;
++ Atom atom;
++
++ number_of_screens = ScreenCount (slave->priv->server_display);
++
++ atom = XInternAtom (slave->priv->server_display,
++ "_XROOTPMAP_ID", False);
++
++ if (atom == 0) {
++ return;
++ }
++
++ for (i = 0; i < number_of_screens; i++) {
++ gdm_slave_save_root_window_of_screen (slave, atom, i);
++ }
++
++ XSync (slave->priv->server_display, False);
++}
++
+ void
+ gdm_slave_set_initial_keyboard_layout (GdmSlave *slave)
+ {
+diff --git a/daemon/gdm-slave.h b/daemon/gdm-slave.h
+index 7af20ed..aaaa8f2 100644
+--- a/daemon/gdm-slave.h
++++ b/daemon/gdm-slave.h
+@@ -78,6 +78,7 @@ void gdm_slave_set_initial_keyboard_layout (GdmSlave *slave);
+ void gdm_slave_set_initial_cursor_position (GdmSlave *slave);
+
+ void gdm_slave_set_busy_cursor (GdmSlave *slave);
++void gdm_slave_save_root_windows (GdmSlave *slave);
+ gboolean gdm_slave_run_script (GdmSlave *slave,
+ const char *dir,
+ const char *username);
+--
+1.7.8.6
+