summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-03-28 23:08:07 +0000
committerPacho Ramos <pacho@gentoo.org>2013-03-28 23:08:07 +0000
commit35be8b2eb0d6c703ecb5d799398f1722183190b3 (patch)
tree90bb81f8f9a3c444a82fe3472e6239e29ccd6308 /gnome-base/gnome-control-center
parentVersion bump for Gnome 3.8 (diff)
downloadgentoo-2-35be8b2eb0d6c703ecb5d799398f1722183190b3.tar.gz
gentoo-2-35be8b2eb0d6c703ecb5d799398f1722183190b3.tar.bz2
gentoo-2-35be8b2eb0d6c703ecb5d799398f1722183190b3.zip
Version bump for Gnome 3.8
(Portage version: 2.1.11.58/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'gnome-base/gnome-control-center')
-rw-r--r--gnome-base/gnome-control-center/ChangeLog12
-rw-r--r--gnome-base/gnome-control-center/files/gnome-control-center-3.7.4-optional-kerberos.patch203
-rw-r--r--gnome-base/gnome-control-center/files/gnome-control-center-3.8.0-optional.patch192
-rw-r--r--gnome-base/gnome-control-center/files/gnome-control-center-3.8.0-paths-makefiles.patch22
-rw-r--r--gnome-base/gnome-control-center/files/gnome-control-center-3.8.0-paths.patch70
-rw-r--r--gnome-base/gnome-control-center/gnome-control-center-3.8.0.ebuild149
6 files changed, 647 insertions, 1 deletions
diff --git a/gnome-base/gnome-control-center/ChangeLog b/gnome-base/gnome-control-center/ChangeLog
index 8eb16e0b5153..c66cb960261f 100644
--- a/gnome-base/gnome-control-center/ChangeLog
+++ b/gnome-base/gnome-control-center/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for gnome-base/gnome-control-center
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-control-center/ChangeLog,v 1.122 2013/02/02 22:33:47 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-control-center/ChangeLog,v 1.123 2013/03/28 23:08:07 pacho Exp $
+
+*gnome-control-center-3.8.0 (28 Mar 2013)
+
+ 28 Mar 2013; Pacho Ramos <pacho@gentoo.org>
+ +files/gnome-control-center-3.7.4-optional-kerberos.patch,
+ +files/gnome-control-center-3.8.0-optional.patch,
+ +files/gnome-control-center-3.8.0-paths-makefiles.patch,
+ +files/gnome-control-center-3.8.0-paths.patch,
+ +gnome-control-center-3.8.0.ebuild:
+ Version bump for Gnome 3.8
02 Feb 2013; Agostino Sarubbo <ago@gentoo.org>
gnome-control-center-3.6.3-r1.ebuild:
diff --git a/gnome-base/gnome-control-center/files/gnome-control-center-3.7.4-optional-kerberos.patch b/gnome-base/gnome-control-center/files/gnome-control-center-3.7.4-optional-kerberos.patch
new file mode 100644
index 000000000000..38088aa2425d
--- /dev/null
+++ b/gnome-base/gnome-control-center/files/gnome-control-center-3.7.4-optional-kerberos.patch
@@ -0,0 +1,203 @@
+From 75c944a788beb749a28086025876406b7864baf5 Mon Sep 17 00:00:00 2001
+From: Sobhan Mohammadpour <sobhanmohammadpour1@yahoo.fr>
+Date: Tue, 19 Feb 2013 16:40:37 +0330
+Subject: [PATCH] gnome-control-center-3.7.4-optional-kerberos
+originaly by Priit Laes <pleas@plaes.org>
+Crappy patch to allow disabling kerberos requirement
+https://bugzilla.gnome.org/show_bug.cgi?id=686840
+---
+ panels/user-accounts/um-account-dialog.c | 30 ++++++++++++++++++++++++++----
+ panels/user-accounts/um-realm-manager.c | 2 ++
+ 2 files changed, 28 insertions(+), 4 deletions(-)
+
+diff --git a/panels/user-accounts/um-account-dialog.c b/panels/user-accounts/um-account-dialog.c
+index 88dff99..5f50087 100644
+--- a/panels/user-accounts/um-account-dialog.c
++++ b/panels/user-accounts/um-account-dialog.c
+@@ -27,9 +27,12 @@
+ #include <act/act.h>
+
+ #include "um-account-dialog.h"
+-#include "um-realm-manager.h"
+ #include "um-utils.h"
+
++#ifdef KERBEROS
++#include "um-realm-manager.h"
++#endif
++
+ typedef enum {
+ UM_LOCAL,
+ UM_ENTERPRISE,
+@@ -41,6 +44,7 @@ static void mode_change (UmAccountDialog *self,
+
+ static void dialog_validate (UmAccountDialog *self);
+
++#ifdef KERBEROS
+ static void on_join_login (GObject *source,
+ GAsyncResult *result,
+ gpointer user_data);
+@@ -48,6 +52,7 @@ static void on_join_login (GObject *source,
+ static void on_realm_joined (GObject *source,
+ GAsyncResult *result,
+ gpointer user_data);
++#endif
+
+ #define UM_ACCOUNT_DIALOG_CLASS(klass) (G_TYPE_CHECK_CLASS_CAST ((klass), UM_TYPE_ACCOUNT_DIALOG, \
+ UmAccountDialogClass))
+@@ -83,6 +88,7 @@ struct _UmAccountDialog {
+ gboolean enterprise_domain_chosen;
+ GtkEntry *enterprise_login;
+ GtkEntry *enterprise_password;
++#ifdef KERBEROS
+ UmRealmManager *realm_manager;
+ UmRealmObject *selected_realm;
+
+@@ -92,6 +98,7 @@ struct _UmAccountDialog {
+ GtkEntry *join_name;
+ GtkEntry *join_password;
+ gboolean join_prompted;
++#endif
+ };
+
+ struct _UmAccountDialogClass {
+@@ -300,6 +307,7 @@ local_prepare (UmAccountDialog *self)
+ gtk_combo_box_set_active (GTK_COMBO_BOX (self->local_account_type), 0);
+ }
+
++#ifdef KERBEROS
+ static gboolean
+ enterprise_validate (UmAccountDialog *self)
+ {
+@@ -504,7 +512,6 @@ on_join_response (GtkDialog *dialog,
+ on_join_login,
+ g_object_ref (self));
+ }
+-
+ static void
+ join_show_prompt (UmAccountDialog *self,
+ GError *error)
+@@ -892,6 +899,7 @@ enterprise_prepare (UmAccountDialog *self)
+ gtk_entry_set_text (GTK_ENTRY (self->enterprise_login), "");
+ gtk_entry_set_text (GTK_ENTRY (self->enterprise_password), "");
+ }
++#endif
+
+ static void
+ dialog_validate (UmAccountDialog *self)
+@@ -902,9 +910,11 @@ dialog_validate (UmAccountDialog *self)
+ case UM_LOCAL:
+ valid = local_validate (self);
+ break;
++#ifdef KERBEROS
+ case UM_ENTERPRISE:
+ valid = enterprise_validate (self);
+ break;
++#endif
+ default:
+ valid = FALSE;
+ break;
+@@ -990,12 +1000,14 @@ on_local_toggle (GtkToggleButton *toggle,
+ mode_toggled (UM_ACCOUNT_DIALOG (user_data), toggle, UM_LOCAL);
+ }
+
++#ifdef KERBEROS
+ static void
+ on_enterprise_toggle (GtkToggleButton *toggle,
+ gpointer user_data)
+ {
+ mode_toggled (UM_ACCOUNT_DIALOG (user_data), toggle, UM_ENTERPRISE);
+ }
++#endif
+
+ static void
+ mode_init (UmAccountDialog *self,
+@@ -1007,15 +1019,18 @@ mode_init (UmAccountDialog *self,
+
+ widget = (GtkWidget *) gtk_builder_get_object (builder, "local-area");
+ self->mode_areas[UM_LOCAL] = widget;
++#ifdef KERBEROS
+ widget = (GtkWidget *) gtk_builder_get_object (builder, "enterprise-area");
+ self->mode_areas[UM_ENTERPRISE] = widget;
+-
++#endif
+ widget = (GtkWidget *) gtk_builder_get_object (builder, "local-button");
+ g_signal_connect (widget, "toggled", G_CALLBACK (on_local_toggle), self);
+ self->mode_buttons[UM_LOCAL] = widget;
++#ifdef KERBEROS
+ widget = (GtkWidget *) gtk_builder_get_object (builder, "enterprise-button");
+ g_signal_connect (widget, "toggled", G_CALLBACK (on_enterprise_toggle), self);
+ self->mode_buttons[UM_ENTERPRISE] = widget;
++#endif
+ }
+
+ static void
+@@ -1073,8 +1088,10 @@ um_account_dialog_init (UmAccountDialog *self)
+ self->container_widget = widget;
+
+ local_init (self, builder);
++#ifdef KERBEROS
+ enterprise_init (self, builder);
+ join_init (self, builder);
++#endif
+ mode_init (self, builder);
+
+ g_object_unref (builder);
+@@ -1092,9 +1109,11 @@ um_account_dialog_response (GtkDialog *dialog,
+ case UM_LOCAL:
+ local_create_user (self);
+ break;
++#ifdef KERBEROS
+ case UM_ENTERPRISE:
+ enterprise_add_user (self);
+ break;
++#endif
+ default:
+ g_assert_not_reached ();
+ }
+@@ -1115,6 +1134,7 @@ um_account_dialog_dispose (GObject *obj)
+ if (self->cancellable)
+ g_cancellable_cancel (self->cancellable);
+
++#ifdef KERBEROS
+ if (self->realmd_watch)
+ g_bus_unwatch_name (self->realmd_watch);
+ self->realmd_watch = 0;
+@@ -1126,7 +1146,7 @@ um_account_dialog_dispose (GObject *obj)
+ g_object_unref (self->realm_manager);
+ self->realm_manager = NULL;
+ }
+-
++#endif
+ G_OBJECT_CLASS (um_account_dialog_parent_class)->dispose (obj);
+ }
+
+@@ -1179,7 +1199,9 @@ um_account_dialog_show (UmAccountDialog *self,
+ self->cancellable = g_cancellable_new ();
+
+ local_prepare (self);
++#ifdef KERBEROS
+ enterprise_prepare (self);
++#endif
+ mode_change (self, UM_LOCAL);
+ dialog_validate (self);
+
+diff --git a/panels/user-accounts/um-realm-manager.c b/panels/user-accounts/um-realm-manager.c
+index 59d57b3..d3390f4 100644
+--- a/panels/user-accounts/um-realm-manager.c
++++ b/panels/user-accounts/um-realm-manager.c
+@@ -21,6 +21,7 @@
+
+ #include "config.h"
+
++#ifdef KERBEROS
+ #include "um-realm-manager.h"
+
+ #include <krb5/krb5.h>
+@@ -899,3 +900,4 @@ um_realm_login_finish (GAsyncResult *result,
+
+ return TRUE;
+ }
++#endif
+--
+1.8.1.2
+
diff --git a/gnome-base/gnome-control-center/files/gnome-control-center-3.8.0-optional.patch b/gnome-base/gnome-control-center/files/gnome-control-center-3.8.0-optional.patch
new file mode 100644
index 000000000000..57bdeaae56ee
--- /dev/null
+++ b/gnome-base/gnome-control-center/files/gnome-control-center-3.8.0-optional.patch
@@ -0,0 +1,192 @@
+--- configure.ac.old 2013-03-27 12:32:00.730437955 +0100
++++ configure.ac 2013-03-27 12:45:04.380808177 +0100
+@@ -143,13 +143,51 @@
+ gnome-settings-daemon >= $GSD_REQUIRED_VERSION x11)
+ PKG_CHECK_MODULES(NETWORK_PANEL, $COMMON_MODULES gmodule-2.0)
+ PKG_CHECK_MODULES(NOTIFICATIONS_PANEL, $COMMON_MODULES libgnome-menu-3.0)
+-PKG_CHECK_MODULES(ONLINE_ACCOUNTS_PANEL, $COMMON_MODULES goa-1.0 goa-backend-1.0 >= $GOA_REQUIRED_VERSION)
++
++build_online_accounts=false
++AC_ARG_ENABLE(goa,
++ AC_HELP_STRING([--disable-goa],
++ [disable online accounts management panel]),
++ [case "${enableval}" in
++ yes) WANT_ONLINE_ACCOUNTS=yes ;;
++ no) WANT_ONLINE_ACCOUNTS=no ;;
++ *) AC_MSG_ERROR(bad value ${enableval} for --disable-goa) ;;
++ esac],
++ [WANT_ONLINE_ACCOUNTS=yes]) dnl Default value
++
++if test x$WANT_ONLINE_ACCOUNTS = xyes; then
++ PKG_CHECK_MODULES(ONLINE_ACCOUNTS_PANEL, $COMMON_MODULES goa-1.0 goa-backend-1.0 >= $GOA_REQUIRED_VERSION)
++ build_online_accounts=true
++fi
++AM_CONDITIONAL(BUILD_ONLINE_ACCOUNTS, test "x$build_online_accounts" = "xtrue")
++AC_SUBST(ONLINE_ACCOUNTS_PANEL_CFLAGS)
++AC_SUBST(ONLINE_ACCOUNTS_PANEL_LIBS)
++
+ PKG_CHECK_MODULES(POWER_PANEL, $COMMON_MODULES upower-glib >= 0.9.1
+ gnome-settings-daemon >= $GSD_REQUIRED_VERSION)
+-PKG_CHECK_MODULES(COLOR_PANEL, $COMMON_MODULES
+- colord >= $COLORD_REQUIRED_VERSION
+- colord-gtk >= $COLORD_GTK_REQUIRED_VERSION
+- gnome-desktop-3.0 >= $GNOME_DESKTOP_REQUIRED_VERSION)
++
++build_color=false
++AC_ARG_ENABLE(color,
++ AC_HELP_STRING([--disable-color],
++ [disable color management panel]),
++ [case "${enableval}" in
++ yes) WANT_COLOR=yes ;;
++ no) WANT_COLOR=no ;;
++ *) AC_MSG_ERROR(bad value ${enableval} for --disable-color) ;;
++ esac],
++ [WANT_COLOR=yes]) dnl Default value
++
++if test x$WANT_COLOR = xyes; then
++ PKG_CHECK_MODULES(COLOR_PANEL, $COMMON_MODULES
++ colord >= $COLORD_REQUIRED_VERSION
++ colord-gtk >= $COLORD_GTK_REQUIRED_VERSION
++ gnome-desktop-3.0 >= $GNOME_DESKTOP_REQUIRED_VERSION)
++ build_color=true
++fi
++AM_CONDITIONAL(BUILD_COLOR, test "x$build_color" = "xtrue")
++AC_SUBST(COLOR_PANEL_CFLAGS)
++AC_SUBST(COLOR_PANEL_LIBS)
++
+ PKG_CHECK_MODULES(PRINTERS_PANEL, $COMMON_MODULES
+ polkit-gobject-1 >= $POLKIT_REQUIRED_VERSION)
+ PKG_CHECK_MODULES(PRIVACY_PANEL, $COMMON_MODULES)
+@@ -210,17 +248,25 @@
+ fi
+ AM_CONDITIONAL(HAVE_MM_GLIB, test "x$have_libmm_glib" = "xyes")
+
+-# Check for gnome-bluetooth
+-PKG_CHECK_MODULES(BLUETOOTH, $COMMON_MODULES gnome-bluetooth-1.0 >= 3.5.5,
+- [have_bluetooth=yes], have_bluetooth=no)
+-if test "x$have_bluetooth" = xyes ; then
+- AC_DEFINE(BUILD_BLUETOOTH, 1, [Define to 1 to build the Bluetooth panel])
+-fi
+-AM_CONDITIONAL(BUILD_BLUETOOTH, [test x$have_bluetooth = xyes])
+-if test x${have_bluetooth} = xyes; then
+- AC_DEFINE(HAVE_BLUETOOTH, 1, [Define to 1 if bluetooth support is available])
++have_bluetooth=false
++AC_ARG_ENABLE(bluetooth,
++ AC_HELP_STRING([--disable-bluetooth],
++ [disable bluetooth management panel]),
++ [case "${enableval}" in
++ yes) WANT_BLUETOOTH=yes ;;
++ no) WANT_BLUETOOTH=no ;;
++ *) AC_MSG_ERROR(bad value ${enableval} for --disable-bluetooth) ;;
++ esac],
++ [WANT_BLUETOOTH=yes]) dnl Default value
++
++if test x$WANT_BLUETOOTH = xyes; then
++ # Check for gnome-bluetooth
++ PKG_CHECK_MODULES(BLUETOOTH, $COMMON_MODULES gnome-bluetooth-1.0 >= 3.5.5)
++ have_bluetooth=true
+ fi
+
++AM_CONDITIONAL(BUILD_BLUETOOTH, [test x$have_bluetooth = xtrue])
++
+ # Check for smbclient
+ PKG_CHECK_MODULES(SMBCLIENT, smbclient, [have_smbclient=yes], [have_smbclient=no])
+
+@@ -289,12 +335,23 @@
+ if test "$host_cpu" = s390 -o "$host_cpu" = s390x; then
+ have_wacom=no
+ else
+- PKG_CHECK_MODULES(WACOM_PANEL, $COMMON_MODULES
+- gnome-settings-daemon >= $GSD_REQUIRED_VERSION
+- xi >= 1.2 x11 libwacom >= $LIBWACOM_REQUIRED_VERSION
+- gnome-desktop-3.0 >= $GNOME_DESKTOP_REQUIRED_VERSION)
+- AC_DEFINE(BUILD_WACOM, 1, [Define to 1 to build the Wacom panel])
+- have_wacom=yes
++ AC_ARG_ENABLE(wacom,
++ AC_HELP_STRING([--disable-wacom],
++ [disable wacom management panel]),
++ [case "${enableval}" in
++ yes) WANT_WACOM=yes ;;
++ no) WANT_WACOM=no ;;
++ *) AC_MSG_ERROR(bad value ${enableval} for --disable-wacom) ;;
++ esac],
++ [WANT_WACOM=yes]) dnl Default value
++
++ if test x$WANT_WACOM = xyes; then
++ PKG_CHECK_MODULES(WACOM_PANEL, $COMMON_MODULES
++ gnome-settings-daemon >= $GSD_REQUIRED_VERSION
++ xi >= 1.2 x11 libwacom >= $LIBWACOM_REQUIRED_VERSION
++ gnome-desktop-3.0 >= $GNOME_DESKTOP_REQUIRED_VERSION)
++ have_wacom=yes
++ fi
+ fi
+ ;;
+ *)
+@@ -555,6 +612,11 @@
+ else
+ AC_MSG_NOTICE([ Bluetooth panel disabled])
+ fi
++if test "x$build_color" = "xtrue"; then
++ AC_MSG_NOTICE([** colord (Color panel)])
++else
++ AC_MSG_NOTICE([ Color panel disabled])
++fi
+ if test "x$enable_cups" = "xyes"; then
+ AC_MSG_NOTICE([** CUPS (Printers panel)])
+ else
+@@ -565,11 +627,21 @@
+ else
+ AC_MSG_NOTICE([ Users panel webcam support disabled])
+ fi
++if test "x$build_online_accounts" = "xtrue"; then
++ AC_MSG_NOTICE([** gnome-online-accounts (Online Accounts panel)])
++else
++ AC_MSG_NOTICE([ Online Accounts panel disabled])
++fi
+ if test "x$with_libsocialweb" = "xyes"; then
+ AC_MSG_NOTICE([** libsocialweb (Background panel Flickr support)])
+ else
+ AC_MSG_NOTICE([ Background panel Flickr support disabled])
+ fi
++if test "x$build_wacom" = "xtrue"; then
++ AC_MSG_NOTICE([** libwacom (Wacom Graphics Tablet panel)])
++else
++ AC_MSG_NOTICE([ Wacom Graphics Tablet panel disabled])
++fi
+ if test "x$have_wacom" = "xyes"; then
+ AC_MSG_NOTICE([** wacom (Wacom tablet panel)])
+ else
+--- panels/Makefile.am.old 2013-03-27 12:45:13.852761402 +0100
++++ panels/Makefile.am 2013-03-27 12:46:26.328393242 +0100
+@@ -2,11 +2,9 @@
+ common \
+ background \
+ power \
+- color \
+ display \
+ mouse \
+ notifications \
+- online-accounts \
+ region \
+ info \
+ sound \
+@@ -18,6 +16,10 @@
+ privacy \
+ sharing
+
++if BUILD_COLOR
++SUBDIRS += color
++endif
++
+ if BUILD_WACOM
+ SUBDIRS += wacom
+ endif
+@@ -34,4 +36,8 @@
+ SUBDIRS += bluetooth
+ endif
+
++if BUILD_ONLINE_ACCOUNTS
++SUBDIRS += online-accounts
++endif
++
+ -include $(top_srcdir)/git.mk
diff --git a/gnome-base/gnome-control-center/files/gnome-control-center-3.8.0-paths-makefiles.patch b/gnome-base/gnome-control-center/files/gnome-control-center-3.8.0-paths-makefiles.patch
new file mode 100644
index 000000000000..899b62258916
--- /dev/null
+++ b/gnome-base/gnome-control-center/files/gnome-control-center-3.8.0-paths-makefiles.patch
@@ -0,0 +1,22 @@
+--- panels/datetime/Makefile.am~ 2013-03-15 12:59:32.000000000 +0100
++++ panels/datetime/Makefile.am 2013-03-27 13:00:45.269448422 +0100
+@@ -24,6 +24,7 @@
+ $(DATETIME_PANEL_CFLAGS) \
+ -DGNOMELOCALEDIR="\"$(datadir)/locale\"" \
+ -DGNOMECC_DATA_DIR="\"$(pkgdatadir)\"" \
++ -DREALDATADIR="\"$(datadir)\"" \
+ $(NULL)
+
+ noinst_PROGRAMS = test-timezone-gfx test-endianess test-timezone
+--- panels/printers/Makefile.am~ 2013-03-15 12:59:32.000000000 +0100
++++ panels/printers/Makefile.am 2013-03-27 13:01:55.161013404 +0100
+@@ -7,6 +7,9 @@
+ $(SMBCLIENT_CFLAGS) \
+ -I$(top_srcdir)/shell/ \
+ -DGNOMELOCALEDIR="\"$(datadir)/locale\"" \
++ -DREALDATADIR="\"$(datadir)\"" \
++ -DPREFIX="\"$(prefix)\"" \
++ -DLIBEXECDIR="\"$(libexecdir)\"" \
+ $(NULL)
+
+ noinst_LTLIBRARIES = libprinters.la
diff --git a/gnome-base/gnome-control-center/files/gnome-control-center-3.8.0-paths.patch b/gnome-base/gnome-control-center/files/gnome-control-center-3.8.0-paths.patch
new file mode 100644
index 000000000000..8b97cefa77b8
--- /dev/null
+++ b/gnome-base/gnome-control-center/files/gnome-control-center-3.8.0-paths.patch
@@ -0,0 +1,70 @@
+Use Gentoo-appropriate absolute paths
+
+Original author: Alexandre Rostovtsev <tetromino@gentoo.org>
+---
+
+--- a/panels/datetime/test-endianess.c
++++ b/panels/datetime/test-endianess.c
+@@ -38,11 +38,11 @@
+ return 0;
+ }
+
+- dir = g_dir_open ("/usr/share/i18n/locales/", 0, NULL);
++ dir = g_dir_open (REALDATADIR "/i18n/locales/", 0, NULL);
+ if (dir == NULL) {
+ /* Try with /usr/share/locale/
+ * https://bugzilla.gnome.org/show_bug.cgi?id=646780 */
+- dir = g_dir_open ("/usr/share/locale/", 0, NULL);
++ dir = g_dir_open (REALDATADIR "/locale/", 0, NULL);
+ if (dir == NULL) {
+ return 1;
+ }
+--- a/panels/datetime/test-timezone.c
++++ b/panels/datetime/test-timezone.c
+@@ -1,7 +1,7 @@
+ #include <gtk/gtk.h>
+ #include "cc-timezone-map.h"
+
+-#define TZ_DIR "/usr/share/zoneinfo/"
++#define TZ_DIR REALDATADIR "/zoneinfo/"
+
+ static GList *
+ get_timezone_list (GList *tzs,
+--- a/panels/datetime/tz.h
++++ b/panels/datetime/tz.h
+@@ -29,9 +29,9 @@
+ #include <glib.h>
+
+ #ifndef __sun
+-# define TZ_DATA_FILE "/usr/share/zoneinfo/zone.tab"
++# define TZ_DATA_FILE REALDATADIR "/zoneinfo/zone.tab"
+ #else
+-# define TZ_DATA_FILE "/usr/share/lib/zoneinfo/tab/zone_sun.tab"
++# define TZ_DATA_FILE REALDATADIR "/lib/zoneinfo/tab/zone_sun.tab"
+ #endif
+
+ typedef struct _TzDB TzDB;
+--- a/panels/printers/cc-printers-panel.c
++++ b/panels/printers/cc-printers-panel.c
+@@ -2199,8 +2199,8 @@
+
+ if (printer_name)
+ {
+- const gchar *const dirs[] = { "/usr/share/cups",
+- "/usr/local/share/cups",
++ const gchar *const dirs[] = { REALDATADIR "/cups",
++ PREFIX "/local/share/cups",
+ NULL };
+ const gchar *testprint[] = { "%s/data/testprint",
+ "%s/data/testprint.ps",
+--- a/panels/printers/pp-host.c
++++ b/panels/printers/pp-host.c
+@@ -251,7 +251,7 @@
+ data->devices->devices = NULL;
+
+ argv = g_new0 (gchar *, 3);
+- argv[0] = g_strdup ("/usr/lib/cups/backend/snmp");
++ argv[0] = g_strdup (LIBEXECDIR "/cups/backend/snmp");
+ argv[1] = g_strdup (priv->hostname);
+
+ /* Use SNMP to get printer's informations */
diff --git a/gnome-base/gnome-control-center/gnome-control-center-3.8.0.ebuild b/gnome-base/gnome-control-center/gnome-control-center-3.8.0.ebuild
new file mode 100644
index 000000000000..c8bc2f8f46b8
--- /dev/null
+++ b/gnome-base/gnome-control-center/gnome-control-center-3.8.0.ebuild
@@ -0,0 +1,149 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-control-center/gnome-control-center-3.8.0.ebuild,v 1.1 2013/03/28 23:08:07 pacho Exp $
+
+EAPI="5"
+GCONF_DEBUG="yes"
+GNOME2_LA_PUNT="yes" # gmodule is used, which uses dlopen
+
+inherit autotools eutils gnome2
+
+DESCRIPTION="GNOME Desktop Configuration Tool"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="GPL-2+"
+SLOT="2"
+IUSE="+bluetooth +colord +cups +gnome-online-accounts +i18n input_devices_wacom kerberos +networkmanager +socialweb systemd v4l"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-solaris"
+
+# XXX: NetworkManager-0.9 support is automagic, make hard-dep once it's released
+#
+# gnome-session-2.91.6-r1 is needed so that 10-user-dirs-update is run at login
+# g-s-d[policykit] needed for bug #403527
+COMMON_DEPEND="
+ >=dev-libs/glib-2.35.1:2
+ >=x11-libs/gdk-pixbuf-2.23.0:2
+ >=x11-libs/gtk+-3.7.7:3
+ >=gnome-base/gsettings-desktop-schemas-3.7.2.2
+ >=gnome-base/gnome-desktop-3.7.5:3=
+ >=gnome-base/gnome-settings-daemon-3.6[colord?,policykit]
+ >=gnome-base/libgnomekbd-2.91.91
+
+ app-text/iso-codes
+ dev-libs/libpwquality
+ dev-libs/libxml2:2
+ gnome-base/gnome-menus:3
+ gnome-base/libgtop:2
+ media-libs/fontconfig
+
+ >=media-libs/libcanberra-0.13[gtk3]
+ >=media-sound/pulseaudio-2[glib]
+ >=sys-auth/polkit-0.97
+ >=sys-power/upower-0.9.1
+ >=x11-libs/libnotify-0.7.3
+
+ x11-apps/xmodmap
+ x11-libs/libX11
+ x11-libs/libXxf86misc
+ >=x11-libs/libXi-1.2
+
+ bluetooth? ( >=net-wireless/gnome-bluetooth-3.5.5:= )
+ colord? ( >=x11-misc/colord-0.1.29 )
+ cups? ( >=net-print/cups-1.4[dbus] )
+ gnome-online-accounts? ( >=net-libs/gnome-online-accounts-3.5.90 )
+ i18n? ( >=app-i18n/ibus-1.4.99 )
+ kerberos? ( virtual/krb5 )
+ networkmanager? (
+ >=gnome-extra/nm-applet-0.9.7.995
+ >=net-misc/networkmanager-0.9.8[modemmanager] )
+ socialweb? ( net-libs/libsocialweb )
+ systemd? ( >=sys-apps/systemd-31 )
+ v4l? (
+ media-libs/gstreamer:1.0
+ media-libs/clutter-gtk:1.0
+ >=media-video/cheese-3.5.91 )
+ input_devices_wacom? (
+ >=dev-libs/libwacom-0.6
+ >=x11-libs/libXi-1.2 )
+"
+# <gnome-color-manager-3.1.2 has file collisions with g-c-c-3.1.x
+RDEPEND="${COMMON_DEPEND}
+ >=sys-apps/accountsservice-0.6.30
+ x11-themes/gnome-icon-theme-symbolic
+ colord? ( >=gnome-extra/gnome-color-manager-3
+ >=x11-misc/colord-0.1.29 )
+ cups? (
+ >=app-admin/system-config-printer-gnome-1.3.5
+ net-print/cups-pk-helper )
+ !systemd? (
+ app-admin/openrc-settingsd
+ sys-auth/consolekit )
+ input_devices_wacom? ( gnome-base/gnome-settings-daemon[input_devices_wacom] )
+
+ !<gnome-base/gdm-2.91.94
+ !<gnome-extra/gnome-color-manager-3.1.2
+ !gnome-extra/gnome-media[pulseaudio]
+ !<gnome-extra/gnome-media-2.32.0-r300
+ !<net-wireless/gnome-bluetooth-3.3.2
+"
+# PDEPEND to avoid circular dependency
+PDEPEND=">=gnome-base/gnome-session-2.91.6-r1"
+DEPEND="${COMMON_DEPEND}
+ x11-proto/xproto
+ x11-proto/xf86miscproto
+ x11-proto/kbproto
+
+ dev-libs/libxml2:2
+ dev-libs/libxslt
+ >=dev-util/intltool-0.40.1
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig
+
+ cups? ( sys-apps/sed )
+
+ gnome-base/gnome-common
+"
+# Needed for autoreconf
+# gnome-base/gnome-common
+
+src_prepare() {
+ # Make some panels optional; requires eautoreconf
+ epatch "${FILESDIR}/${PN}-3.8.0-optional.patch"
+
+ # https://bugzilla.gnome.org/show_bug.cgi?id=686840
+ epatch "${FILESDIR}/${PN}-3.7.4-optional-kerberos.patch"
+
+ # Fix some absolute paths to be appropriate for Gentoo
+ epatch "${FILESDIR}/${PN}-3.8.0-paths-makefiles.patch"
+ epatch "${FILESDIR}/${PN}-3.8.0-paths.patch"
+
+ eautoreconf
+ gnome2_src_prepare
+
+ # panels/datetime/Makefile.am gets touched as a result of something in our
+ # src_prepare(). We need to touch timedated{c,h} to prevent them from being
+ # regenerated (bug #415901)
+ [[ -f panels/datetime/timedated.h ]] && touch panels/datetime/timedated.h
+ [[ -f panels/datetime/timedated.c ]] && touch panels/datetime/timedated.c
+}
+
+src_configure() {
+ G2CONF="${G2CONF}
+ --disable-update-mimedb
+ --disable-static
+ --enable-documentation
+ $(use_enable bluetooth)
+ $(use_enable colord color)
+ $(use_enable cups)
+ $(use_enable gnome-online-accounts goa)
+ $(use_enable i18n ibus)
+ $(use_with socialweb libsocialweb)
+ $(use_enable systemd)
+ $(use_with v4l cheese)
+ $(use_enable input_devices_wacom wacom)"
+ # XXX: $(use_with kerberos) # for 3.7.x
+ if ! use kerberos; then
+ G2CONF+=" KRB5_CONFIG=$(type -P true)"
+ fi
+ gnome2_src_configure
+}