summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-12-24 17:55:14 +0000
committerPacho Ramos <pacho@gentoo.org>2013-12-24 17:55:14 +0000
commitaf9b6c20a29681c142d6bdcad3abec8ec0a225aa (patch)
treef24b0f03ff9bc9ae5e9f1a250954d811c3fa5c86 /gnome-base/gnome-settings-daemon
parentVersion bump for Gnome 3.10 (diff)
downloadgentoo-2-af9b6c20a29681c142d6bdcad3abec8ec0a225aa.tar.gz
gentoo-2-af9b6c20a29681c142d6bdcad3abec8ec0a225aa.tar.bz2
gentoo-2-af9b6c20a29681c142d6bdcad3abec8ec0a225aa.zip
Fix files
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'gnome-base/gnome-settings-daemon')
-rw-r--r--gnome-base/gnome-settings-daemon/ChangeLog7
-rw-r--r--gnome-base/gnome-settings-daemon/files/gnome-settings-daemon-3.10.2-optional.patch89
-rw-r--r--gnome-base/gnome-settings-daemon/files/gnome-settings-daemon-3.10.2.ebuild141
3 files changed, 95 insertions, 142 deletions
diff --git a/gnome-base/gnome-settings-daemon/ChangeLog b/gnome-base/gnome-settings-daemon/ChangeLog
index 2dfb7922a21b..1ffb6c3312e2 100644
--- a/gnome-base/gnome-settings-daemon/ChangeLog
+++ b/gnome-base/gnome-settings-daemon/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for gnome-base/gnome-settings-daemon
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-settings-daemon/ChangeLog,v 1.131 2013/12/24 17:53:40 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-settings-daemon/ChangeLog,v 1.132 2013/12/24 17:55:14 pacho Exp $
+
+ 24 Dec 2013; Pacho Ramos <pacho@gentoo.org>
+ +files/gnome-settings-daemon-3.10.2-optional.patch,
+ -files/gnome-settings-daemon-3.10.2.ebuild:
+ Fix files
*gnome-settings-daemon-3.10.2 (24 Dec 2013)
*gnome-settings-daemon-3.10.2 (24 Dec 2013)
diff --git a/gnome-base/gnome-settings-daemon/files/gnome-settings-daemon-3.10.2-optional.patch b/gnome-base/gnome-settings-daemon/files/gnome-settings-daemon-3.10.2-optional.patch
new file mode 100644
index 000000000000..213d0a738969
--- /dev/null
+++ b/gnome-base/gnome-settings-daemon/files/gnome-settings-daemon-3.10.2-optional.patch
@@ -0,0 +1,89 @@
+From a5ee890809d279c06bb5f00dec7ad71eae2af14f Mon Sep 17 00:00:00 2001
+From: Sobhan Mohammadpour <sobhanmohammadpour1@yahoo.fr>
+Date: Tue, 10 Dec 2013 00:27:27 +0100
+Subject: [PATCH] Make colord and wacom support optional
+
+---
+ configure.ac | 30 ++++++++++++++++++++++++++----
+ plugins/Makefile.am | 7 ++++++-
+ 2 files changed, 32 insertions(+), 5 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 9f3b7ed..5720d36 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -245,7 +245,20 @@ dnl ---------------------------------------------------------------------------
+ dnl - color
+ dnl ---------------------------------------------------------------------------
+
+-PKG_CHECK_MODULES(COLOR, [colord >= 1.0.2 gnome-desktop-3.0 >= $GNOME_DESKTOP_REQUIRED_VERSION libcanberra-gtk3])
++AC_ARG_ENABLE([color],
++ AS_HELP_STRING([--disable-color],
++ [turn off color plugin]),
++ [with_color=$enableval],
++ [with_color=yes]) dnl Default value
++
++if test x$with_color = xyes; then
++ PKG_CHECK_MODULES(COLOR, [colord >= 1.0.2 gnome-desktop-3.0 >= $GNOME_DESKTOP_REQUIRED_VERSION libcanberra-gtk3])
++ AC_DEFINE(HAVE_COLOR, 1, [Define if color plugin is enabled])
++fi
++AM_CONDITIONAL(WITH_COLOR, test "x$with_color" = "xyes")
++
++AC_SUBST(COLOR_CFLAGS)
++AC_SUBST(COLOR_LIBS)
+
+ dnl ---------------------------------------------------------------------------
+ dnl - datetime
+@@ -276,12 +289,21 @@ case $host_os in
+ have_wacom=no
+ else
+ if test x$enable_gudev != xno; then
+- PKG_CHECK_MODULES(WACOM, [libwacom >= $LIBWACOM_REQUIRED_VERSION x11 xi xtst gudev-1.0 gnome-desktop-3.0 >= $GNOME_DESKTOP_REQUIRED_VERSION xorg-wacom librsvg-2.0 >= $LIBRSVG_REQUIRED_VERSION libnotify >= $LIBNOTIFY_REQUIRED_VERSION pango >= $PANGO_REQUIRED_VERSION])
+- PKG_CHECK_MODULES(WACOM_OLED, [gudev-1.0])
++ AC_ARG_ENABLE([wacom],
++ AS_HELP_STRING([--disable-wacom],
++ [turn off wacom plugin]),
++ [with_wacom=$enableval],
++ [with_wacom=no]) dnl Default value
++ if test x$with_wacom = xyes; then
++ PKG_CHECK_MODULES(WACOM, [libwacom >= $LIBWACOM_REQUIRED_VERSION x11 xi xtst gudev-1.0 gnome-desktop-3.0 >= $GNOME_DESKTOP_REQUIRED_VERSION xorg-wacom librsvg-2.0 >= $LIBRSVG_REQUIRED_VERSION libnotify >= $LIBNOTIFY_REQUIRED_VERSION pango >= $PANGO_REQUIRED_VERSION])
++ PKG_CHECK_MODULES(WACOM_OLED, [gudev-1.0])
++ have_wacom=yes
++ fi
++ AC_SUBST(WACOM_CFLAGS)
++ AC_SUBST(WACOM_LIBS)
+ else
+ AC_MSG_ERROR([GUdev is necessary to compile Wacom support])
+ fi
+- have_wacom=yes
+ fi
+ ;;
+ *)
+diff --git a/plugins/Makefile.am b/plugins/Makefile.am
+index 2f4840d..d517e77 100644
+--- a/plugins/Makefile.am
++++ b/plugins/Makefile.am
+@@ -4,7 +4,6 @@ enabled_plugins = \
+ a11y-keyboard \
+ a11y-settings \
+ clipboard \
+- color \
+ cursor \
+ datetime \
+ dummy \
+@@ -22,6 +21,12 @@ enabled_plugins = \
+
+ disabled_plugins = $(NULL)
+
++if WITH_COLOR
++enabled_plugins += color
++else
++disabled_plugins += color
++endif
++
+ if HAVE_PACKAGEKIT
+ enabled_plugins += updates
+ else
+--
+1.8.3.2
+
diff --git a/gnome-base/gnome-settings-daemon/files/gnome-settings-daemon-3.10.2.ebuild b/gnome-base/gnome-settings-daemon/files/gnome-settings-daemon-3.10.2.ebuild
deleted file mode 100644
index 929da6b16712..000000000000
--- a/gnome-base/gnome-settings-daemon/files/gnome-settings-daemon-3.10.2.ebuild
+++ /dev/null
@@ -1,141 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-settings-daemon/files/gnome-settings-daemon-3.10.2.ebuild,v 1.1 2013/12/24 17:53:39 pacho Exp $
-
-EAPI="5"
-GCONF_DEBUG="no"
-GNOME2_LA_PUNT="yes"
-
-inherit autotools eutils gnome2 systemd virtualx
-
-DESCRIPTION="Gnome Settings Daemon"
-HOMEPAGE="https://git.gnome.org/browse/gnome-settings-daemon"
-
-LICENSE="GPL-2+"
-SLOT="0"
-IUSE="+colord +cups debug +i18n input_devices_wacom -openrc-force packagekit policykit +short-touchpad-timeout smartcard +udev"
-REQUIRED_USE="
- packagekit? ( udev )
- smartcard? ( udev )
-"
-KEYWORDS="~alpha ~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-solaris"
-
-COMMON_DEPEND="
- >=dev-libs/glib-2.37.7:2
- >=x11-libs/gtk+-3.7.8:3
- >=gnome-base/gnome-desktop-3.9:3=
- >=gnome-base/gsettings-desktop-schemas-3.9.91.1
- >=gnome-base/librsvg-2.36.2
- media-fonts/cantarell
- media-libs/fontconfig
- >=media-libs/lcms-2.2:2
- media-libs/libcanberra[gtk3]
- >=media-sound/pulseaudio-2
- >=sys-power/upower-0.9.11
- x11-libs/cairo
- x11-libs/gdk-pixbuf:2
- >=x11-libs/libnotify-0.7.3:=
- x11-libs/libX11
- x11-libs/libxkbfile
- x11-libs/libXi
- x11-libs/libXext
- x11-libs/libXfixes
- x11-libs/libXtst
- x11-libs/libXxf86misc
-
- app-misc/geoclue:2.0
- >=dev-libs/libgweather-3.9.5:2
- >=sci-geosciences/geocode-glib-3.10
- >=sys-auth/polkit-0.103
-
- colord? ( >=x11-misc/colord-1.0.2:= )
- cups? ( >=net-print/cups-1.4[dbus] )
- i18n? ( >=app-i18n/ibus-1.4.99 )
- input_devices_wacom? (
- >=dev-libs/libwacom-0.7
- >=x11-libs/pango-1.20
- x11-drivers/xf86-input-wacom
- virtual/udev[gudev] )
- packagekit? ( >=app-admin/packagekit-base-0.8.1 )
- smartcard? ( >=dev-libs/nss-3.11.2 )
- udev? ( virtual/udev[gudev] )
-"
-# Themes needed by g-s-d, gnome-shell, gtk+:3 apps to work properly
-# <gnome-color-manager-3.1.1 has file collisions with g-s-d-3.1.x
-# <gnome-power-manager-3.1.3 has file collisions with g-s-d-3.1.x
-# systemd needed for power and session management, bug #464944
-RDEPEND="${COMMON_DEPEND}
- gnome-base/dconf
- !openrc-force? ( sys-apps/systemd )
- >=x11-themes/gnome-themes-standard-2.91
- >=x11-themes/gnome-icon-theme-2.91
- >=x11-themes/gnome-icon-theme-symbolic-2.91
- !<gnome-base/gnome-control-center-2.22
- !<gnome-extra/gnome-color-manager-3.1.1
- !<gnome-extra/gnome-power-manager-3.1.3
-"
-# xproto-7.0.15 needed for power plugin
-DEPEND="${COMMON_DEPEND}
- cups? ( sys-apps/sed )
- dev-libs/libxml2:2
- sys-devel/gettext
- >=dev-util/intltool-0.40
- virtual/pkgconfig
- x11-proto/inputproto
- x11-proto/xf86miscproto
- >=x11-proto/xproto-7.0.15
-"
-
-src_prepare() {
- # https://bugzilla.gnome.org/show_bug.cgi?id=621836
- # Apparently this change severely affects touchpad usability for some
- # people, so revert it if USE=short-touchpad-timeout.
- # Revisit if/when upstream adds a setting for customizing the timeout.
- use short-touchpad-timeout &&
- epatch "${FILESDIR}/${PN}-3.7.90-short-touchpad-timeout.patch"
-
- # Make colord and wacom optional; requires eautoreconf
- epatch "${FILESDIR}/${PN}-3.10.2-optional.patch"
-
- epatch_user
- eautoreconf
-
- gnome2_src_prepare
-}
-
-src_configure() {
- gnome2_src_configure \
- --disable-static \
- --enable-man \
- $(use_enable colord color) \
- $(use_enable cups) \
- $(use_enable debug) \
- $(use_enable debug more-warnings) \
- $(use_enable i18n ibus) \
- $(use_enable packagekit) \
- $(use_enable smartcard smartcard-support) \
- $(use_enable udev gudev) \
- $(use_enable input_devices_wacom wacom)
-}
-
-src_test() {
- Xemake check
-}
-
-pkg_postinst() {
- gnome2_pkg_postinst
-
- if ! systemd_is_booted; then
- ewarn "${PN} needs Systemd to be *running* for working"
- ewarn "properly. Please follow the this guide to migrate:"
- ewarn "http://wiki.gentoo.org/wiki/Systemd"
- fi
-
- if use openrc-force; then
- ewarn "You are enabling 'openrc-force' USE flag to skip systemd requirement,"
- ewarn "this can lead to unexpected problems and is not supported neither by"
- ewarn "upstream neither by Gnome Gentoo maintainers. If you suffer any problem,"
- ewarn "you will need to disable this USE flag system wide and retest before"
- ewarn "opening any bug report."
- fi
-}