summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2014-04-27 17:02:41 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2014-04-27 17:02:41 +0000
commitd2258332ab10ac7dc5d6e5b6669108c2ea304206 (patch)
treeceb0daf3dbe1ee74d383c9bd2af45e813e4f5d23 /gnome-base/gvfs
parentVersion bump for Gnome 3.12. (diff)
downloadgentoo-2-d2258332ab10ac7dc5d6e5b6669108c2ea304206.tar.gz
gentoo-2-d2258332ab10ac7dc5d6e5b6669108c2ea304206.tar.bz2
gentoo-2-d2258332ab10ac7dc5d6e5b6669108c2ea304206.zip
Version bump for Gnome 3.12.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key C6085806)
Diffstat (limited to 'gnome-base/gvfs')
-rw-r--r--gnome-base/gvfs/ChangeLog8
-rw-r--r--gnome-base/gvfs/gvfs-1.20.1.ebuild124
-rw-r--r--gnome-base/gvfs/metadata.xml13
3 files changed, 135 insertions, 10 deletions
diff --git a/gnome-base/gvfs/ChangeLog b/gnome-base/gvfs/ChangeLog
index 9240cd90f43c..17678cd7b232 100644
--- a/gnome-base/gvfs/ChangeLog
+++ b/gnome-base/gvfs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for gnome-base/gvfs
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gvfs/ChangeLog,v 1.248 2014/04/26 18:42:03 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gvfs/ChangeLog,v 1.249 2014/04/27 17:02:41 eva Exp $
+
+*gvfs-1.20.1 (27 Apr 2014)
+
+ 27 Apr 2014; Gilles Dartiguelongue <eva@gentoo.org> +gvfs-1.20.1.ebuild,
+ metadata.xml:
+ Version bump for Gnome 3.12.
*gvfs-1.18.3-r1 (26 Apr 2014)
diff --git a/gnome-base/gvfs/gvfs-1.20.1.ebuild b/gnome-base/gvfs/gvfs-1.20.1.ebuild
new file mode 100644
index 000000000000..438dccb288fe
--- /dev/null
+++ b/gnome-base/gvfs/gvfs-1.20.1.ebuild
@@ -0,0 +1,124 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gvfs/gvfs-1.20.1.ebuild,v 1.1 2014/04/27 17:02:41 eva Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit autotools bash-completion-r1 eutils gnome2
+
+DESCRIPTION="Virtual filesystem implementation for gio"
+HOMEPAGE="https://git.gnome.org/browse/gvfs"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+
+IUSE="afp archive avahi bluetooth bluray cdda fuse gnome-online-accounts gphoto2 gtk +http ios libsecret mtp samba systemd test +udev udisks"
+REQUIRED_USE="
+ cdda? ( udev )
+ udisks? ( udev )
+ systemd? ( udisks )
+"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~sparc-solaris ~x86-solaris"
+
+# Can use libgphoto-2.5.0 as well. Automagic detection.
+RDEPEND="
+ >=dev-libs/glib-2.37:2
+ sys-apps/dbus
+ dev-libs/libxml2:2
+ net-misc/openssh
+ afp? ( >=dev-libs/libgcrypt-1.2.2:0= )
+ archive? ( app-arch/libarchive:= )
+ avahi? ( >=net-dns/avahi-0.6 )
+ bluetooth? (
+ >=app-mobilephone/obex-data-server-0.4.5
+ dev-libs/dbus-glib
+ net-wireless/bluez
+ dev-libs/expat )
+ bluray? ( media-libs/libbluray )
+ fuse? ( >=sys-fs/fuse-2.8.0 )
+ gnome-online-accounts? ( >=net-libs/gnome-online-accounts-3.7.1 )
+ gphoto2? ( >=media-libs/libgphoto2-2.4.7:= )
+ gtk? ( >=x11-libs/gtk+-3.0:3 )
+ http? ( >=net-libs/libsoup-2.42:2.4 )
+ ios? (
+ >=app-pda/libimobiledevice-1.1.5:=
+ >=app-pda/libplist-1:= )
+ libsecret? ( app-crypt/libsecret )
+ mtp? ( >=media-libs/libmtp-1.1.6 )
+ samba? ( || ( >=net-fs/samba-3.4.6[smbclient] >=net-fs/samba-4[client] ) )
+ systemd? ( sys-apps/systemd:0= )
+ udev? (
+ cdda? ( || ( dev-libs/libcdio-paranoia <dev-libs/libcdio-0.90[-minimal] ) )
+ virtual/udev[gudev] )
+ udisks? ( >=sys-fs/udisks-1.97:2 )
+"
+DEPEND="${RDEPEND}
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt
+ >=dev-util/intltool-0.40
+ virtual/pkgconfig
+ dev-util/gdbus-codegen
+ dev-util/gtk-doc-am
+ test? (
+ >=dev-python/twisted-core-12.3.0
+ || (
+ net-analyzer/netcat
+ net-analyzer/netcat6 ) )
+ !udev? ( >=dev-libs/libgcrypt-1.2.2:0 )
+"
+# libgcrypt.m4, provided by libgcrypt, needed for eautoreconf, bug #399043
+# test dependencies needed per https://bugzilla.gnome.org/700162
+
+# Tests with multiple failures, this is being handled upstream at:
+# https://bugzilla.gnome.org/700162
+RESTRICT="test"
+
+src_prepare() {
+ if ! use udev; then
+ sed -e 's/gvfsd-burn/ /' \
+ -e 's/burn.mount.in/ /' \
+ -e 's/burn.mount/ /' \
+ -i daemon/Makefile.am || die
+
+ eautoreconf
+ fi
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ # --enable-documentation installs man pages
+ gnome2_src_configure \
+ --disable-bash-completion \
+ --disable-gdu \
+ --disable-hal \
+ --with-dbus-service-dir="${EPREFIX}"/usr/share/dbus-1/services \
+ --enable-documentation \
+ $(use_enable afp) \
+ $(use_enable archive) \
+ $(use_enable avahi) \
+ $(use_enable bluetooth obexftp) \
+ $(use_enable bluray) \
+ $(use_enable cdda) \
+ $(use_enable fuse) \
+ $(use_enable gnome-online-accounts goa) \
+ $(use_enable gphoto2) \
+ $(use_enable gtk) \
+ $(use_enable ios afc) \
+ $(use_enable mtp libmtp) \
+ $(use_enable udev) \
+ $(use_enable udev gudev) \
+ $(use_enable http) \
+ $(use_enable libsecret keyring) \
+ $(use_enable samba) \
+ $(use_enable systemd libsystemd-login) \
+ $(use_enable udisks udisks2)
+}
+
+src_install() {
+ DOCS="AUTHORS ChangeLog NEWS MAINTAINERS README TODO" # ChangeLog.pre-1.2 README.commits
+ gnome2_src_install
+ dobashcomp programs/completion/gvfs
+}
diff --git a/gnome-base/gvfs/metadata.xml b/gnome-base/gvfs/metadata.xml
index 3a6970fdbee8..bbad585bf65e 100644
--- a/gnome-base/gvfs/metadata.xml
+++ b/gnome-base/gvfs/metadata.xml
@@ -10,20 +10,15 @@ using the APIs of libgio. There is also fuse support that allows
applications not using gio to access the gvfs filesystems.
</longdescription>
<use>
- <flag name='afp'>Enables support for accessing AFP (Apple Filing Protocol)
- network shares</flag>
- <flag name='archive'>Enables support for accessing files in archives
- transparently via <pkg>app-arch/libarchive</pkg></flag>
+ <flag name='afp'>Enables support for accessing AFP (Apple Filing Protocol) network shares</flag>
+ <flag name='archive'>Enables support for accessing files in archives transparently via <pkg>app-arch/libarchive</pkg></flag>
<flag name='bluray'>Enable playback of Blu-ray filesystems using <pkg>media-libs/libbluray</pkg></flag>
- <flag name='fuse'>Enables fuse mount points in $HOME/.gvfs for legacy
- application access</flag>
+ <flag name='fuse'>Enables fuse mount points in $HOME/.gvfs for legacy application access</flag>
<flag name="gdu">Enable <pkg>sys-apps/gnome-disk-utility</pkg> integration</flag>
<flag name="gnome-online-accounts">Enable configuration panel for <pkg>net-libs/gnome-online-accounts</pkg> accounts</flag>
<flag name="http">Enable the HTTP/DAV backend using <pkg>net-libs/libsoup-gnome</pkg></flag>
- <flag name="libsecret">Enable <pkg>app-crypt/libsecret</pkg> support
- to store login credentials.</flag>
+ <flag name="libsecret">Enable <pkg>app-crypt/libsecret</pkg> support to store login credentials.</flag>
<flag name="udev">Enable udev base replacement code for cdda feature</flag>
<flag name="udisks">Enable volume monitoring using <pkg>sys-fs/udisks</pkg></flag>
</use>
</pkgmetadata>
-