summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorD.M.D. Ljungmark <spider@gentoo.org>2002-04-25 07:48:25 +0000
committerD.M.D. Ljungmark <spider@gentoo.org>2002-04-25 07:48:25 +0000
commit54710d38cd1faafbed26117626ee94c9f96402db (patch)
tree7f6dcef2a27431b9de0ac9794d0cc0303990acc6 /gnome-base/libglade
parentnew python and portage still broke with respect to deps (diff)
downloadgentoo-2-54710d38cd1faafbed26117626ee94c9f96402db.tar.gz
gentoo-2-54710d38cd1faafbed26117626ee94c9f96402db.tar.bz2
gentoo-2-54710d38cd1faafbed26117626ee94c9f96402db.zip
slotted version
Diffstat (limited to 'gnome-base/libglade')
-rw-r--r--gnome-base/libglade/ChangeLog7
-rw-r--r--gnome-base/libglade/files/digest-libglade-0.17-r61
-rw-r--r--gnome-base/libglade/libglade-0.17-r6.ebuild52
3 files changed, 58 insertions, 2 deletions
diff --git a/gnome-base/libglade/ChangeLog b/gnome-base/libglade/ChangeLog
index c06483a0be0c..85f38e632d04 100644
--- a/gnome-base/libglade/ChangeLog
+++ b/gnome-base/libglade/ChangeLog
@@ -1,9 +1,12 @@
# ChangeLog for gnome-base/libglade
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/libglade/ChangeLog,v 1.4 2002/04/09 22:07:19 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/libglade/ChangeLog,v 1.5 2002/04/25 07:48:25 spider Exp $
-*libglade-0.17-r5 (9 Apr 2002)
+*libglade-0.17-r5 (24 Apr 2002)
+ 24 Apr 2002; Spider <spider@gentoo.org> libglade-0.17-r5.ebuild
+ SLOTify
+*libglade-0.17-r5 (9 Apr 2002)
9 Apr 2002; M.Schlemmer <azarah@gentoo.org> libglade-0.17-r5.ebuild
Fix build in console. Add gnome-libs back as a perm depend again, as
diff --git a/gnome-base/libglade/files/digest-libglade-0.17-r6 b/gnome-base/libglade/files/digest-libglade-0.17-r6
new file mode 100644
index 000000000000..f084922d5464
--- /dev/null
+++ b/gnome-base/libglade/files/digest-libglade-0.17-r6
@@ -0,0 +1 @@
+MD5 38b2e2cfd813783fe157617813bfe3b3 libglade-0.17.tar.gz 418921
diff --git a/gnome-base/libglade/libglade-0.17-r6.ebuild b/gnome-base/libglade/libglade-0.17-r6.ebuild
new file mode 100644
index 000000000000..a156daa0156b
--- /dev/null
+++ b/gnome-base/libglade/libglade-0.17-r6.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/libglade/libglade-0.17-r6.ebuild,v 1.1 2002/04/25 07:48:25 spider Exp $
+
+#provide Xmake and Xemake
+. /usr/portage/eclass/inherit.eclass
+inherit virtualx
+
+S=${WORKDIR}/${P}
+DESCRIPTION="libglade allows programs to load their UIs from an XMLS description at tuntime."
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/${PN}/${P}.tar.gz"
+HOMEPAGE="http://developer.gnome.org/doc/API/libglade/libglade.html"
+
+SLOT="0"
+#please dont add gnome-libs as an optional DEPEND, as
+#it causes too many problems.
+RDEPEND=">=dev-libs/libxml-1.8.15
+ >=gnome-base/gnome-libs-1.4.1.2-r1
+ bonobo? ( >=gnome-base/bonobo-1.0.19-r1 )"
+
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_compile() {
+ local myconf=""
+
+ use bonobo && myconf="${myconf} --enable-bonobo"
+ use bonobo || myconf="${myconf} --disable-bonobo --disable-bonobotest"
+
+ use nls || myconf="${myconf} --disable-nls"
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var/lib \
+ --disable-gnomedb \
+ ${myconf} || die
+
+ Xemake || die
+}
+
+src_install() {
+ make prefix=${D}/usr \
+ sysconfdir=${D}/etc \
+ localstatedir=${D}/var/lib \
+ install || die
+
+ dodoc AUTHORS COPYING* ChangeLog NEWS
+ dodoc doc/*.txt
+}
+