summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2012-12-24 14:30:56 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2012-12-24 14:30:56 +0000
commit05fda8586534314b7cdd27dfcd11b9afead565d4 (patch)
tree2b1f9ece28c682019ba9290e1288fbce038876e5 /gnome-base/nautilus
parentuse the right patch wrt #448380 (diff)
downloadgentoo-2-05fda8586534314b7cdd27dfcd11b9afead565d4.tar.gz
gentoo-2-05fda8586534314b7cdd27dfcd11b9afead565d4.tar.bz2
gentoo-2-05fda8586534314b7cdd27dfcd11b9afead565d4.zip
Version bump for Gnome 3.6. Switch to EAPI=5. USE=debug not managed by eclass due to gnome macro not being used. USE=introspection is now global.
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key C6085806)
Diffstat (limited to 'gnome-base/nautilus')
-rw-r--r--gnome-base/nautilus/ChangeLog9
-rw-r--r--gnome-base/nautilus/files/nautilus-3.5.91-delete.patch44
-rw-r--r--gnome-base/nautilus/nautilus-3.6.3.ebuild109
3 files changed, 161 insertions, 1 deletions
diff --git a/gnome-base/nautilus/ChangeLog b/gnome-base/nautilus/ChangeLog
index cc252910efba..be18962869de 100644
--- a/gnome-base/nautilus/ChangeLog
+++ b/gnome-base/nautilus/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for gnome-base/nautilus
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/nautilus/ChangeLog,v 1.400 2012/12/20 16:27:56 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/nautilus/ChangeLog,v 1.401 2012/12/24 14:30:56 eva Exp $
+
+*nautilus-3.6.3 (24 Dec 2012)
+
+ 24 Dec 2012; Gilles Dartiguelongue <eva@gentoo.org>
+ +files/nautilus-3.5.91-delete.patch, +nautilus-3.6.3.ebuild:
+ Version bump for Gnome 3.6. Switch to EAPI=5. USE=debug not managed by eclass
+ due to gnome macro not being used. USE=introspection is now global.
20 Dec 2012; Alexandre Rostovtsev <tetromino@gentoo.org>
-nautilus-2.32.2.1.ebuild, -nautilus-2.32.2.1-r1.ebuild,
diff --git a/gnome-base/nautilus/files/nautilus-3.5.91-delete.patch b/gnome-base/nautilus/files/nautilus-3.5.91-delete.patch
new file mode 100644
index 000000000000..072b34ea9131
--- /dev/null
+++ b/gnome-base/nautilus/files/nautilus-3.5.91-delete.patch
@@ -0,0 +1,44 @@
+From 92af7beb790ad9181e5a6a89ac52f177354536f2 Mon Sep 17 00:00:00 2001
+From: Alexandre Rostovtsev <tetromino@gentoo.org>
+Date: Thu, 8 Dec 2011 18:39:28 -0500
+Subject: [PATCH] Delete key should delete files
+
+Make the Delete key delete files like in nautilus-2.x and every other
+file manager on the planet. Note: the nautilus-3 Ctrl+Delete shortcut
+will also continue to work.
+
+https://bugzilla.gnome.org/show_bug.cgi?id=647048
+https://bugs.gentoo.org/show_bug.cgi?id=393663
+---
+ src/nautilus-view.c | 6 +++++-
+ 1 file changed, 5 insertions(+), 1 deletion(-)
+
+diff --git a/src/nautilus-view.c b/src/nautilus-view.c
+index f51d916..0a50994 100644
+--- a/src/nautilus-view.c
++++ b/src/nautilus-view.c
+@@ -7237,7 +7237,7 @@ static const GtkActionEntry directory_view_entries[] = {
+ /* tooltip */ NULL,
+ G_CALLBACK (action_rename_select_all_callback) },
+ /* name, stock id */ { NAUTILUS_ACTION_TRASH, NULL,
+- /* label, accelerator */ N_("Mo_ve to Trash"), "<control>Delete",
++ /* label, accelerator */ N_("Mo_ve to Trash"), "Delete",
+ /* tooltip */ N_("Move each selected item to the Trash"),
+ G_CALLBACK (action_trash_callback) },
+ /* name, stock id */ { NAUTILUS_ACTION_DELETE, NULL,
+@@ -9895,8 +9895,12 @@ nautilus_view_class_init (NautilusViewClass *klass)
+ binding_set = gtk_binding_set_by_class (klass);
+ gtk_binding_entry_add_signal (binding_set, GDK_KEY_Delete, GDK_CONTROL_MASK,
+ "trash", 0);
++ gtk_binding_entry_add_signal (binding_set, GDK_KEY_Delete, 0,
++ "trash", 0);
+ gtk_binding_entry_add_signal (binding_set, GDK_KEY_KP_Delete, GDK_CONTROL_MASK,
+ "trash", 0);
++ gtk_binding_entry_add_signal (binding_set, GDK_KEY_KP_Delete, 0,
++ "trash", 0);
+ gtk_binding_entry_add_signal (binding_set, GDK_KEY_KP_Delete, GDK_SHIFT_MASK,
+ "delete", 0);
+ }
+--
+1.7.12
+
diff --git a/gnome-base/nautilus/nautilus-3.6.3.ebuild b/gnome-base/nautilus/nautilus-3.6.3.ebuild
new file mode 100644
index 000000000000..22d092cc46f6
--- /dev/null
+++ b/gnome-base/nautilus/nautilus-3.6.3.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/nautilus/nautilus-3.6.3.ebuild,v 1.1 2012/12/24 14:30:56 eva Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit eutils gnome2 virtualx
+
+DESCRIPTION="A file manager for the GNOME desktop"
+HOMEPAGE="http://live.gnome.org/Nautilus"
+
+LICENSE="GPL-2+ LGPL-2+ FDL-1.1"
+SLOT="0"
+# profiling?
+IUSE="debug exif gnome +introspection packagekit +previewer sendto tracker xmp"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux"
+
+# FIXME: tests fails under Xvfb, but pass when building manually
+# "FAIL: check failed in nautilus-file.c, line 8307"
+RESTRICT="test"
+
+# FIXME: selinux support is automagic
+# Require {glib,gdbus-codegen}-2.30.0 due to GDBus API changes between 2.29.92
+# and 2.30.0
+COMMON_DEPEND="
+ >=dev-libs/glib-2.33.13:2
+ >=x11-libs/pango-1.28.3
+ >=x11-libs/gtk+-3.5.12:3[introspection?]
+ >=dev-libs/libxml2-2.7.8:2
+ >=gnome-base/gnome-desktop-3:3=
+
+ gnome-base/dconf
+ gnome-base/gsettings-desktop-schemas
+ >=x11-libs/libnotify-0.7:=
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXrender
+
+ exif? ( >=media-libs/libexif-0.6.20 )
+ introspection? ( >=dev-libs/gobject-introspection-0.6.4 )
+ tracker? ( >=app-misc/tracker-0.14:= )
+ xmp? ( >=media-libs/exempi-2.1.0 )"
+DEPEND="${COMMON_DEPEND}
+ >=dev-lang/perl-5
+ >=dev-util/gdbus-codegen-2.33
+ >=dev-util/gtk-doc-am-1.4
+ >=dev-util/intltool-0.40.1
+ sys-devel/gettext
+ virtual/pkgconfig
+ x11-proto/xproto"
+RDEPEND="${COMMON_DEPEND}
+ packagekit? ( app-admin/packagekit-base )
+ sendto? ( !<gnome-extra/nautilus-sendto-3.0.1 )"
+# For eautoreconf
+# gnome-base/gnome-common
+# dev-util/gtk-doc-am"
+PDEPEND="gnome? (
+ >=x11-themes/gnome-icon-theme-1.1.91
+ x11-themes/gnome-icon-theme-symbolic )
+ tracker? ( >=gnome-extra/nautilus-tracker-tags-0.12 )
+ previewer? ( >=gnome-extra/sushi-0.1.9 )
+ sendto? ( >=gnome-extra/nautilus-sendto-3.0.1 )
+ >=gnome-base/gvfs-1.14[gtk]"
+# Need gvfs[gtk] for recent:/// support
+
+src_prepare() {
+ # Restore the nautilus-2.x Delete shortcut (Ctrl+Delete will still work);
+ # bug #393663
+ epatch "${FILESDIR}/${PN}-3.5.91-delete.patch"
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ DOCS="AUTHORS ChangeLog* HACKING MAINTAINERS NEWS README THANKS"
+ G2CONF="${G2CONF}
+ --disable-profiling
+ --disable-update-mimedb
+ $(use_enable debug)
+ $(use_enable exif libexif)
+ $(use_enable introspection)
+ $(use_enable packagekit)
+ $(use_enable sendto nst-extension)
+ $(use_enable tracker)
+ $(use_enable xmp)"
+ gnome2_src_configure
+}
+
+src_test() {
+ gnome2_environment_reset
+ unset DBUS_SESSION_BUS_ADDRESS
+ export GSETTINGS_BACKEND="memory"
+ Xemake check
+ unset GSETTINGS_BACKEND
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+
+ if use previewer; then
+ elog "nautilus uses gnome-extra/sushi to preview media files."
+ elog "To activate the previewer, select a file and press space; to"
+ elog "close the previewer, press space again."
+ else
+ elog "To preview media files, emerge nautilus with USE=previewer"
+ fi
+}