summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2009-03-21 13:32:36 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2009-03-21 13:32:36 +0000
commit2b740bf55bb2aab05c9643d5906f722a211a7685 (patch)
tree38e86e76c5b4fccbb9e21f8c617026c970ab0bae /gnome-base/nautilus
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-2b740bf55bb2aab05c9643d5906f722a211a7685.tar.gz
gentoo-2-2b740bf55bb2aab05c9643d5906f722a211a7685.tar.bz2
gentoo-2-2b740bf55bb2aab05c9643d5906f722a211a7685.zip
Bump to 2.24.2-r3. Fix scaling of thumbnails, bug #261219.
(Portage version: 2.2_rc25/cvs/Linux x86_64)
Diffstat (limited to 'gnome-base/nautilus')
-rw-r--r--gnome-base/nautilus/ChangeLog9
-rw-r--r--gnome-base/nautilus/files/nautilus-2.24.2-thumbnail-scaling.patch65
-rw-r--r--gnome-base/nautilus/nautilus-2.24.2-r3.ebuild82
3 files changed, 155 insertions, 1 deletions
diff --git a/gnome-base/nautilus/ChangeLog b/gnome-base/nautilus/ChangeLog
index 9d79ab4cf5ae..16f2aa90509b 100644
--- a/gnome-base/nautilus/ChangeLog
+++ b/gnome-base/nautilus/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for gnome-base/nautilus
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/nautilus/ChangeLog,v 1.300 2009/03/21 12:59:21 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/nautilus/ChangeLog,v 1.301 2009/03/21 13:32:36 eva Exp $
+
+*nautilus-2.24.2-r3 (21 Mar 2009)
+
+ 21 Mar 2009; Gilles Dartiguelongue <eva@gentoo.org>
+ +files/nautilus-2.24.2-thumbnail-scaling.patch,
+ +nautilus-2.24.2-r3.ebuild:
+ Bump to 2.24.2-r3. Fix scaling of thumbnails, bug #261219.
*nautilus-2.24.2-r2 (21 Mar 2009)
diff --git a/gnome-base/nautilus/files/nautilus-2.24.2-thumbnail-scaling.patch b/gnome-base/nautilus/files/nautilus-2.24.2-thumbnail-scaling.patch
new file mode 100644
index 000000000000..cbec1a547e40
--- /dev/null
+++ b/gnome-base/nautilus/files/nautilus-2.24.2-thumbnail-scaling.patch
@@ -0,0 +1,65 @@
+# https://bugs.gentoo.org/show_bug.cgi?id=261219
+# https://bugzilla.gnome.org/show_bug.cgi?id=574708
+#
+# Bug 523883 – Thumbnails for 200% zoom are regenerated each time a folder is opened.
+#
+# * libnautilus-private/nautilus-file.c:
+# (nautilus_file_get_icon):
+# allow scaling up thumbnails, use the scaled up thumnail
+# for up to 25% size increase.
+#
+# * src/file-manager/fm-icon-container.c:
+# (fm_icon_container_get_icon_images):
+# Force thumbnail size for compact view to avoid loading at wrong size
+# and then rescaling
+#
+--- a/libnautilus-private/nautilus-file.c 2009/03/16 12:13:10 15121
++++ b/libnautilus-private/nautilus-file.c 2009/03/16 14:18:13 15122
+@@ -3579,27 +3579,17 @@
+ scale = (double)modified_size / s;
+
+
+- if (scale > 0.99) {
+- /* never scale any thumbnails up */
+- scaled_pixbuf = gdk_pixbuf_new (GDK_COLORSPACE_RGB,
+- gdk_pixbuf_get_has_alpha (raw_pixbuf),
+- gdk_pixbuf_get_bits_per_sample (raw_pixbuf),
+- w * scale, h * scale);
+- gdk_pixbuf_fill (scaled_pixbuf, 0xffffff00);
+- gdk_pixbuf_copy_area (raw_pixbuf,
+- 0, 0, w, h,
+- scaled_pixbuf,
+- (gdk_pixbuf_get_width (scaled_pixbuf) - w) / 2,
+- (gdk_pixbuf_get_height (scaled_pixbuf) - h) / 2);
+- } else {
+- scaled_pixbuf = gdk_pixbuf_scale_simple (raw_pixbuf,
+- w * scale, h * scale,
+- GDK_INTERP_BILINEAR);
+- }
++ scaled_pixbuf = gdk_pixbuf_scale_simple (raw_pixbuf,
++ w * scale, h * scale,
++ GDK_INTERP_BILINEAR);
+ nautilus_thumbnail_frame_image (&scaled_pixbuf);
+ g_object_unref (raw_pixbuf);
+
+- if (modified_size > 128 &&
++ /* Don't scale up if more than 25%, then read the original
++ image instead. We don't want to compare to exactly 100%,
++ since the zoom level 150% gives thumbnails at 144, which is
++ ok to scale up from 128. */
++ if (modified_size > 128*1.25 &&
+ !file->details->thumbnail_wants_original) {
+ /* Invalidate if we resize upward */
+ file->details->thumbnail_wants_original = TRUE;
+--- a/src/file-manager/fm-icon-container.c 2009/03/16 12:13:10 15121
++++ b/src/file-manager/fm-icon-container.c 2009/03/16 14:18:13 15122
+@@ -99,6 +99,9 @@
+ if (!fm_icon_view_is_compact (icon_view) ||
+ nautilus_icon_container_get_zoom_level (container) > NAUTILUS_ZOOM_LEVEL_STANDARD) {
+ flags |= NAUTILUS_FILE_ICON_FLAGS_USE_THUMBNAILS;
++ if (fm_icon_view_is_compact (icon_view)) {
++ flags |= NAUTILUS_FILE_ICON_FLAGS_FORCE_THUMBNAIL_SIZE;
++ }
+ }
+
+ if (use_embedding) {
diff --git a/gnome-base/nautilus/nautilus-2.24.2-r3.ebuild b/gnome-base/nautilus/nautilus-2.24.2-r3.ebuild
new file mode 100644
index 000000000000..03f0f9f2a0cf
--- /dev/null
+++ b/gnome-base/nautilus/nautilus-2.24.2-r3.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/nautilus/nautilus-2.24.2-r3.ebuild,v 1.1 2009/03/21 13:32:36 eva Exp $
+
+EAPI="2"
+
+inherit gnome2 eutils virtualx
+
+DESCRIPTION="A file manager for the GNOME desktop"
+HOMEPAGE="http://www.gnome.org/projects/nautilus/"
+
+LICENSE="GPL-2 LGPL-2 FDL-1.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="beagle doc gnome tracker xmp"
+
+RDEPEND=">=gnome-base/libbonobo-2.1
+ >=gnome-base/eel-2.24.0
+ >=dev-libs/glib-2.17.5
+ >=gnome-base/gnome-desktop-2.10
+ >=gnome-base/libgnome-2.14
+ >=gnome-base/libgnomeui-2.6
+ >=gnome-base/orbit-2.4
+ >=x11-libs/pango-1.1.2
+ >=x11-libs/gtk+-2.13.0
+ >=gnome-base/librsvg-2.0.1
+ >=dev-libs/libxml2-2.4.7
+ >=x11-libs/startup-notification-0.8
+ >=media-libs/libexif-0.5.12
+ >=gnome-base/gconf-2.0
+ >=gnome-base/gvfs-0.1.2
+ beagle? ( || (
+ dev-libs/libbeagle
+ =app-misc/beagle-0.2* ) )
+ tracker? ( >=app-misc/tracker-0.6.4 )
+ xmp? ( >=media-libs/exempi-2 )"
+
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ >=dev-util/pkgconfig-0.9
+ >=dev-util/intltool-0.35
+ doc? ( >=dev-util/gtk-doc-1.4 )"
+
+PDEPEND="gnome? ( >=x11-themes/gnome-icon-theme-1.1.91 )"
+
+DOCS="AUTHORS ChangeLog* HACKING MAINTAINERS NEWS README THANKS TODO"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --disable-update-mimedb
+ $(use_enable beagle)
+ $(use_enable tracker)
+ $(use_enable xmp)"
+}
+
+src_prepare() {
+ # Fix update of scrollbars, bug #260965
+ epatch "${FILESDIR}/${P}-scrollbars.patch"
+
+ # Fix preview on playlists, bug #263162
+ epatch "${FILESDIR}/${P}-playlist-preview.patch"
+
+ # Fix non asyncness in custom icon filechooser, bug #263165
+ epatch "${FILESDIR}/${P}-filechooser-icon.patch"
+
+ # Fix scaling of thumbnails, bug #261219
+ epatch "${FILESDIR}/${P}-thumbnail-scaling.patch"
+}
+
+src_test() {
+ addwrite "/root/.gnome2_private"
+ unset SESSION_MANAGER
+ Xemake check || die "Test phase failed"
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+
+ elog "nautilus can use gstreamer to preview audio files. Just make sure"
+ elog "to have the necessary plugins available to play the media type you"
+ elog "want to preview"
+}