summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikael Hallendal <hallski@gentoo.org>2001-07-07 00:36:59 +0000
committerMikael Hallendal <hallski@gentoo.org>2001-07-07 00:36:59 +0000
commit6b02f745b03f20bbaeee0fcfcef0b715b6857e32 (patch)
tree1857b6f36a8b58bf14a3e9fe26dac4f5971c45ba /gnome-base
parentAdded unrar to portage (diff)
downloadgentoo-2-6b02f745b03f20bbaeee0fcfcef0b715b6857e32.tar.gz
gentoo-2-6b02f745b03f20bbaeee0fcfcef0b715b6857e32.tar.bz2
gentoo-2-6b02f745b03f20bbaeee0fcfcef0b715b6857e32.zip
updated, depend on eel 1.0.1 and librsvg 1.0.1
Diffstat (limited to 'gnome-base')
-rw-r--r--gnome-base/nautilus/files/digest-nautilus-1.0.4-r11
-rw-r--r--gnome-base/nautilus/nautilus-1.0.4-r1.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/gnome-base/nautilus/files/digest-nautilus-1.0.4-r1 b/gnome-base/nautilus/files/digest-nautilus-1.0.4-r1
new file mode 100644
index 000000000000..aba4416e68d3
--- /dev/null
+++ b/gnome-base/nautilus/files/digest-nautilus-1.0.4-r1
@@ -0,0 +1 @@
+MD5 e024b3d994838c4469ddbd8c1fbb4e28 nautilus-1.0.4.tar.gz
diff --git a/gnome-base/nautilus/nautilus-1.0.4-r1.ebuild b/gnome-base/nautilus/nautilus-1.0.4-r1.ebuild
new file mode 100644
index 000000000000..6201a7ca5a8a
--- /dev/null
+++ b/gnome-base/nautilus/nautilus-1.0.4-r1.ebuild
@@ -0,0 +1,67 @@
+## Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# Updated by Sebastian Werner <sebastian@werner-productions.de>
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/nautilus/nautilus-1.0.4-r1.ebuild,v 1.1 2001/07/07 00:36:59 hallski Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="nautilus"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/${PN}/${A}
+ ftp://rpmfind.net/linux/gnome.org/stable/latest/sources/${A}"
+
+HOMEPAGE="http://www.gnome.org/"
+
+DEPEND="nls? ( sys-devel/gettext )
+ mozilla? ( >=net-www/mozilla-0.8-r1 )
+ >=media-sound/cdparanoia-3.9.8
+ >=gnome-base/bonobo-1.0.2
+ >=gnome-base/libghttp-1.0.9
+ >=gnome-base/scrollkeeper-0.2
+ >=gnome-base/gnome-core-1.4.0.4
+ >=gnome-libs/medusa-0.5.1
+ >=gnome-libs/eel-1.0.1
+ >=gnome-libs/librsvg-1.0.1
+ >=dev-util/xml-i18n-tools-0.8.4"
+
+RDEPEND="mozilla? ( >=net-www/mozilla-0.8-r1 )
+ >=media-sound/cdparanoia-3.9.8
+ >=gnome-base/bonobo-1.0.2
+ >=gnome-base/gnome-core-1.4.0.4
+ >=gnome-libs/medusa-0.5.1
+ >=gnome-libs/eel-1.0.1
+ >=gnome-libs/librsvg-1.0.1"
+
+src_compile() {
+ local myconf
+ if [ -z "`use nls`" ]
+ then
+ myconf="--disable-nls"
+ fi
+ if [ "`use mozilla`" ]
+ then
+ MOZILLA=/opt/mozilla
+ myconf="${myconf} --with-mozilla-lib-place=$MOZILLA \
+ --with-mozilla-include-place=$MOZILLA/include"
+ export MOZILLA_FIVE_HOME=$MOZILLA
+ export LD_LIBRARY_PATH=$MOZILLA_FIVE_HOME
+# export CXXFLAGS="$CXXFLAGS -fno-exceptions -fno-rtti"
+ else
+ myconf="${myconf} --disable-mozilla-component"
+ fi
+ try ./configure --host=${CHOST} --prefix=/opt/gnome \
+ --sysconfdir=/etc/opt/gnome --infodir=/opt/gnome/info \
+ --mandir=/opt/gnome/man --enable-eazel-services=1 ${myconf}
+ try pmake
+}
+
+src_install() {
+ try make prefix=${D}/opt/gnome sysconfdir=${D}/etc/opt/gnome \
+ mandir=${D}/opt/gnome/man infodir=${D}/opt/gnome/info install
+ dodoc AUTHORS COPYING* ChangeLog* NEWS TODO
+}
+
+
+
+
+