summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2005-06-24 22:12:06 +0000
committerAron Griffis <agriffis@gentoo.org>2005-06-24 22:12:06 +0000
commit8f69df6ed2f0ba43c0e7e37f072e61a9a2585099 (patch)
tree7dea3e9a31b25107556a37425eac045127c18d8a /gnome-base
parentNew upstream version. Dropped keywords as I can't test it for now. (diff)
downloadgentoo-2-8f69df6ed2f0ba43c0e7e37f072e61a9a2585099.tar.gz
gentoo-2-8f69df6ed2f0ba43c0e7e37f072e61a9a2585099.tar.bz2
gentoo-2-8f69df6ed2f0ba43c0e7e37f072e61a9a2585099.zip
Don't call dodir in pkg_*; it breaks binary packages. Also use $IMAGE
instead of $D in pkg_* (Portage version: 2.0.51.22-r1)
Diffstat (limited to 'gnome-base')
-rw-r--r--gnome-base/gconf/ChangeLog9
-rw-r--r--gnome-base/gconf/gconf-2.10.0.ebuild10
-rw-r--r--gnome-base/gconf/gconf-2.4.0.1.ebuild10
-rw-r--r--gnome-base/gconf/gconf-2.6.0.ebuild10
-rw-r--r--gnome-base/gconf/gconf-2.6.1.ebuild10
-rw-r--r--gnome-base/gconf/gconf-2.6.2.ebuild7
-rw-r--r--gnome-base/gconf/gconf-2.8.0.1.ebuild10
-rw-r--r--gnome-base/gconf/gconf-2.8.1-r1.ebuild10
-rw-r--r--gnome-base/gconf/gconf-2.9.91.ebuild10
9 files changed, 47 insertions, 39 deletions
diff --git a/gnome-base/gconf/ChangeLog b/gnome-base/gconf/ChangeLog
index 1144c243e6a6..44efa13f656e 100644
--- a/gnome-base/gconf/ChangeLog
+++ b/gnome-base/gconf/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for gnome-base/gconf
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gconf/ChangeLog,v 1.107 2005/06/12 21:30:03 tester Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gconf/ChangeLog,v 1.108 2005/06/24 22:12:06 agriffis Exp $
+
+ 24 Jun 2005; Aron Griffis <agriffis@gentoo.org> gconf-2.4.0.1.ebuild,
+ gconf-2.6.0.ebuild, gconf-2.6.1.ebuild, gconf-2.6.2.ebuild,
+ gconf-2.8.0.1.ebuild, gconf-2.8.1-r1.ebuild, gconf-2.9.91.ebuild,
+ gconf-2.10.0.ebuild:
+ Don't call dodir in pkg_*; it breaks binary packages. Also use $IMAGE
+ instead of $D in pkg_*
12 Jun 2005; Olivier Crête <tester@gentoo.org> gconf-1.0.9.ebuild:
Stable on amd64
diff --git a/gnome-base/gconf/gconf-2.10.0.ebuild b/gnome-base/gconf/gconf-2.10.0.ebuild
index d72b39902d87..674e8aaef7ba 100644
--- a/gnome-base/gconf/gconf-2.10.0.ebuild
+++ b/gnome-base/gconf/gconf-2.10.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gconf/gconf-2.10.0.ebuild,v 1.6 2005/06/12 18:18:03 tester Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gconf/gconf-2.10.0.ebuild,v 1.7 2005/06/24 22:12:06 agriffis Exp $
inherit eutils gnome2
@@ -43,6 +43,9 @@ src_install() {
touch ${D}/etc/gconf/gconf.xml.mandatory/.keep${SLOT}
touch ${D}/etc/gconf/gconf.xml.defaults/.keep${SLOT}
+ dodir /etc/env.d
+ dodir /root/.gconfd
+
}
kill_gconf() {
@@ -76,10 +79,7 @@ pkg_preinst() {
kill_gconf
- dodir /etc/env.d
- echo 'CONFIG_PROTECT_MASK="/etc/gconf"' > ${D}/etc/env.d/50gconf
-
- dodir /root/.gconfd
+ echo 'CONFIG_PROTECT_MASK="/etc/gconf"' > ${IMAGE}/etc/env.d/50gconf
}
diff --git a/gnome-base/gconf/gconf-2.4.0.1.ebuild b/gnome-base/gconf/gconf-2.4.0.1.ebuild
index 1c8b90dc9072..86737f7b0d34 100644
--- a/gnome-base/gconf/gconf-2.4.0.1.ebuild
+++ b/gnome-base/gconf/gconf-2.4.0.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gconf/gconf-2.4.0.1.ebuild,v 1.18 2005/01/08 23:26:55 slarti Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gconf/gconf-2.4.0.1.ebuild,v 1.19 2005/06/24 22:12:06 agriffis Exp $
inherit gnome2
@@ -41,6 +41,9 @@ src_install() {
touch ${D}/etc/gconf/gconf.xml.mandatory/.keep${SLOT}
touch ${D}/etc/gconf/gconf.xml.defaults/.keep${SLOT}
+ dodir /etc/env.d
+ dodir /root/.gconfd
+
}
kill_gconf () {
@@ -74,10 +77,7 @@ pkg_preinst () {
kill_gconf
- dodir /etc/env.d
- echo 'CONFIG_PROTECT_MASK="/etc/gconf"' > ${D}/etc/env.d/50gconf
-
- dodir /root/.gconfd
+ echo 'CONFIG_PROTECT_MASK="/etc/gconf"' > ${IMAGE}/etc/env.d/50gconf
}
diff --git a/gnome-base/gconf/gconf-2.6.0.ebuild b/gnome-base/gconf/gconf-2.6.0.ebuild
index db745130840f..aa3b79dfc5ea 100644
--- a/gnome-base/gconf/gconf-2.6.0.ebuild
+++ b/gnome-base/gconf/gconf-2.6.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gconf/gconf-2.6.0.ebuild,v 1.12 2005/01/08 23:26:55 slarti Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gconf/gconf-2.6.0.ebuild,v 1.13 2005/06/24 22:12:06 agriffis Exp $
inherit gnome2
@@ -42,6 +42,9 @@ src_install() {
touch ${D}/etc/gconf/gconf.xml.mandatory/.keep${SLOT}
touch ${D}/etc/gconf/gconf.xml.defaults/.keep${SLOT}
+ dodir /etc/env.d
+ dodir /root/.gconfd
+
}
kill_gconf () {
@@ -75,10 +78,7 @@ pkg_preinst () {
kill_gconf
- dodir /etc/env.d
- echo 'CONFIG_PROTECT_MASK="/etc/gconf"' > ${D}/etc/env.d/50gconf
-
- dodir /root/.gconfd
+ echo 'CONFIG_PROTECT_MASK="/etc/gconf"' > ${IMAGE}/etc/env.d/50gconf
}
diff --git a/gnome-base/gconf/gconf-2.6.1.ebuild b/gnome-base/gconf/gconf-2.6.1.ebuild
index 2fd919bb0bf5..1e822c88f8bb 100644
--- a/gnome-base/gconf/gconf-2.6.1.ebuild
+++ b/gnome-base/gconf/gconf-2.6.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gconf/gconf-2.6.1.ebuild,v 1.9 2005/01/08 23:26:55 slarti Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gconf/gconf-2.6.1.ebuild,v 1.10 2005/06/24 22:12:06 agriffis Exp $
inherit eutils gnome2
@@ -50,6 +50,9 @@ src_install() {
touch ${D}/etc/gconf/gconf.xml.mandatory/.keep${SLOT}
touch ${D}/etc/gconf/gconf.xml.defaults/.keep${SLOT}
+ dodir /etc/env.d
+ dodir /root/.gconfd
+
}
kill_gconf () {
@@ -83,10 +86,7 @@ pkg_preinst () {
kill_gconf
- dodir /etc/env.d
- echo 'CONFIG_PROTECT_MASK="/etc/gconf"' > ${D}/etc/env.d/50gconf
-
- dodir /root/.gconfd
+ echo 'CONFIG_PROTECT_MASK="/etc/gconf"' > ${IMAGE}/etc/env.d/50gconf
}
diff --git a/gnome-base/gconf/gconf-2.6.2.ebuild b/gnome-base/gconf/gconf-2.6.2.ebuild
index d1693be85259..a86d11a5c181 100644
--- a/gnome-base/gconf/gconf-2.6.2.ebuild
+++ b/gnome-base/gconf/gconf-2.6.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gconf/gconf-2.6.2.ebuild,v 1.12 2005/01/08 23:26:55 slarti Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gconf/gconf-2.6.2.ebuild,v 1.13 2005/06/24 22:12:06 agriffis Exp $
inherit eutils gnome2
@@ -40,6 +40,8 @@ src_install() {
dodir /etc/gconf/gconf.xml.mandatory /etc/gconf/gconf.xml.defaults
touch ${D}/etc/gconf/gconf.xml.mandatory/.keep${SLOT} ${D}/etc/gconf/gconf.xml.defaults/.keep${SLOT}
+ dodir /etc/env.d /root/.gconfd
+
}
kill_gconf () {
@@ -72,8 +74,7 @@ pkg_setup () {
pkg_preinst () {
kill_gconf
- dodir /etc/env.d /root/.gconfd
- echo 'CONFIG_PROTECT_MASK="/etc/gconf"' > ${D}/etc/env.d/50gconf
+ echo 'CONFIG_PROTECT_MASK="/etc/gconf"' > ${IMAGE}/etc/env.d/50gconf
}
diff --git a/gnome-base/gconf/gconf-2.8.0.1.ebuild b/gnome-base/gconf/gconf-2.8.0.1.ebuild
index e3e42fa901ad..b39d3ad70c90 100644
--- a/gnome-base/gconf/gconf-2.8.0.1.ebuild
+++ b/gnome-base/gconf/gconf-2.8.0.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gconf/gconf-2.8.0.1.ebuild,v 1.8 2005/01/08 23:26:55 slarti Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gconf/gconf-2.8.0.1.ebuild,v 1.9 2005/06/24 22:12:06 agriffis Exp $
inherit eutils gnome2
@@ -42,6 +42,9 @@ src_install() {
touch ${D}/etc/gconf/gconf.xml.mandatory/.keep${SLOT}
touch ${D}/etc/gconf/gconf.xml.defaults/.keep${SLOT}
+ dodir /etc/env.d
+ dodir /root/.gconfd
+
}
kill_gconf () {
@@ -75,10 +78,7 @@ pkg_preinst () {
kill_gconf
- dodir /etc/env.d
- echo 'CONFIG_PROTECT_MASK="/etc/gconf"' > ${D}/etc/env.d/50gconf
-
- dodir /root/.gconfd
+ echo 'CONFIG_PROTECT_MASK="/etc/gconf"' > ${IMAGE}/etc/env.d/50gconf
}
diff --git a/gnome-base/gconf/gconf-2.8.1-r1.ebuild b/gnome-base/gconf/gconf-2.8.1-r1.ebuild
index e9f07903ae6c..2927e95bbf05 100644
--- a/gnome-base/gconf/gconf-2.8.1-r1.ebuild
+++ b/gnome-base/gconf/gconf-2.8.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gconf/gconf-2.8.1-r1.ebuild,v 1.8 2005/04/02 04:16:24 geoman Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gconf/gconf-2.8.1-r1.ebuild,v 1.9 2005/06/24 22:12:06 agriffis Exp $
inherit eutils gnome2
@@ -51,6 +51,9 @@ src_install() {
touch ${D}/etc/gconf/gconf.xml.mandatory/.keep${SLOT}
touch ${D}/etc/gconf/gconf.xml.defaults/.keep${SLOT}
+ dodir /etc/env.d
+ dodir /root/.gconfd
+
}
kill_gconf() {
@@ -84,10 +87,7 @@ pkg_preinst() {
kill_gconf
- dodir /etc/env.d
- echo 'CONFIG_PROTECT_MASK="/etc/gconf"' > ${D}/etc/env.d/50gconf
-
- dodir /root/.gconfd
+ echo 'CONFIG_PROTECT_MASK="/etc/gconf"' > ${IMAGE}/etc/env.d/50gconf
}
diff --git a/gnome-base/gconf/gconf-2.9.91.ebuild b/gnome-base/gconf/gconf-2.9.91.ebuild
index 2e4a46b15cbc..6624768f49eb 100644
--- a/gnome-base/gconf/gconf-2.9.91.ebuild
+++ b/gnome-base/gconf/gconf-2.9.91.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gconf/gconf-2.9.91.ebuild,v 1.1 2005/03/09 05:29:14 joem Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gconf/gconf-2.9.91.ebuild,v 1.2 2005/06/24 22:12:06 agriffis Exp $
inherit eutils gnome2
@@ -43,6 +43,9 @@ src_install() {
touch ${D}/etc/gconf/gconf.xml.mandatory/.keep${SLOT}
touch ${D}/etc/gconf/gconf.xml.defaults/.keep${SLOT}
+ dodir /etc/env.d
+ dodir /root/.gconfd
+
}
kill_gconf() {
@@ -76,10 +79,7 @@ pkg_preinst() {
kill_gconf
- dodir /etc/env.d
- echo 'CONFIG_PROTECT_MASK="/etc/gconf"' > ${D}/etc/env.d/50gconf
-
- dodir /root/.gconfd
+ echo 'CONFIG_PROTECT_MASK="/etc/gconf"' > ${IMAGE}/etc/env.d/50gconf
}