summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2014-05-03 22:29:26 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2014-05-03 22:29:26 +0000
commit8de6dd0da8e07853a205968dd15db3e8dbeb0032 (patch)
tree20943801ae501c80964c208dcec293057d707ce0 /gnome-extra/gnome-commander
parentMassive ebuild improvements and clean up thanks to Paul Fertser <fercerpav@gm... (diff)
downloadgentoo-2-8de6dd0da8e07853a205968dd15db3e8dbeb0032.tar.gz
gentoo-2-8de6dd0da8e07853a205968dd15db3e8dbeb0032.tar.bz2
gentoo-2-8de6dd0da8e07853a205968dd15db3e8dbeb0032.zip
Initial commit thanks to Uwe Scholz <u.scholz83@gmx.de> on bug #231885. He will also act as proxy-maintainer
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 09BF4F54C2BA7F3C!)
Diffstat (limited to 'gnome-extra/gnome-commander')
-rw-r--r--gnome-extra/gnome-commander/ChangeLog10
-rw-r--r--gnome-extra/gnome-commander/Manifest3
-rw-r--r--gnome-extra/gnome-commander/gnome-commander-1.4.1.ebuild52
-rw-r--r--gnome-extra/gnome-commander/metadata.xml26
4 files changed, 91 insertions, 0 deletions
diff --git a/gnome-extra/gnome-commander/ChangeLog b/gnome-extra/gnome-commander/ChangeLog
new file mode 100644
index 000000000000..9074e95d1829
--- /dev/null
+++ b/gnome-extra/gnome-commander/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for gnome-extra/gnome-commander
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gnome-commander/ChangeLog,v 1.1 2014/05/03 22:29:26 hwoarang Exp $
+
+*gnome-commander-1.4.1 (03 May 2014)
+
+ 03 May 2014; Markos Chandras <hwoarang@gentoo.org>
+ +gnome-commander-1.4.1.ebuild, +metadata.xml:
+ Initial commit thanks to Uwe Scholz <u.scholz83@gmx.de> on bug #231885. He
+ will also act as proxy-maintainer
diff --git a/gnome-extra/gnome-commander/Manifest b/gnome-extra/gnome-commander/Manifest
new file mode 100644
index 000000000000..db863837070e
--- /dev/null
+++ b/gnome-extra/gnome-commander/Manifest
@@ -0,0 +1,3 @@
+DIST gnome-commander-1.4.1.tar.xz 6263268 SHA256 ec57e81008a07bf4589bff8fe1ac519cb422016a8dc272d5ebf3d2441385d443 SHA512 13ea070d488220588965f2034a47451c6596418398d75ae8aa3cc43ab79a38466541bacb39c9de0230147da4cf9f339d9cd762516f03760957533f0ee9c18f70 WHIRLPOOL 074e62d83bc16890dc8522d8257c6d0fc9f4a8a4038e50c4e9874c7a2a348c3f5f66eaa7f72c4865bec5ad6967e1a261abc5916f7e22e05260d8d16d971ed9dd
+EBUILD gnome-commander-1.4.1.ebuild 1267 SHA256 007376ae7efb25a3a41dca0440d3ac234baee77caed529f4538075eba6a0b486 SHA512 3a6112e56e96ba26066b4b805b64d564cc2c5917d5f574712e1967cf75723a998bc6c41ae19035c0ded49c30a5ecb01799ca80a58b45981e7098a35bcbd79e76 WHIRLPOOL c1be6b5c5f9fcea493fdb21f8ebff5ad2b7045e21c8e90dc402b2d45857c5c415e7614542efca7a5eea7b01a8ebce8ce23d344260f5aff63186f05455b63cb6b
+MISC metadata.xml 1070 SHA256 64bd49128846e2e268d4980c405eb2f4669cfa39d7a10fe454d2a96a3f76d3db SHA512 5724cce62fc296dae59f106e18050dbab0631aa5624b473ca42b28af8bad275341cd4f04f965a81ea741fa1fafde47cafb7c520f6390a9a8f7a03e136e4ce775 WHIRLPOOL d32bca2342ae0945b813aaef94a7188fca2d2d5a4ea2e332447c614cfccdd47dcc5549737ab770b8d8828731e080c61ce59c306aff9aeb231f6c4afe578b9e10
diff --git a/gnome-extra/gnome-commander/gnome-commander-1.4.1.ebuild b/gnome-extra/gnome-commander/gnome-commander-1.4.1.ebuild
new file mode 100644
index 000000000000..3eba865dd8b9
--- /dev/null
+++ b/gnome-extra/gnome-commander/gnome-commander-1.4.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gnome-commander/gnome-commander-1.4.1.ebuild,v 1.1 2014/05/03 22:29:26 hwoarang Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit eutils gnome2 python-r1
+
+DESCRIPTION="A full featured, twin-panel file manager for Gnome2"
+HOMEPAGE="http://gcmd.github.io/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="chm doc exif gsf pdf python taglib"
+
+RDEPEND="app-text/gnome-doc-utils
+ >=dev-libs/glib-2.6.0:2
+ >=dev-libs/libunique-0.9.3:1
+ dev-util/meld
+ gnome-base/gnome-keyring
+ >=gnome-base/gnome-vfs-2.0.0
+ >=gnome-base/libgnome-2.0.0
+ >=gnome-base/libgnomeui-2.4.0
+ >=x11-libs/gtk+-2.8.0:2
+ chm? ( dev-libs/chmlib )
+ doc? ( app-text/scrollkeeper
+ gnome-extra/yelp )
+ exif? ( >=media-gfx/exiv2-0.14 )
+ gsf? ( >=gnome-extra/libgsf-1.12.0 )
+ pdf? ( >=app-text/poppler-0.18 )
+ python? ( >=dev-python/gnome-vfs-python-2.0.0 )
+ taglib? ( >=media-libs/taglib-1.4 )"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.35.0
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+DOCS="AUTHORS BUGS ChangeLog NEWS README TODO"
+
+src_configure() {
+ G2CONF="$(use_enable doc scrollkeeper)
+ $(use_enable python)
+ $(use_with chm libchm)
+ $(use_with exif exiv2)
+ $(use_with gsf libgsf)
+ $(use_with taglib)
+ $(use_with pdf poppler)"
+ gnome2_src_configure
+}
diff --git a/gnome-extra/gnome-commander/metadata.xml b/gnome-extra/gnome-commander/metadata.xml
new file mode 100644
index 000000000000..53b83744b9fe
--- /dev/null
+++ b/gnome-extra/gnome-commander/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>u.scholz83@gmx.de</email>
+ <name>Uwe Scholz</name>
+ <description>Proxy maintainer. Assign bugs to him.</description>
+ </maintainer>
+<upstream>
+ <maintainer status="active">
+ <email>u.scholz83@gmx.de</email>
+ <name>Uwe Scholz</name>
+ </maintainer>
+ <changelog>https://git.gnome.org/browse/gnome-commander/tree/NEWS?h=gcmd-1-4</changelog>
+ <bugs-to>https://bugzilla.gnome.org/browse.cgi?product=gnome-commander</bugs-to>
+ <remote-id type="freecode">gnome-commander</remote-id>
+</upstream>
+<use>
+ <flag name="chm">Enable metadata support for Microsoft Compiled HTML Help files</flag>
+ <flag name="gsf">Add metadata support for OLE, OLE2 and ODF</flag>
+ <flag name="pdf">Add metadata support for PDF</flag>
+ <flag name="python">Add support for python plugins"</flag>
+ <flag name="taglib">Add metadata support for ID3, Vorbis, FLAC and APE</flag>
+</use>
+</pkgmetadata>