summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2003-03-15 22:57:11 +0000
committerAlastair Tse <liquidx@gentoo.org>2003-03-15 22:57:11 +0000
commit3065fb106c2b11a1f7d7b3884bba890f860336a6 (patch)
treeb6dae4a910c2eb59bac5f25901cb11a2684eaca6 /gnome-extra/libgda
parentInitial import of OSKit, submitted in bug 17218 (diff)
downloadgentoo-2-3065fb106c2b11a1f7d7b3884bba890f860336a6.tar.gz
gentoo-2-3065fb106c2b11a1f7d7b3884bba890f860336a6.tar.bz2
gentoo-2-3065fb106c2b11a1f7d7b3884bba890f860336a6.zip
version bump
Diffstat (limited to 'gnome-extra/libgda')
-rw-r--r--gnome-extra/libgda/ChangeLog7
-rw-r--r--gnome-extra/libgda/files/digest-libgda-0.11.01
-rw-r--r--gnome-extra/libgda/libgda-0.11.0.ebuild96
3 files changed, 103 insertions, 1 deletions
diff --git a/gnome-extra/libgda/ChangeLog b/gnome-extra/libgda/ChangeLog
index 6a1a7b64c9c8..33293f3f091d 100644
--- a/gnome-extra/libgda/ChangeLog
+++ b/gnome-extra/libgda/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for gnome-extra/libgda
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/libgda/ChangeLog,v 1.15 2003/03/10 00:02:22 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/libgda/ChangeLog,v 1.16 2003/03/15 22:52:17 liquidx Exp $
+
+*libgda-0.11.0 (15 Mar 2003)
+
+ 15 Mar 2003; Alastair Tse <liquidx@gentoo.org> libgda-0.11.0.ebuild:
+ version bump
*libgda-0.10.0 (09 Mar 2003)
diff --git a/gnome-extra/libgda/files/digest-libgda-0.11.0 b/gnome-extra/libgda/files/digest-libgda-0.11.0
new file mode 100644
index 000000000000..4b0aa016f4e6
--- /dev/null
+++ b/gnome-extra/libgda/files/digest-libgda-0.11.0
@@ -0,0 +1 @@
+MD5 8e50d1082033f413c8e8b700b078194b libgda-0.11.0.tar.bz2 828283
diff --git a/gnome-extra/libgda/libgda-0.11.0.ebuild b/gnome-extra/libgda/libgda-0.11.0.ebuild
new file mode 100644
index 000000000000..56a7352967aa
--- /dev/null
+++ b/gnome-extra/libgda/libgda-0.11.0.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/libgda/libgda-0.11.0.ebuild,v 1.1 2003/03/15 22:52:17 liquidx Exp $
+
+IUSE="odbc postgres mysql ldap"
+
+inherit gnome2 gnome.org
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Gnome Database Access Library"
+HOMEPAGE="http://www.gnome-db.org/"
+SLOT="0"
+LICENSE="GPL-2 LGPL-2"
+KEYWORDS="~x86"
+
+RDEPEND=">=gnome-base/ORBit2-2.3.91
+ >=dev-libs/glib-2.0.4
+ >=gnome-base/bonobo-activation-0.7.0
+ >=gnome-base/libbonobo-2.0.0
+ >=dev-libs/libxml2-2.4.23
+ >=gnome-base/gconf-1.2.0
+ >=dev-libs/libxslt-1.0.9
+ >=gnome-base/gnome-vfs-2.0.0
+ dev-libs/popt
+ sys-libs/readline
+ sys-libs/ncurses
+ mysql? ( >=dev-db/mysql-3.23.51 )
+ postgres? ( >=dev-db/postgresql-7.2.1 )
+ odbc? ( >=dev-db/unixODBC-2.0.6 )
+ ldap? ( net-nds/openldap )"
+
+# removing un-ratified use flags
+# sqlite? ( >=dev-db/sqlite-2.4.2 )
+# freetds? ( >=dev-db/freetds-0.53 )
+
+DEPEND=">=dev-util/pkgconfig-0.8
+ >=dev-util/intltool-0.22
+ ${RDEPEND}"
+
+src_compile() {
+
+ local myconf
+
+ if [ -n "`use mysql`" ]; then
+ myconf="--with-mysql=/usr"
+ else
+ myconf="--without-mysql"
+ fi
+
+ if [ -n "`use postgres`" ]; then
+ myconf="${myconf} --with-postgres=/usr"
+ else
+ myconf="${myconf} --without-postgres"
+ fi
+
+ if [ -n "`use odbc`" ]; then
+ myconf="${myconf} --with-odbc=/usr"
+ else
+ myconf="${myconf} --without-odbc"
+ fi
+
+ if [ -n "`use ldap`" ]; then
+ myconf="${myconf} --with-ldap=/usr"
+ else
+ myconf="${myconf} --without-ldap"
+ fi
+
+ # disabling unratified USE flags
+
+ #if [ -n "`use sqlite`" ]; then
+ # myconf="$myconf --with-sqlite=/usr"
+ #else
+ # myconf="$myconf --without-sqlite"
+ #fi
+
+ #if [ -n "`use freetds`" ]; then
+ # myconf="$myconf --with-tds=/usr"
+ #else
+ # myconf="$myconf --without-tds"
+ #fi
+
+ # not setting these, because we should allow
+ # libgda to autodetect the environment if
+ # there are no use flags for these backends.
+
+ #myconf="${myconf} --without-sqlite"
+ #myconf="${myconf} --without-tds"
+ #myconf="${myconf} --without-ibmdb2"
+ #myconf="${myconf} --without-sybase"
+ #myconf="${myconf} --without-oracle"
+ #myconf="${myconf} --without-firebird"
+ #myconf="${myconf} --without-mdb"
+
+ gnome2_src_compile ${myconf}
+
+}