summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-03-28 17:30:55 +0000
committerPacho Ramos <pacho@gentoo.org>2013-03-28 17:30:55 +0000
commit860760604ee9454a3e5bb19fca80e53643970950 (patch)
tree033cb4a8c69e0a0cf0018bd321cd4dfa13915e5f /gnome-extra/sushi
parentVersion bump for Gnome 3.8 (diff)
downloadgentoo-2-860760604ee9454a3e5bb19fca80e53643970950.tar.gz
gentoo-2-860760604ee9454a3e5bb19fca80e53643970950.tar.bz2
gentoo-2-860760604ee9454a3e5bb19fca80e53643970950.zip
Version bump for Gnome 3.8
(Portage version: 2.1.11.58/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'gnome-extra/sushi')
-rw-r--r--gnome-extra/sushi/ChangeLog7
-rw-r--r--gnome-extra/sushi/sushi-3.8.0.ebuild60
2 files changed, 66 insertions, 1 deletions
diff --git a/gnome-extra/sushi/ChangeLog b/gnome-extra/sushi/ChangeLog
index 6494806a418c..78b24f69ce3d 100644
--- a/gnome-extra/sushi/ChangeLog
+++ b/gnome-extra/sushi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for gnome-extra/sushi
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/sushi/ChangeLog,v 1.12 2013/02/02 22:41:36 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/sushi/ChangeLog,v 1.13 2013/03/28 17:30:55 pacho Exp $
+
+*sushi-3.8.0 (28 Mar 2013)
+
+ 28 Mar 2013; Pacho Ramos <pacho@gentoo.org> +sushi-3.8.0.ebuild:
+ Version bump for Gnome 3.8
02 Feb 2013; Agostino Sarubbo <ago@gentoo.org> sushi-3.6.1.ebuild:
Add ~arm, wrt bug #449220
diff --git a/gnome-extra/sushi/sushi-3.8.0.ebuild b/gnome-extra/sushi/sushi-3.8.0.ebuild
new file mode 100644
index 000000000000..f340b306a0fd
--- /dev/null
+++ b/gnome-extra/sushi/sushi-3.8.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/sushi/sushi-3.8.0.ebuild,v 1.1 2013/03/28 17:30:55 pacho Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+
+inherit gnome2
+
+DESCRIPTION="A quick previewer for Nautilus, the GNOME file manager"
+HOMEPAGE="http://git.gnome.org/browse/sushi"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="office"
+
+# Optional app-office/unoconv support (OOo to pdf)
+# freetype needed for font loader
+# libX11 needed for sushi_create_foreign_window()
+COMMON_DEPEND="
+ >=x11-libs/gdk-pixbuf-2.23[introspection]
+ >=dev-libs/gjs-1.34
+ >=dev-libs/glib-2.29.14:2
+ >=dev-libs/gobject-introspection-0.9.6
+ >=media-libs/clutter-1.11.4:1.0[introspection]
+ >=media-libs/clutter-gtk-1.0.1:1.0[introspection]
+ >=x11-libs/gtk+-3.4.0:3[introspection]
+
+ >=app-text/evince-3.0[introspection]
+ media-libs/freetype:2
+ media-libs/gstreamer:1.0[introspection]
+ media-libs/gst-plugins-base:1.0[introspection]
+ media-libs/clutter-gst:2.0[introspection]
+ media-libs/musicbrainz:5
+ net-libs/webkit-gtk:3[introspection]
+ x11-libs/gtksourceview:3.0[introspection]
+ x11-libs/libX11
+
+ office? ( app-office/unoconv )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.40
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig
+"
+RDEPEND="${COMMON_DEPEND}
+ >=gnome-base/nautilus-3.1.90
+ x11-themes/gnome-icon-theme-symbolic
+"
+
+src_configure() {
+ G2CONF="${G2CONF}
+ UNOCONV=$(type -P false)
+ --disable-static"
+ if use office; then
+ G2CONF="${G2CONF} UNOCONV=$(type -P unoconv)"
+ fi
+ gnome2_src_configure
+}