summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2013-02-06 03:52:06 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2013-02-06 03:52:06 +0000
commit78b2ed6bac263ae9c9e1445b15b966fb22a8c338 (patch)
tree5286ba717ab7f90e111fc576ea528039634e12bd /gnome-extra/yelp-xsl
parentAdd an upper bound on v8 due to API change. Reported by Mr_Bones_. (diff)
downloadgentoo-2-78b2ed6bac263ae9c9e1445b15b966fb22a8c338.tar.gz
gentoo-2-78b2ed6bac263ae9c9e1445b15b966fb22a8c338.tar.bz2
gentoo-2-78b2ed6bac263ae9c9e1445b15b966fb22a8c338.zip
Ensure gawk, not virtual/awk is used; nawk fails on build scripts with syntax errors (bug #455730, thanks to Christoph Junghans). Drop old.
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, signed Manifest commit with key CF0ADD61)
Diffstat (limited to 'gnome-extra/yelp-xsl')
-rw-r--r--gnome-extra/yelp-xsl/ChangeLog8
-rw-r--r--gnome-extra/yelp-xsl/files/yelp-xsl-3.6.1-gawk.patch59
-rw-r--r--gnome-extra/yelp-xsl/yelp-xsl-3.2.1.ebuild24
-rw-r--r--gnome-extra/yelp-xsl/yelp-xsl-3.4.2.ebuild13
-rw-r--r--gnome-extra/yelp-xsl/yelp-xsl-3.6.1.ebuild11
5 files changed, 85 insertions, 30 deletions
diff --git a/gnome-extra/yelp-xsl/ChangeLog b/gnome-extra/yelp-xsl/ChangeLog
index ccf2950ffd35..49449f60c561 100644
--- a/gnome-extra/yelp-xsl/ChangeLog
+++ b/gnome-extra/yelp-xsl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for gnome-extra/yelp-xsl
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/yelp-xsl/ChangeLog,v 1.20 2013/01/28 13:48:20 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/yelp-xsl/ChangeLog,v 1.21 2013/02/06 03:52:06 tetromino Exp $
+
+ 06 Feb 2013; Alexandre Rostovtsev <tetromino@gentoo.org>
+ -yelp-xsl-3.2.1.ebuild, yelp-xsl-3.4.2.ebuild, yelp-xsl-3.6.1.ebuild,
+ +files/yelp-xsl-3.6.1-gawk.patch:
+ Ensure gawk, not virtual/awk is used; nawk fails on build scripts with syntax
+ errors (bug #455730, thanks to Christoph Junghans). Drop old.
28 Jan 2013; Alexis Ballier <aballier@gentoo.org> yelp-xsl-3.6.1.ebuild:
keyword ~amd64-fbsd
diff --git a/gnome-extra/yelp-xsl/files/yelp-xsl-3.6.1-gawk.patch b/gnome-extra/yelp-xsl/files/yelp-xsl-3.6.1-gawk.patch
new file mode 100644
index 000000000000..9f06c436050c
--- /dev/null
+++ b/gnome-extra/yelp-xsl/files/yelp-xsl-3.6.1-gawk.patch
@@ -0,0 +1,59 @@
+From 7dfe59cd3ed75a245804ea3081460988c4affdee Mon Sep 17 00:00:00 2001
+From: Alexandre Rostovtsev <tetromino@gentoo.org>
+Date: Tue, 5 Feb 2013 22:41:14 -0500
+Subject: [PATCH] Use gawk, not awk
+
+Despite all attempts to be compatible with other awks, using some (e.g.
+nawk) still results in syntax errors:
+
+nawk: syntax error at source line 3 source file
+doc/yelp-xsl/xsldoc-scan.awk
+ context is
+ # -*- indent-tabs-mode: nil -*- >>>
+ <<<
+ 2 extra }'s
+---
+ doc/yelp-xsl/mal2cache | 2 +-
+ doc/yelp-xsl/xsldoc-scan | 2 +-
+ doc/yelp-xsl/xsldoc-scan.awk | 2 +-
+ 3 files changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/doc/yelp-xsl/mal2cache b/doc/yelp-xsl/mal2cache
+index a7a23ee..6beaa64 100755
+--- a/doc/yelp-xsl/mal2cache
++++ b/doc/yelp-xsl/mal2cache
+@@ -2,7 +2,7 @@
+ # -*- indent-tabs-mode: nil -*-
+ export LANG=C
+ urlencode() {
+- echo "$1" | awk --posix '
++ echo "$1" | gawk --posix '
+ BEGIN {
+ for (i = 1; i <= 256; i++) {
+ bytes[sprintf("%c", i)] = i;
+diff --git a/doc/yelp-xsl/xsldoc-scan b/doc/yelp-xsl/xsldoc-scan
+index 63e713b..892bb3a 100755
+--- a/doc/yelp-xsl/xsldoc-scan
++++ b/doc/yelp-xsl/xsldoc-scan
+@@ -9,7 +9,7 @@ while [ "$#" != "0" ]; do
+ else
+ fullfile=$(cd $(dirname "$1") && pwd)/$(basename "$1")
+ outfile=$(basename "$1" .xsl)
+- awk -f $(dirname "$0")/xsldoc-scan.awk "$1" | \
++ gawk -f $(dirname "$0")/xsldoc-scan.awk "$1" | \
+ xsltproc -o "$outdir/$outfile".page \
+ --stringparam xsldoc.id "$outfile" \
+ --stringparam xsldoc.xslt_file "$fullfile" \
+diff --git a/doc/yelp-xsl/xsldoc-scan.awk b/doc/yelp-xsl/xsldoc-scan.awk
+index a8859df..83e976a 100644
+--- a/doc/yelp-xsl/xsldoc-scan.awk
++++ b/doc/yelp-xsl/xsldoc-scan.awk
+@@ -1,4 +1,4 @@
+-#!/bin/awk
++#!/usr/bin/env gawk
+ # -*- indent-tabs-mode: nil -*-
+ # xsldoc.awk - Convert inline documentation to XML suitable for xsldoc.xsl
+ # Copyright (C) 2006 Shaun McCance <shaunm@gnome.org>
+--
+1.8.1.2
+
diff --git a/gnome-extra/yelp-xsl/yelp-xsl-3.2.1.ebuild b/gnome-extra/yelp-xsl/yelp-xsl-3.2.1.ebuild
deleted file mode 100644
index fc6418d8e32b..000000000000
--- a/gnome-extra/yelp-xsl/yelp-xsl-3.2.1.ebuild
+++ /dev/null
@@ -1,24 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/yelp-xsl/yelp-xsl-3.2.1.ebuild,v 1.5 2012/12/16 10:12:24 tetromino Exp $
-
-EAPI="4"
-
-inherit gnome.org
-
-DESCRIPTION="XSL stylesheets for yelp"
-HOMEPAGE="http://www.gnome.org/"
-
-LICENSE="GPL-2+ LGPL-2.1+ MIT FDL-1.1+"
-SLOT="0"
-KEYWORDS="amd64 ~mips x86 ~amd64-linux ~x86-linux"
-IUSE=""
-
-RDEPEND=">=dev-libs/libxml2-2.6.12
- >=dev-libs/libxslt-1.1.8"
-DEPEND="${RDEPEND}
- sys-apps/gawk
- sys-devel/gettext
- >=dev-util/intltool-0.40
- dev-util/itstool
- virtual/pkgconfig"
diff --git a/gnome-extra/yelp-xsl/yelp-xsl-3.4.2.ebuild b/gnome-extra/yelp-xsl/yelp-xsl-3.4.2.ebuild
index d082126057ad..c902e6f650b9 100644
--- a/gnome-extra/yelp-xsl/yelp-xsl-3.4.2.ebuild
+++ b/gnome-extra/yelp-xsl/yelp-xsl-3.4.2.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/yelp-xsl/yelp-xsl-3.4.2.ebuild,v 1.7 2012/12/19 15:54:30 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/yelp-xsl/yelp-xsl-3.4.2.ebuild,v 1.8 2013/02/06 03:52:06 tetromino Exp $
EAPI="4"
-inherit gnome.org
+inherit eutils gnome.org
DESCRIPTION="XSL stylesheets for yelp"
HOMEPAGE="http://www.gnome.org/"
@@ -16,9 +16,16 @@ IUSE=""
RDEPEND=">=dev-libs/libxml2-2.6.12
>=dev-libs/libxslt-1.1.8"
+# Requires gawk, not virtual/awk: nawk fails with syntax errors
DEPEND="${RDEPEND}
>=dev-util/intltool-0.40
dev-util/itstool
sys-apps/gawk
sys-devel/gettext
virtual/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-3.6.1-gawk.patch"
+ sed -e 's/$(YELP_XSL_AWK)/gawk/' -i doc/yelp-xsl/Makefile.{am,in} || die
+ default
+}
diff --git a/gnome-extra/yelp-xsl/yelp-xsl-3.6.1.ebuild b/gnome-extra/yelp-xsl/yelp-xsl-3.6.1.ebuild
index 3c73079579b5..4c8b6a275d80 100644
--- a/gnome-extra/yelp-xsl/yelp-xsl-3.6.1.ebuild
+++ b/gnome-extra/yelp-xsl/yelp-xsl-3.6.1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/yelp-xsl/yelp-xsl-3.6.1.ebuild,v 1.9 2013/01/28 13:48:20 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/yelp-xsl/yelp-xsl-3.6.1.ebuild,v 1.10 2013/02/06 03:52:06 tetromino Exp $
EAPI="5"
-inherit gnome.org
+inherit eutils gnome.org
DESCRIPTION="XSL stylesheets for yelp"
HOMEPAGE="http://www.gnome.org/"
@@ -16,9 +16,16 @@ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fb
RDEPEND=">=dev-libs/libxml2-2.6.12
>=dev-libs/libxslt-1.1.8"
+# Requires gawk, not virtual/awk: nawk fails with syntax errors
DEPEND="${RDEPEND}
>=dev-util/intltool-0.40
dev-util/itstool
sys-apps/gawk
sys-devel/gettext
virtual/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-3.6.1-gawk.patch"
+ sed -e 's/$(YELP_XSL_AWK)/gawk/' -i doc/yelp-xsl/Makefile.{am,in} || die
+ default
+}