summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-03-28 17:33:23 +0000
committerPacho Ramos <pacho@gentoo.org>2013-03-28 17:33:23 +0000
commite76880024a01e7aada0b93e9606d374c32c91528 (patch)
tree2fdfa380890eb2112baf08272f47f5ed6b29ab6d /gnome-extra/zenity
parentVersion bump for Gnome 3.8 (diff)
downloadgentoo-2-e76880024a01e7aada0b93e9606d374c32c91528.tar.gz
gentoo-2-e76880024a01e7aada0b93e9606d374c32c91528.tar.bz2
gentoo-2-e76880024a01e7aada0b93e9606d374c32c91528.zip
Version bump for Gnome 3.8
(Portage version: 2.1.11.58/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'gnome-extra/zenity')
-rw-r--r--gnome-extra/zenity/ChangeLog9
-rw-r--r--gnome-extra/zenity/zenity-3.8.0.ebuild49
2 files changed, 56 insertions, 2 deletions
diff --git a/gnome-extra/zenity/ChangeLog b/gnome-extra/zenity/ChangeLog
index cd706db90c15..1837ebac8684 100644
--- a/gnome-extra/zenity/ChangeLog
+++ b/gnome-extra/zenity/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for gnome-extra/zenity
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/zenity/ChangeLog,v 1.209 2012/12/24 00:35:19 eva Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/zenity/ChangeLog,v 1.210 2013/03/28 17:33:23 pacho Exp $
+
+*zenity-3.8.0 (28 Mar 2013)
+
+ 28 Mar 2013; Pacho Ramos <pacho@gentoo.org> +zenity-3.8.0.ebuild:
+ Version bump for Gnome 3.8
*zenity-3.6.0 (24 Dec 2012)
diff --git a/gnome-extra/zenity/zenity-3.8.0.ebuild b/gnome-extra/zenity/zenity-3.8.0.ebuild
new file mode 100644
index 000000000000..f5c510ea501b
--- /dev/null
+++ b/gnome-extra/zenity/zenity-3.8.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/zenity/zenity-3.8.0.ebuild,v 1.1 2013/03/28 17:33:23 pacho Exp $
+
+EAPI="5"
+GCONF_DEBUG="yes"
+
+inherit gnome2
+
+DESCRIPTION="Tool to display dialogs from the commandline and shell scripts"
+HOMEPAGE="http://live.gnome.org/Zenity"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux"
+IUSE="libnotify test +webkit"
+
+RDEPEND=">=dev-libs/glib-2.8:2
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-3:3
+ x11-libs/libX11
+ x11-libs/pango
+ libnotify? ( >=x11-libs/libnotify-0.6.1:= )
+ webkit? ( >=net-libs/webkit-gtk-1.4.0:3 )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.40
+ >=sys-devel/gettext-0.14
+ virtual/pkgconfig
+ test? ( app-text/yelp-tools )"
+# eautoreconf needs:
+# >=gnome-base/gnome-common-2.12
+
+src_configure() {
+ DOCS="AUTHORS ChangeLog HACKING NEWS README THANKS TODO"
+ G2CONF="${G2CONF}
+ $(use_enable libnotify)
+ $(use_enable webkit webkitgtk)
+ PERL=$(type -P false)
+ ITSTOOL=$(type -P true)"
+
+ gnome2_src_configure
+}
+
+src_install() {
+ gnome2_src_install
+
+ rm "${ED}/usr/bin/gdialog" || die "rm gdialog failed!"
+}