summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2011-08-19 10:54:09 +0000
committerNirbheek Chauhan <nirbheek@gentoo.org>2011-08-19 10:54:09 +0000
commit05c4a326ebf912c86821f519a89c1eddff8830b5 (patch)
treef942ec7e4e8097fba40553fd5ba1b16c5b372795 /gnome-extra
parentBump to 3.0.2, from gnome overlay for GNOME 3 (diff)
downloadgentoo-2-05c4a326ebf912c86821f519a89c1eddff8830b5.tar.gz
gentoo-2-05c4a326ebf912c86821f519a89c1eddff8830b5.tar.bz2
gentoo-2-05c4a326ebf912c86821f519a89c1eddff8830b5.zip
Bump to 3.0.0, from gnome overlay for GNOME 3
(Portage version: 2.2.0_alpha51/cvs/Linux x86_64)
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/zenity/ChangeLog8
-rw-r--r--gnome-extra/zenity/files/zenity-3.0.0-libnotify-ifdef.patch30
-rw-r--r--gnome-extra/zenity/zenity-3.0.0.ebuild51
3 files changed, 88 insertions, 1 deletions
diff --git a/gnome-extra/zenity/ChangeLog b/gnome-extra/zenity/ChangeLog
index 41aee65f1251..d2721829b014 100644
--- a/gnome-extra/zenity/ChangeLog
+++ b/gnome-extra/zenity/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for gnome-extra/zenity
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/zenity/ChangeLog,v 1.203 2011/03/23 08:33:01 nirbheek Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/zenity/ChangeLog,v 1.204 2011/08/19 10:54:09 nirbheek Exp $
+
+*zenity-3.0.0 (19 Aug 2011)
+
+ 19 Aug 2011; Nirbheek Chauhan <nirbheek@gentoo.org> +zenity-3.0.0.ebuild,
+ +files/zenity-3.0.0-libnotify-ifdef.patch:
+ Bump to 3.0.0, from gnome overlay for GNOME 3
23 Mar 2011; Nirbheek Chauhan <nirbheek@gentoo.org> -zenity-2.30.0.ebuild:
Remove old
diff --git a/gnome-extra/zenity/files/zenity-3.0.0-libnotify-ifdef.patch b/gnome-extra/zenity/files/zenity-3.0.0-libnotify-ifdef.patch
new file mode 100644
index 000000000000..1599677a5f1d
--- /dev/null
+++ b/gnome-extra/zenity/files/zenity-3.0.0-libnotify-ifdef.patch
@@ -0,0 +1,30 @@
+From 3388135658e8a8f56da7fd01015490c2c97958ee Mon Sep 17 00:00:00 2001
+From: Nirbheek Chauhan <nirbheek@gentoo.org>
+Date: Thu, 2 Jun 2011 22:42:33 +0530
+Subject: [PATCH] Fix bug 651723, don't look for libnotify.h if not requested
+
+---
+ src/notification.c | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/src/notification.c b/src/notification.c
+index 41d64e2..3f4c454 100644
+--- a/src/notification.c
++++ b/src/notification.c
+@@ -29,12 +29,12 @@
+ #include <gtk/gtk.h>
+ #include <time.h>
+ #include <string.h>
++#ifdef HAVE_LIBNOTIFY
+ #include <libnotify/notify.h>
+
+ #include "zenity.h"
+ #include "util.h"
+
+-#ifdef HAVE_LIBNOTIFY
+ static char *icon_file;
+
+ static void
+--
+1.7.3.4
+
diff --git a/gnome-extra/zenity/zenity-3.0.0.ebuild b/gnome-extra/zenity/zenity-3.0.0.ebuild
new file mode 100644
index 000000000000..16b1fa89091d
--- /dev/null
+++ b/gnome-extra/zenity/zenity-3.0.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/zenity/zenity-3.0.0.ebuild,v 1.1 2011/08/19 10:54:09 nirbheek Exp $
+
+EAPI="4"
+GCONF_DEBUG="yes"
+GNOME_TARBALL_SUFFIX="bz2"
+GNOME2_LA_PUNT="yes"
+
+inherit eutils gnome2
+
+DESCRIPTION="Tool to display dialogs from the commandline and shell scripts"
+HOMEPAGE="http://live.gnome.org/Zenity"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux"
+IUSE="libnotify"
+
+RDEPEND=">=x11-libs/gtk+-3.0.0:3
+ >=dev-libs/glib-2.8:2
+ libnotify? ( >=x11-libs/libnotify-0.6.1 )"
+
+DEPEND="${RDEPEND}
+ app-text/scrollkeeper
+ app-text/docbook-xml-dtd:4.1.2
+ >=dev-util/intltool-0.40
+ >=sys-devel/gettext-0.14
+ >=dev-util/pkgconfig-0.9
+ >=app-text/gnome-doc-utils-0.10.1"
+# eautoreconf needs:
+# >=gnome-base/gnome-common-2.12
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --disable-scrollkeeper
+ $(use_enable libnotify)
+ PERL=$(type -P false)"
+ DOCS="AUTHORS ChangeLog HACKING NEWS README THANKS TODO"
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-libnotify-ifdef.patch"
+ gnome2_src_prepare
+}
+
+src_install() {
+ gnome2_src_install
+
+ rm "${ED}/usr/bin/gdialog" || die "rm gdialog failed!"
+}