summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2004-03-22 10:15:50 +0000
committerAlastair Tse <liquidx@gentoo.org>2004-03-22 10:15:50 +0000
commit080fa3baf34c7626d9ae1639ecc490fbe9391f0a (patch)
treeed39061f9474ca2eceb685f65172a8a0418e0f1c /gnome-extra
parentAdded to ~ppc (Manifest recommit) (diff)
downloadgentoo-2-080fa3baf34c7626d9ae1639ecc490fbe9391f0a.tar.gz
gentoo-2-080fa3baf34c7626d9ae1639ecc490fbe9391f0a.tar.bz2
gentoo-2-080fa3baf34c7626d9ae1639ecc490fbe9391f0a.zip
version bump
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/libgtkhtml/ChangeLog7
-rw-r--r--gnome-extra/libgtkhtml/files/digest-libgtkhtml-3.0.101
-rw-r--r--gnome-extra/libgtkhtml/libgtkhtml-3.0.10.ebuild50
3 files changed, 57 insertions, 1 deletions
diff --git a/gnome-extra/libgtkhtml/ChangeLog b/gnome-extra/libgtkhtml/ChangeLog
index ad80b8727487..904b39f3cd4c 100644
--- a/gnome-extra/libgtkhtml/ChangeLog
+++ b/gnome-extra/libgtkhtml/ChangeLog
@@ -1,6 +1,6 @@
# ChangeLog for gnome-extra/libgtkhtml
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/libgtkhtml/ChangeLog,v 1.64 2004/03/21 15:06:24 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/libgtkhtml/ChangeLog,v 1.65 2004/03/22 10:13:38 liquidx Exp $
*libgtkhtml-2.5.6 (21 Mar 2004)
@@ -8,6 +8,11 @@
Gnome 2.6 commit
Add accessibility USE
+*libgtkhtml-3.0.10 (22 Mar 2004)
+
+ 22 Mar 2004; Alastair Tse <liquidx@gentoo.org> libgtkhtml-3.0.10.ebuild:
+ version bump
+
16 Mar 2004; Stephen P. Becker <geoman@gentoo.org> libgtkhtml-2.4.1.ebuild:
Added ~mips keyword.
diff --git a/gnome-extra/libgtkhtml/files/digest-libgtkhtml-3.0.10 b/gnome-extra/libgtkhtml/files/digest-libgtkhtml-3.0.10
new file mode 100644
index 000000000000..1533aceb51d9
--- /dev/null
+++ b/gnome-extra/libgtkhtml/files/digest-libgtkhtml-3.0.10
@@ -0,0 +1 @@
+MD5 b05b8551f7803f32ecfcf505a6310f3f gtkhtml-3.0.10.tar.bz2 1074973
diff --git a/gnome-extra/libgtkhtml/libgtkhtml-3.0.10.ebuild b/gnome-extra/libgtkhtml/libgtkhtml-3.0.10.ebuild
new file mode 100644
index 000000000000..e0b8e190342e
--- /dev/null
+++ b/gnome-extra/libgtkhtml/libgtkhtml-3.0.10.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/libgtkhtml/libgtkhtml-3.0.10.ebuild,v 1.1 2004/03/22 10:13:38 liquidx Exp $
+
+inherit gnome2
+
+MY_P=${P/lib/}
+MY_PN=${PN/lib/}
+DESCRIPTION="Lightweight HTML Rendering/Printing/Editing Engine"
+HOMEPAGE="http://www.gnome.org/"
+
+# stolen from gnome.org eclass because it support this one-off name-mangling
+
+[ -z "${GNOME_TARBALL_SUFFIX}" ] && export GNOME_TARBALL_SUFFIX="bz2"
+PVP=($(echo " $PV " | sed 's:[-\._]: :g'))
+SRC_URI="mirror://gnome/sources/${MY_PN}/${PVP[0]}.${PVP[1]}/${MY_P}.tar.${GNOME_TARBALL_SUFFIX}"
+LICENSE="GPL-2"
+SLOT="3"
+KEYWORDS="~x86 ~ppc ~sparc ~hppa ~alpha ~ia64 ~amd64"
+IUSE=""
+
+S=${WORKDIR}/${MY_P}
+
+RDEPEND=">=gnome-extra/gal-1.99.10
+ >=net-libs/libsoup-1.99.26
+ >=gnome-base/libgnomeui-2.2
+ >=gnome-base/libgnomeprint-2.2
+ >=gnome-base/libgnomeprintui-2.2.1
+ >=gnome-base/libbonoboui-2.0
+ >=gnome-base/libbonobo-2.0
+ >=gnome-base/ORBit2-2.5.6
+ >=gnome-base/gnome-vfs-2.1
+ >=gnome-base/gail-1.1
+ >=dev-libs/libxml2-2.5"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.12.0"
+
+USE_DESTDIR="1"
+SCROLLKEEPER_UPDATE="0"
+ELTCONF="--reverse-deps"
+
+src_compile() {
+ gnome2_src_configure
+
+ EPATCH_OPTS="${S}/libtool"
+ epatch ${FILESDIR}/${PN}-3.0.7-libtool.patch
+
+ emake || die "make failed"
+}