summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2012-05-24 07:54:52 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2012-05-24 07:54:52 +0000
commit4c59bc9fe05af1467402e71915c1890c87674c58 (patch)
tree0eb2d7025039c9b1fdc07bbda436e3d17e8d95f8 /gnome-extra
parentInitial import (thanks to Ortwin Glueck and sunrise for the initial ebuild, b... (diff)
downloadgentoo-2-4c59bc9fe05af1467402e71915c1890c87674c58.tar.gz
gentoo-2-4c59bc9fe05af1467402e71915c1890c87674c58.tar.bz2
gentoo-2-4c59bc9fe05af1467402e71915c1890c87674c58.zip
Version bump.
(Portage version: 2.2.0_alpha107/cvs/Linux x86_64)
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/gnome-color-manager/ChangeLog8
-rw-r--r--gnome-extra/gnome-color-manager/gnome-color-manager-3.4.2.ebuild73
2 files changed, 80 insertions, 1 deletions
diff --git a/gnome-extra/gnome-color-manager/ChangeLog b/gnome-extra/gnome-color-manager/ChangeLog
index a2eed4d9d5cf..7757a4ad610a 100644
--- a/gnome-extra/gnome-color-manager/ChangeLog
+++ b/gnome-extra/gnome-color-manager/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for gnome-extra/gnome-color-manager
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gnome-color-manager/ChangeLog,v 1.18 2012/05/21 19:02:27 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gnome-color-manager/ChangeLog,v 1.19 2012/05/24 07:54:52 tetromino Exp $
+
+*gnome-color-manager-3.4.2 (24 May 2012)
+
+ 24 May 2012; Alexandre Rostovtsev <tetromino@gentoo.org>
+ +gnome-color-manager-3.4.2.ebuild:
+ Version bump.
21 May 2012; Alexandre Rostovtsev <tetromino@gentoo.org>
gnome-color-manager-3.2.3.ebuild, gnome-color-manager-3.2.4.ebuild:
diff --git a/gnome-extra/gnome-color-manager/gnome-color-manager-3.4.2.ebuild b/gnome-extra/gnome-color-manager/gnome-color-manager-3.4.2.ebuild
new file mode 100644
index 000000000000..398ec86dbeb9
--- /dev/null
+++ b/gnome-extra/gnome-color-manager/gnome-color-manager-3.4.2.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gnome-color-manager/gnome-color-manager-3.4.2.ebuild,v 1.1 2012/05/24 07:54:52 tetromino Exp $
+
+EAPI="4"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2
+
+DESCRIPTION="Color profile manager for the GNOME desktop"
+HOMEPAGE="http://projects.gnome.org/gnome-color-manager/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="clutter packagekit raw"
+
+# FIXME: fix detection of docbook2man
+COMMON_DEPEND=">=dev-libs/glib-2.31.10:2
+ gnome-base/gnome-desktop:3
+ >=media-libs/lcms-2.2:2
+ >=media-libs/libcanberra-0.10[gtk3]
+ media-libs/libexif
+ media-libs/tiff
+
+ x11-libs/libX11
+ x11-libs/libXrandr
+ >=x11-libs/gtk+-2.91:3
+ >=x11-libs/vte-0.25.1:2.90
+ >=x11-misc/colord-0.1.12
+
+ clutter? (
+ >=media-libs/clutter-1.9.11:1.0
+ media-libs/clutter-gtk:1.0
+ media-libs/mash:0.2 )
+ packagekit? ( app-admin/packagekit-base )
+ raw? ( media-gfx/exiv2 )
+"
+RDEPEND="${COMMON_DEPEND}
+ media-gfx/shared-color-profiles
+"
+# docbook-sgml-{utils,dtd:4.1} needed to generate man pages
+DEPEND="${COMMON_DEPEND}
+ app-text/docbook-sgml-dtd:4.1
+ app-text/docbook-sgml-utils
+ app-text/gnome-doc-utils
+ dev-libs/libxslt
+ >=dev-util/intltool-0.35
+ virtual/pkgconfig
+"
+
+# FIXME: run test-suite with files on live file-system
+RESTRICT="test"
+
+pkg_setup() {
+ # Always enable tests since they are check_PROGRAMS anyway
+ G2CONF="${G2CONF}
+ --disable-static
+ --disable-schemas-compile
+ --disable-scrollkeeper
+ --enable-tests
+ $(use_enable clutter)
+ $(use_enable packagekit)
+ $(use_enable raw exiv)"
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+
+ elog "If you want to do display or scanner calibration, you will need to"
+ elog "install media-gfx/argyllcms"
+}