summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-01-17 20:54:30 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-01-17 20:54:30 +0000
commit57b2772034ae60ce56baad6f0f4fc5109fa20f25 (patch)
tree61c33d5f5588cc2ed1ed1aa8a095f2c3312be007 /gnome-extra
parentHmmm. I may have forgotten to commit the original ebuild. In any event, (diff)
downloadgentoo-2-57b2772034ae60ce56baad6f0f4fc5109fa20f25.tar.gz
gentoo-2-57b2772034ae60ce56baad6f0f4fc5109fa20f25.tar.bz2
gentoo-2-57b2772034ae60ce56baad6f0f4fc5109fa20f25.zip
fix compile problem with gnome-libs-1.4.1.3
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/medusa/files/digest-medusa-0.5.1-r21
-rw-r--r--gnome-extra/medusa/medusa-0.5.1-r2.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/gnome-extra/medusa/files/digest-medusa-0.5.1-r2 b/gnome-extra/medusa/files/digest-medusa-0.5.1-r2
new file mode 100644
index 000000000000..4cce5fa5fa00
--- /dev/null
+++ b/gnome-extra/medusa/files/digest-medusa-0.5.1-r2
@@ -0,0 +1 @@
+MD5 26da7d668110d2a053a53ff23f15d0d0 medusa-0.5.1.tar.gz 389120
diff --git a/gnome-extra/medusa/medusa-0.5.1-r2.ebuild b/gnome-extra/medusa/medusa-0.5.1-r2.ebuild
new file mode 100644
index 000000000000..7802b941ce8a
--- /dev/null
+++ b/gnome-extra/medusa/medusa-0.5.1-r2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/medusa/medusa-0.5.1-r2.ebuild,v 1.1 2002/01/17 20:54:30 azarah Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="medusa"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/${PN}/${P}.tar.gz"
+HOMEPAGE="http://www.gnome.org/"
+
+DEPEND=">=gnome-base/gnome-vfs-1.0.2-r1"
+
+src_compile() {
+ CFLAGS="${CFLAGS} -I/usr/include/gnome-1.0"
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --sharedstatedir=/var/lib \
+ --localstatedir=/var/lib \
+ --enable-prefer-db1 || die
+
+ # uid_t and gid_t is not #defined, fix
+ mv libmedusa/medusa-file-info-utilities.h \
+ libmedusa/medusa-file-info-utilities.h.orig
+ sed -e 's/uid_t/__uid_t/' \
+ -e 's/gid_t/__gid_t/' \
+ libmedusa/medusa-file-info-utilities.h.orig \
+ > libmedusa/medusa-file-info-utilities.h
+
+ emake medusainitdir=/tmp || die
+}
+
+src_install() {
+ make DESTDIR=${D} medusainitdir=/tmp install || die
+
+ dodoc ABOUT-NLS AUTHORS COPYING ChangeLog INSTALL NEWS README THANKS TODO
+}