summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2007-08-18 13:26:57 +0000
committerFabian Groffen <grobian@gentoo.org>2007-08-18 13:26:57 +0000
commit19ce6258035be4d268e1c449101c529447597deb (patch)
treecea6fb39d5c3ab0d42b0fceb397f67d31409d83a /gnustep-base
parentAdd gnustep eclasses from GNUstep overlay. Discussed on -dev. (diff)
downloadgentoo-2-19ce6258035be4d268e1c449101c529447597deb.tar.gz
gentoo-2-19ce6258035be4d268e1c449101c529447597deb.tar.bz2
gentoo-2-19ce6258035be4d268e1c449101c529447597deb.zip
Adding newest gnustep-make from GNUstep overlay, using new gnustep eclasses.
(Portage version: 2.1.2.11)
Diffstat (limited to 'gnustep-base')
-rw-r--r--gnustep-base/gnustep-make/ChangeLog9
-rw-r--r--gnustep-base/gnustep-make/files/digest-gnustep-make-2.0.13
-rw-r--r--gnustep-base/gnustep-make/files/gnustep-2.csh16
-rw-r--r--gnustep-base/gnustep-make/files/gnustep-2.sh20
-rw-r--r--gnustep-base/gnustep-make/files/gnustep-make-2.0.1-destdir.patch21
-rw-r--r--gnustep-base/gnustep-make/gnustep-make-2.0.1.ebuild83
6 files changed, 151 insertions, 1 deletions
diff --git a/gnustep-base/gnustep-make/ChangeLog b/gnustep-base/gnustep-make/ChangeLog
index f944ad25dd55..0da4d9d47d78 100644
--- a/gnustep-base/gnustep-make/ChangeLog
+++ b/gnustep-base/gnustep-make/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for gnustep-base/gnustep-make
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-make/ChangeLog,v 1.43 2007/03/18 01:33:13 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-make/ChangeLog,v 1.44 2007/08/18 13:26:56 grobian Exp $
+
+*gnustep-make-2.0.1 (18 Aug 2007)
+
+ 18 Aug 2007; Fabian Groffen <grobian@gentoo.org>
+ +files/gnustep-make-2.0.1-destdir.patch, +files/gnustep-2.csh,
+ +files/gnustep-2.sh, +gnustep-make-2.0.1.ebuild:
+ Adding newest gnustep-make from GNUstep overlay, using new gnustep eclasses.
18 Mar 2007; Marius Mauch <genone@gentoo.org>
gnustep-make-1.10.0-r2.ebuild, gnustep-make-1.12.0-r1.ebuild,
diff --git a/gnustep-base/gnustep-make/files/digest-gnustep-make-2.0.1 b/gnustep-base/gnustep-make/files/digest-gnustep-make-2.0.1
new file mode 100644
index 000000000000..d8b6ea04bfdd
--- /dev/null
+++ b/gnustep-base/gnustep-make/files/digest-gnustep-make-2.0.1
@@ -0,0 +1,3 @@
+MD5 f268733ea23f53e211e3977e27b46098 gnustep-make-2.0.1.tar.gz 444343
+RMD160 b70f2cfbca02898018403787cd5ab879a0beafd8 gnustep-make-2.0.1.tar.gz 444343
+SHA256 63d5f1bc8f2f12707f0c109ddff3492a297e4ae21ff13eee62ed4e2aa761f653 gnustep-make-2.0.1.tar.gz 444343
diff --git a/gnustep-base/gnustep-make/files/gnustep-2.csh b/gnustep-base/gnustep-make/files/gnustep-2.csh
new file mode 100644
index 000000000000..00dfd6159aa9
--- /dev/null
+++ b/gnustep-base/gnustep-make/files/gnustep-2.csh
@@ -0,0 +1,16 @@
+#!/bin/csh
+
+# Test for an interactive shell
+if ( $?prompt ) then
+
+ setenv GNUSTEP_SYSTEM_TOOLS /usr/GNUstep/System/Tools
+
+ if ( -x $GNUSTEP_SYSTEM_TOOLS/make_services ) then
+ $GNUSTEP_SYSTEM_TOOLS/make_services
+ endif
+
+ if ( -x $GNUSTEP_SYSTEM_TOOLS/gdnc ) then
+ $GNUSTEP_SYSTEM_TOOLS/gdnc
+ endif
+
+endif
diff --git a/gnustep-base/gnustep-make/files/gnustep-2.sh b/gnustep-base/gnustep-make/files/gnustep-2.sh
new file mode 100644
index 000000000000..652a8e8bad73
--- /dev/null
+++ b/gnustep-base/gnustep-make/files/gnustep-2.sh
@@ -0,0 +1,20 @@
+#!/bin/sh
+
+# Test for an interactive shell
+case $- in
+ *i*)
+ ;;
+ *)
+ return
+ ;;
+esac
+
+GNUSTEP_SYSTEM_TOOLS=/usr/GNUstep/System/Tools
+
+if [ -x ${GNUSTEP_SYSTEM_TOOLS}/make_services ]; then
+ ${GNUSTEP_SYSTEM_TOOLS}/make_services
+fi
+
+if [ -x ${GNUSTEP_SYSTEM_TOOLS}/gdnc ]; then
+ ${GNUSTEP_SYSTEM_TOOLS}/gdnc
+fi
diff --git a/gnustep-base/gnustep-make/files/gnustep-make-2.0.1-destdir.patch b/gnustep-base/gnustep-make/files/gnustep-make-2.0.1-destdir.patch
new file mode 100644
index 000000000000..407a5145724e
--- /dev/null
+++ b/gnustep-base/gnustep-make/files/gnustep-make-2.0.1-destdir.patch
@@ -0,0 +1,21 @@
+* grobian@gentoo.org: because we use sandbox this check fails (cannot
+ write outside the DESTDIR. Allowing to write in the
+ GNUSTEP_INSTALLATION_DIR means our sandbox is useless, since then
+ everything can be written, so prefer to just check the DESTDIR
+ location instead.
+
+--- Master/rules.make
++++ Master/rules.make
+@@ -107,9 +107,9 @@
+
+ ifneq ($(GNUSTEP_INSTALLATION_DIR),)
+ internal-check-install-permissions:
+- @if [ -d "$(GNUSTEP_INSTALLATION_DIR)" \
+- -a ! -w "$(GNUSTEP_INSTALLATION_DIR)" ]; then \
+- echo "*ERROR*: the software is configured to install itself into $(GNUSTEP_INSTALLATION_DIR)"; \
++ @if [ -d "$(DESTDIR)$(GNUSTEP_INSTALLATION_DIR)" \
++ -a ! -w "$(DESTDIR)$(GNUSTEP_INSTALLATION_DIR)" ]; then \
++ echo "*ERROR*: the software is configured to install itself into $(DESTDIR)$(GNUSTEP_INSTALLATION_DIR)"; \
+ echo "but you do not have permissions to write in that directory:";\
+ echo "Aborting installation."; \
+ echo ""; \
diff --git a/gnustep-base/gnustep-make/gnustep-make-2.0.1.ebuild b/gnustep-base/gnustep-make/gnustep-make-2.0.1.ebuild
new file mode 100644
index 000000000000..9ecae4cee124
--- /dev/null
+++ b/gnustep-base/gnustep-make/gnustep-make-2.0.1.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-make/gnustep-make-2.0.1.ebuild,v 1.1 2007/08/18 13:26:56 grobian Exp $
+
+inherit gnustep-base eutils
+
+DESCRIPTION="GNUstep Makefile Package"
+
+HOMEPAGE="http://www.gnustep.org"
+SRC_URI="ftp://ftp.gnustep.org/pub/gnustep/core/${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+LICENSE="GPL-2"
+
+DEPEND="${GNUSTEP_CORE_DEPEND}
+ >=sys-devel/make-3.75"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ gnustep-base_pkg_setup
+
+ if ! built_with_use sys-devel/gcc objc; then
+ ewarn "gcc must be compiled with Objective-C support! See the objc USE flag."
+ die "ObjC support not available"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-destdir.patch
+}
+
+src_compile() {
+ cd ${S}
+
+ local myconf
+ myconf="--prefix=${GNUSTEP_PREFIX} --with-layout=gnustep"
+ myconf="$myconf --with-config-file=/etc/GNUstep/GNUstep.conf"
+ myconf="$myconf --enable-native-objc-exceptions"
+ econf $myconf || die "configure failed"
+
+ emake
+ # Prepare doc here (needed when no gnustep-make is already installed)
+ if use doc ; then
+ # If a gnustep-1 environment is set
+ unset GNUSTEP_MAKEFILES
+ cd Documentation
+ emake -j1 all install || die "doc make has failed"
+ cd ..
+ fi
+}
+
+src_install() {
+ # Get GNUSTEP_* variables
+ . ./GNUstep.conf
+
+ local make_eval="-j1"
+ use debug || make_eval="${make_eval} debug=no"
+ make_eval="${make_eval} verbose=yes"
+
+ emake ${make_eval} DESTDIR=${D} install || die "install has failed"
+
+ # Copy the documentation
+ if use doc ; then
+ dodir ${GNUSTEP_SYSTEM_LIBRARY}
+ cp -r Documentation/tmp-installation/System/Library/Documentation \
+ ${D}${GNUSTEP_SYSTEM_LIBRARY}
+ fi
+
+ exeinto /etc/profile.d
+ doexe ${FILESDIR}/gnustep-2.sh
+ doexe ${FILESDIR}/gnustep-2.csh
+
+ dodir /etc/env.d
+ cat <<- EOF > "${D}"/etc/env.d/99gnustep
+PATH=${GNUSTEP_SYSTEM_TOOLS}:${GNUSTEP_LOCAL_TOOLS}
+LDPATH=${GNUSTEP_SYSTEM_LIBRARIES}:${GNUSTEP_LOCAL_LIBRARIES}
+MANPATH=${GNUSTEP_SYSTEM_DOC_MAN}:${GNUSTEP_LOCAL_DOC_MAN}
+INFOPATH=${GNUSTEP_SYSTEM_DOC_INFO}:${GNUSTEP_LOCAL_DOC_INFO}
+INFODIR=${GNUSTEP_SYSTEM_DOC_INFO}:${GNUSTEP_LOCAL_DOC_INFO}
+EOF
+}