summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2013-09-26 11:55:20 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2013-09-26 11:55:20 +0000
commit27fe3dd4f1be5fac194108d698463faa0c282bf5 (patch)
tree283dced5d6f1d2ad581894686bb1728731adedad /gnustep-base
parentFix bug #485834 - Fix build failure if USE=-acl is set (diff)
downloadgentoo-2-27fe3dd4f1be5fac194108d698463faa0c282bf5.tar.gz
gentoo-2-27fe3dd4f1be5fac194108d698463faa0c282bf5.tar.bz2
gentoo-2-27fe3dd4f1be5fac194108d698463faa0c282bf5.zip
Version bump. Still uses old Makefile, should move to cmake build for next version
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key C74525F2)
Diffstat (limited to 'gnustep-base')
-rw-r--r--gnustep-base/libobjc2/ChangeLog8
-rw-r--r--gnustep-base/libobjc2/libobjc2-1.7.ebuild57
2 files changed, 64 insertions, 1 deletions
diff --git a/gnustep-base/libobjc2/ChangeLog b/gnustep-base/libobjc2/ChangeLog
index 71ae57626c92..61fa917ea57d 100644
--- a/gnustep-base/libobjc2/ChangeLog
+++ b/gnustep-base/libobjc2/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for gnustep-base/libobjc2
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnustep-base/libobjc2/ChangeLog,v 1.11 2013/03/17 15:37:33 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnustep-base/libobjc2/ChangeLog,v 1.12 2013/09/26 11:55:20 voyageur Exp $
+
+*libobjc2-1.7 (26 Sep 2013)
+
+ 26 Sep 2013; Bernard Cafarelli <voyageur@gentoo.org> +libobjc2-1.7.ebuild:
+ Version bump. Still uses old Makefile, should move to cmake build for next
+ version
17 Mar 2013; Markos Chandras <hwoarang@gentoo.org> metadata.xml:
Add proxy-maintainers to metadata.xml
diff --git a/gnustep-base/libobjc2/libobjc2-1.7.ebuild b/gnustep-base/libobjc2/libobjc2-1.7.ebuild
new file mode 100644
index 000000000000..36a42c175f70
--- /dev/null
+++ b/gnustep-base/libobjc2/libobjc2-1.7.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnustep-base/libobjc2/libobjc2-1.7.ebuild,v 1.1 2013/09/26 11:55:20 voyageur Exp $
+
+EAPI=5
+inherit multilib
+
+# We need gnustep-make, but gnustep-make can depend on libobjc
+# Use a temporary setup to install in /usr/
+GSMAKE=gnustep-make-2.6.5
+DESCRIPTION="GNUstep Objective-C runtime"
+HOMEPAGE="http://www.gnustep.org"
+SRC_URI="http://download.gna.org/gnustep/${P}.tar.bz2
+ ftp://ftp.gnustep.org/pub/gnustep/core/${GSMAKE}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+boehm-gc"
+
+RDEPEND="boehm-gc? ( dev-libs/boehm-gc )"
+DEPEND="${DEPEND}
+ >=sys-devel/clang-2.9"
+
+GSMAKE_S=${WORKDIR}/${GSMAKE}
+
+src_prepare() {
+ # Remove CFLAGS from assembly calls
+ sed -e "s/\$(ALL_CFLAGS)//" -i GNUmakefile || die "Assembly sed failed"
+ # Multilib-strict
+ cd "${GSMAKE_S}"
+ sed -e "s/lib/$(get_libdir)/g" \
+ -i FilesystemLayouts/fhs-system || die "multilib path sed failed"
+}
+
+src_configure() {
+ export CC=clang
+
+ cd "${GSMAKE_S}"
+ econf --with-layout=fhs-system
+}
+
+src_compile() {
+ local gb
+ use boehm-gc \
+ && gb="boehm_gc=yes" \
+ || gb="boehm_gc=no"
+ emake GNUSTEP_MAKEFILES="${GSMAKE_S}" messages=yes ${gb}
+}
+
+src_install() {
+ emake GNUSTEP_MAKEFILES="${GSMAKE_S}" \
+ GNUSTEP_CONFIG_FILE="${GSMAKE_S}"/GNUstep.conf \
+ GNUSTEP_INSTALLATION_DOMAIN=SYSTEM \
+ messages=yes \
+ DESTDIR="${D}" install
+}