summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2011-04-20 17:46:21 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2011-04-20 17:46:21 +0000
commit4dc64ebfe30a6e5d61bd4fd1c1ab90b6ffd18366 (patch)
tree1447eeb46538cfafe45f19cb4355848116e6c20c /gnustep-base
parentVersion bump (diff)
downloadgentoo-2-4dc64ebfe30a6e5d61bd4fd1c1ab90b6ffd18366.tar.gz
gentoo-2-4dc64ebfe30a6e5d61bd4fd1c1ab90b6ffd18366.tar.bz2
gentoo-2-4dc64ebfe30a6e5d61bd4fd1c1ab90b6ffd18366.zip
Version bump
(Portage version: 2.2.0_alpha30/cvs/Linux x86_64)
Diffstat (limited to 'gnustep-base')
-rw-r--r--gnustep-base/gnustep-gui/ChangeLog10
-rw-r--r--gnustep-base/gnustep-gui/gnustep-gui-0.20.0.ebuild50
2 files changed, 58 insertions, 2 deletions
diff --git a/gnustep-base/gnustep-gui/ChangeLog b/gnustep-base/gnustep-gui/ChangeLog
index a9402fc9c188..ba4f28016644 100644
--- a/gnustep-base/gnustep-gui/ChangeLog
+++ b/gnustep-base/gnustep-gui/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for gnustep-base/gnustep-gui
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-gui/ChangeLog,v 1.88 2010/11/08 13:21:25 voyageur Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-gui/ChangeLog,v 1.89 2011/04/20 17:46:21 voyageur Exp $
+
+*gnustep-gui-0.20.0 (20 Apr 2011)
+
+ 20 Apr 2011; Bernard Cafarelli <voyageur@gentoo.org>
+ +gnustep-gui-0.20.0.ebuild:
+ Version bump
08 Nov 2010; Bernard Cafarelli <voyageur@gentoo.org>
gnustep-gui-0.18.0.ebuild:
diff --git a/gnustep-base/gnustep-gui/gnustep-gui-0.20.0.ebuild b/gnustep-base/gnustep-gui/gnustep-gui-0.20.0.ebuild
new file mode 100644
index 000000000000..3b6d5dc21e63
--- /dev/null
+++ b/gnustep-base/gnustep-gui/gnustep-gui-0.20.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-gui/gnustep-gui-0.20.0.ebuild,v 1.1 2011/04/20 17:46:21 voyageur Exp $
+
+EAPI="3"
+
+inherit gnustep-base multilib
+
+DESCRIPTION="Library of GUI classes written in Obj-C"
+HOMEPAGE="http://www.gnustep.org/"
+SRC_URI="ftp://ftp.gnustep.org/pub/gnustep/core/${P}.tar.gz"
+
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-solaris"
+SLOT="0"
+LICENSE="LGPL-2.1"
+
+IUSE="jpeg gif png cups"
+
+DEPEND="${GNUSTEP_CORE_DEPEND}
+ >=gnustep-base/gnustep-base-1.22.0
+ x11-libs/libXt
+ >=media-libs/tiff-3
+ jpeg? ( virtual/jpeg )
+ gif? ( >=media-libs/giflib-4.1 )
+ png? ( >=media-libs/libpng-1.2 )
+ cups? ( >=net-print/cups-1.1 )
+ media-libs/audiofile
+ app-text/aspell"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ egnustep_env
+
+ local myconf=
+ use gif && myconf="--disable-ungif --enable-libgif"
+
+ econf \
+ --with-tiff-include="${EPREFIX}"/usr/include \
+ --with-tiff-library="${EPREFIX}"/usr/$(get_libdir) \
+ $(use_enable jpeg) \
+ $(use_enable png) \
+ $(use_enable cups) \
+ ${myconf} || die "configure failed"
+}
+
+pkg_postinst() {
+ ewarn "The shared library version has changed in this release."
+ ewarn "You will need to recompile all Applications/Tools/etc in order"
+ ewarn "to use this library. Please run revdep-rebuild to do so"
+}