summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2001-09-23 18:43:20 +0000
committerDan Armak <danarmak@gentoo.org>2001-09-23 18:43:20 +0000
commit692828fb4d2a316e219180eb36015a1c788487a0 (patch)
tree6bfb572f20032522c355b08b0df02a28108c5bd5 /incoming
parentmakefile patch still seems to be needed (diff)
downloadgentoo-2-692828fb4d2a316e219180eb36015a1c788487a0.tar.gz
gentoo-2-692828fb4d2a316e219180eb36015a1c788487a0.tar.bz2
gentoo-2-692828fb4d2a316e219180eb36015a1c788487a0.zip
new version posted on gentoo-ebuild
Diffstat (limited to 'incoming')
-rw-r--r--incoming/mailx/mailx-8.1.1.11.ebuild18
1 files changed, 14 insertions, 4 deletions
diff --git a/incoming/mailx/mailx-8.1.1.11.ebuild b/incoming/mailx/mailx-8.1.1.11.ebuild
index 9250c77540b7..4bbe3d701112 100644
--- a/incoming/mailx/mailx-8.1.1.11.ebuild
+++ b/incoming/mailx/mailx-8.1.1.11.ebuild
@@ -2,12 +2,15 @@
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Martin Schlemmer <azarah@saintmail.net>
-S=${WORKDIR}/${P}.orig
+S=${WORKDIR}/mailx-8.1.1.orig
DESCRIPTION="The /bin/mail program, which is used to send mail via shell scripts."
SRC_URI="ftp://ftp.debian.org/debian/pool/main/m/mailx/mailx_8.1.1.orig.tar.gz"
HOMEPAGE="http://www.debian.org"
-DEPEND=">=sys-libs/liblockfile-1.03"
+DEPEND="virtual/glibc
+ >=sys-libs/liblockfile-1.03"
+
+RDEPEND="$DEPEND"
src_unpack() {
unpack ${A}
@@ -36,10 +39,17 @@ src_install () {
dodir /bin /usr/share/man/man1 /etc /usr/lib
make BINDIR=/bin DESTDIR=${D} install || die
+ # Install the docs
+ docinto debian
+ dodoc debian/*
+
# Create symlinks (some scripts require Mail)
- cd ${D}/bin
ln -sf mail Mail
- cd ${D}/usr/share/man/man1
ln -sf mail.1 Mail.1
+ into /
+ dobin Mail
+ into /usr
+ doman Mail.1
+
}