summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2011-04-21 20:16:14 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2011-04-21 20:16:14 +0000
commit2c9797a2f6a1d37b894a3e12dc23ea0500df761d (patch)
tree86cac97c4ac350dae400d4b454055a7da5d3aa93 /kde-base/akonadi
parentAdd patch snatched from debian for bug #364365 (diff)
downloadgentoo-2-2c9797a2f6a1d37b894a3e12dc23ea0500df761d.tar.gz
gentoo-2-2c9797a2f6a1d37b894a3e12dc23ea0500df761d.tar.bz2
gentoo-2-2c9797a2f6a1d37b894a3e12dc23ea0500df761d.zip
Version bump
(Portage version: 2.1.9.46/cvs/Linux x86_64)
Diffstat (limited to 'kde-base/akonadi')
-rw-r--r--kde-base/akonadi/ChangeLog8
-rw-r--r--kde-base/akonadi/akonadi-4.4.11.1.ebuild41
2 files changed, 48 insertions, 1 deletions
diff --git a/kde-base/akonadi/ChangeLog b/kde-base/akonadi/ChangeLog
index a447b51a5a93..b6823f74c2fb 100644
--- a/kde-base/akonadi/ChangeLog
+++ b/kde-base/akonadi/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/akonadi
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/akonadi/ChangeLog,v 1.85 2011/03/24 23:59:13 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/akonadi/ChangeLog,v 1.86 2011/04/21 20:16:14 dilfridge Exp $
+
+*akonadi-4.4.11.1 (21 Apr 2011)
+
+ 21 Apr 2011; Andreas K. Huettel <dilfridge@gentoo.org>
+ +akonadi-4.4.11.1.ebuild:
+ Version bump
24 Mar 2011; Andreas K. Huettel <dilfridge@gentoo.org>
-akonadi-4.4.5.ebuild:
diff --git a/kde-base/akonadi/akonadi-4.4.11.1.ebuild b/kde-base/akonadi/akonadi-4.4.11.1.ebuild
new file mode 100644
index 000000000000..6517815b980d
--- /dev/null
+++ b/kde-base/akonadi/akonadi-4.4.11.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/akonadi/akonadi-4.4.11.1.ebuild,v 1.1 2011/04/21 20:16:14 dilfridge Exp $
+
+EAPI=4
+
+KDE_MINIMAL="4.6"
+KMNAME="kdepim"
+inherit kde4-meta
+
+DESCRIPTION="An extensible cross-desktop storage service for PIM data and meta data"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug"
+
+DEPEND="
+ >=app-office/akonadi-server-1.3.1
+ $(add_kdebase_dep kdelibs 'semantic-desktop')
+ $(add_kdebase_dep kdepimlibs 'semantic-desktop')
+ $(add_kdebase_dep libkdepim)
+"
+RDEPEND="${DEPEND}
+ $(add_kdebase_dep kdepim-runtime)
+"
+
+KMEXTRA="
+ akonadiconsole/
+"
+
+# @since 4.3 - blocks kdemaildir - no longer provided (it's in akonadi now)
+add_blocker kdemaildir
+add_blocker kdepim-kresources '<4.2.95'
+
+src_configure() {
+ mycmakeargs=(
+ # Set the dbus dirs, otherwise it searches in KDEDIR
+ -DAKONADI_DBUS_INTERFACES_INSTALL_DIR="${EPREFIX}/usr/share/dbus-1/interfaces"
+ -DAKONADI_DBUS_SERVICES_INSTALL_DIR="${EPREFIX}/usr/share/dbus-1/services"
+ )
+
+ kde4-meta_src_configure
+}