summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2009-01-13 21:02:20 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2009-01-13 21:02:20 +0000
commitc1c3883cd5a5fea2dd98f34b1ef98a471feecaa0 (patch)
treeada98de5c37a9b667b625d08fc2e8d0ba3d4d2fc /kde-base/akonadi
parentFix compilation with gcc-4.3, Bug #251187 (diff)
downloadgentoo-2-c1c3883cd5a5fea2dd98f34b1ef98a471feecaa0.tar.gz
gentoo-2-c1c3883cd5a5fea2dd98f34b1ef98a471feecaa0.tar.bz2
gentoo-2-c1c3883cd5a5fea2dd98f34b1ef98a471feecaa0.zip
Bump kde to 4.1.4
(Portage version: 2.2_rc21/cvs/Linux 2.6.28-gentoo x86_64)
Diffstat (limited to 'kde-base/akonadi')
-rw-r--r--kde-base/akonadi/ChangeLog12
-rw-r--r--kde-base/akonadi/akonadi-4.1.4.ebuild55
2 files changed, 65 insertions, 2 deletions
diff --git a/kde-base/akonadi/ChangeLog b/kde-base/akonadi/ChangeLog
index accd93612b78..954323d932d4 100644
--- a/kde-base/akonadi/ChangeLog
+++ b/kde-base/akonadi/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for kde-base/akonadi
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/akonadi/ChangeLog,v 1.4 2008/11/16 04:40:13 vapier Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/akonadi/ChangeLog,v 1.5 2009/01/13 21:02:20 alexxy Exp $
+
+ 13 Jan 2009; Alexey Shvetsov <alexxy@gentoo.org> +akonadi-4.1.4.ebuild:
+ Bump to 4.1.4
+
+*akonadi-4.1.4 (13 Jan 2009)
+
+ 13 Jan 2009; Alexey Shvetsov <alexxy@gentoo.org> +akonadi-4.1.4.ebuild:
+ Bump to 4.1.4
15 Nov 2008; Mike Frysinger <vapier@gentoo.org> akonadi-4.1.3.ebuild:
Add ppc/ppc64 love #244306.
diff --git a/kde-base/akonadi/akonadi-4.1.4.ebuild b/kde-base/akonadi/akonadi-4.1.4.ebuild
new file mode 100644
index 000000000000..5accb8b2621a
--- /dev/null
+++ b/kde-base/akonadi/akonadi-4.1.4.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/akonadi/akonadi-4.1.4.ebuild,v 1.1 2009/01/13 21:02:20 alexxy Exp $
+
+EAPI="2"
+
+KMNAME=kdepim
+inherit kde4-meta
+
+DESCRIPTION="An extensible cross-desktop storage service for PIM data and meta data"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+# add when libmapi becomes available with an ebuild
+#exchange
+IUSE="debug +nepomuk +plasma"
+
+# add when libmapi becomes available with an ebuild
+#exchange? ( net-libs/libmapi )
+RDEPEND="app-misc/strigi[dbus,qt4]
+ app-office/akonadi-server
+ dev-libs/boost
+ dev-libs/libxslt
+ >=kde-base/kdemaildir-${PV}:${SLOT}
+ >=kde-base/libkdepim-${PV}:${SLOT}
+ >=x11-misc/shared-mime-info-0.20
+ nepomuk? ( >=kde-base/nepomuk-${PV}:${SLOT} )
+ plasma? ( kde-base/libplasma:${SLOT} )"
+DEPEND="${RDEPEND}
+ dev-libs/libxml2"
+
+KMEXTRACTONLY="libkdepim/
+ maildir/"
+
+src_configure() {
+ # Set the dbus dirs, otherwise it searches in KDEDIR
+ mycmakeargs="${mycmakeargs}
+ -DAKONADI_DBUS_INTERFACES_INSTALL_DIR=/usr/share/dbus-1/interfaces
+ -DAKONADI_DBUS_SERVICES_INSTALL_DIR=/usr/share/dbus-1/services"
+ # replace with $(cmake-utils_use_with exchange OpenChange) when libmapi becomes available with an ebuild
+ mycmakeargs="${mycmakeargs}
+ -DWITH_LibXslt=ON
+ -DWITH_OpenChange=OFF
+ $(cmake-utils_use_with nepomuk Nepomuk)
+ $(cmake-utils_use_with plasma Plasma)"
+
+ kde4-meta_src_configure
+}
+
+src_test() {
+ # disable broken test
+ sed -i -e '/mailserializerplugintest/ s/^/#DO_NOT_RUN_TEST /' \
+ "${S}"/akonadi/plugins/tests/CMakeLists.txt || \
+ die "sed to disable mailserializerplugintest failed."
+
+ kde4-meta_src_test
+}