summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2014-08-20 16:02:53 +0000
committerJohannes Huber <johu@gentoo.org>2014-08-20 16:02:53 +0000
commitb5a8b2e1508f119b3da9007782069d7554f7973d (patch)
tree3039b14e2a5b6b94c65ead7c9d1b9e21cdab1b44 /kde-base/dolphin-plugins
parentStable for x86, wrt bug #520220 (diff)
downloadgentoo-2-b5a8b2e1508f119b3da9007782069d7554f7973d.tar.gz
gentoo-2-b5a8b2e1508f119b3da9007782069d7554f7973d.tar.bz2
gentoo-2-b5a8b2e1508f119b3da9007782069d7554f7973d.zip
Version bump KDE SC 4.14.0
(Portage version: 2.2.12/cvs/Linux x86_64, signed Manifest commit with key 0xF3CFD2BD)
Diffstat (limited to 'kde-base/dolphin-plugins')
-rw-r--r--kde-base/dolphin-plugins/ChangeLog7
-rw-r--r--kde-base/dolphin-plugins/dolphin-plugins-4.14.0.ebuild35
2 files changed, 41 insertions, 1 deletions
diff --git a/kde-base/dolphin-plugins/ChangeLog b/kde-base/dolphin-plugins/ChangeLog
index 01789c20edb1..fcd7ac5c4de5 100644
--- a/kde-base/dolphin-plugins/ChangeLog
+++ b/kde-base/dolphin-plugins/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/dolphin-plugins
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin-plugins/ChangeLog,v 1.161 2014/07/23 16:52:38 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin-plugins/ChangeLog,v 1.162 2014/08/20 16:02:47 johu Exp $
+
+*dolphin-plugins-4.14.0 (20 Aug 2014)
+
+ 20 Aug 2014; Johannes Huber <johu@gentoo.org> +dolphin-plugins-4.14.0.ebuild:
+ Version bump KDE SC 4.14.0
23 Jul 2014; Johannes Huber <johu@gentoo.org> -dolphin-plugins-4.13.2.ebuild:
Remove KDE SC 4.13.2
diff --git a/kde-base/dolphin-plugins/dolphin-plugins-4.14.0.ebuild b/kde-base/dolphin-plugins/dolphin-plugins-4.14.0.ebuild
new file mode 100644
index 000000000000..9680ca6f383c
--- /dev/null
+++ b/kde-base/dolphin-plugins/dolphin-plugins-4.14.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin-plugins/dolphin-plugins-4.14.0.ebuild,v 1.1 2014/08/20 16:02:47 johu Exp $
+
+EAPI=5
+
+inherit kde4-base
+
+DESCRIPTION="Extra Dolphin plugins"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug bazaar git mercurial subversion"
+
+DEPEND="
+ $(add_kdebase_dep libkonq)
+"
+RDEPEND="${DEPEND}
+ $(add_kdebase_dep kompare)
+ bazaar? ( dev-vcs/bzr )
+ git? ( dev-vcs/git )
+ mercurial? ( dev-vcs/mercurial )
+ subversion? ( dev-vcs/subversion )
+"
+
+src_install() {
+ { use bazaar || use git || use mercurial || use subversion; } && kde4-base_src_install
+}
+
+pkg_postinst() {
+ if ! use bazaar && ! use git && ! use mercurial && ! use subversion ; then
+ einfo
+ einfo "You have disabled all plugin use flags. If you want to have vcs"
+ einfo "integration in dolphin, enable those of your needs."
+ einfo
+ fi
+}