summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2010-01-25 14:23:16 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2010-01-25 14:23:16 +0000
commit2a5b8ab35090a1a3539cb14f1cee03883a1e9d7f (patch)
tree6ac0614491ba5e59a0105858bc8703839448c836 /kde-base/dolphin/dolphin-4.3.5.ebuild
parentVersion bump KDE 4.3.5 (diff)
downloadgentoo-2-2a5b8ab35090a1a3539cb14f1cee03883a1e9d7f.tar.gz
gentoo-2-2a5b8ab35090a1a3539cb14f1cee03883a1e9d7f.tar.bz2
gentoo-2-2a5b8ab35090a1a3539cb14f1cee03883a1e9d7f.zip
Version bump KDE 4.3.5
(Portage version: 2.2_rc61/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'kde-base/dolphin/dolphin-4.3.5.ebuild')
-rw-r--r--kde-base/dolphin/dolphin-4.3.5.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/kde-base/dolphin/dolphin-4.3.5.ebuild b/kde-base/dolphin/dolphin-4.3.5.ebuild
new file mode 100644
index 000000000000..c76e7492a0b8
--- /dev/null
+++ b/kde-base/dolphin/dolphin-4.3.5.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin/dolphin-4.3.5.ebuild,v 1.1 2010/01/25 14:23:16 scarabeus Exp $
+
+EAPI="2"
+
+KMNAME="kdebase-apps"
+inherit kde4-meta
+
+DESCRIPTION="A KDE filemanager focusing on usability"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug +handbook semantic-desktop thumbnail"
+
+DEPEND="
+ $(add_kdebase_dep kdelibs 'semantic-desktop?')
+ $(add_kdebase_dep libkonq)
+"
+RDEPEND="${DEPEND}
+ $(add_kdebase_dep kfind)
+"
+PDEPEND="
+ thumbnail? ( $(add_kdebase_dep mplayerthumbs) )
+"
+
+KMLOADLIBS="libkonq"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with semantic-desktop Nepomuk)
+ $(cmake-utils_use_with semantic-desktop Soprano)
+ )
+
+ kde4-meta_src_configure
+}