summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2013-11-09 13:43:52 +0000
committerJohannes Huber <johu@gentoo.org>2013-11-09 13:43:52 +0000
commitdd44313751521151b59dc789750d97e4c28700ef (patch)
tree506af0c388b8db8754aa7002569cee7a677416f0 /kde-base/dolphin
parentVersion bump (bug #484896) (diff)
downloadgentoo-2-dd44313751521151b59dc789750d97e4c28700ef.tar.gz
gentoo-2-dd44313751521151b59dc789750d97e4c28700ef.tar.bz2
gentoo-2-dd44313751521151b59dc789750d97e4c28700ef.zip
Revision bump adds upstream patch announced on packagers ml. Patch fixes clicking the trash plasmoid or starting Dolphin from the command line with a URL that includes another kioslave will just open the home folder.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key F3CFD2BD)
Diffstat (limited to 'kde-base/dolphin')
-rw-r--r--kde-base/dolphin/ChangeLog10
-rw-r--r--kde-base/dolphin/dolphin-4.11.3-r1.ebuild (renamed from kde-base/dolphin/dolphin-4.11.3.ebuild)4
-rw-r--r--kde-base/dolphin/files/dolphin-4.11.3-regression.patch61
3 files changed, 73 insertions, 2 deletions
diff --git a/kde-base/dolphin/ChangeLog b/kde-base/dolphin/ChangeLog
index 5182bbc1f252..075a322527da 100644
--- a/kde-base/dolphin/ChangeLog
+++ b/kde-base/dolphin/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for kde-base/dolphin
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin/ChangeLog,v 1.208 2013/11/05 22:23:21 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin/ChangeLog,v 1.209 2013/11/09 13:43:52 johu Exp $
+
+*dolphin-4.11.3-r1 (09 Nov 2013)
+
+ 09 Nov 2013; Johannes Huber <johu@gentoo.org> +dolphin-4.11.3-r1.ebuild,
+ +files/dolphin-4.11.3-regression.patch, -dolphin-4.11.3.ebuild:
+ Revision bump adds upstream patch announced on packagers ml. Patch fixes
+ clicking the trash plasmoid or starting Dolphin from the command line with a
+ URL that includes another kioslave will just open the home folder.
*dolphin-4.11.3 (05 Nov 2013)
diff --git a/kde-base/dolphin/dolphin-4.11.3.ebuild b/kde-base/dolphin/dolphin-4.11.3-r1.ebuild
index b197f55b8f27..1021f9b1c985 100644
--- a/kde-base/dolphin/dolphin-4.11.3.ebuild
+++ b/kde-base/dolphin/dolphin-4.11.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin/dolphin-4.11.3.ebuild,v 1.1 2013/11/05 22:23:21 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin/dolphin-4.11.3-r1.ebuild,v 1.1 2013/11/09 13:43:52 johu Exp $
EAPI=5
@@ -41,6 +41,8 @@ PDEPEND="
RESTRICT="test"
# bug 393129
+PATCHES=( "${FILESDIR}/${P}-regression.patch" )
+
src_configure() {
mycmakeargs=(
$(cmake-utils_use_with semantic-desktop NepomukCore)
diff --git a/kde-base/dolphin/files/dolphin-4.11.3-regression.patch b/kde-base/dolphin/files/dolphin-4.11.3-regression.patch
new file mode 100644
index 000000000000..d27c176faa27
--- /dev/null
+++ b/kde-base/dolphin/files/dolphin-4.11.3-regression.patch
@@ -0,0 +1,61 @@
+commit 1c856e44774a7ce8eb6dce6828ef689647f83ca4
+Author: Wolfgang Bauer <wbauer@tmo.at>
+Date: Wed Nov 6 16:46:09 2013 +0100
+
+ Revert "Files passed as arguments: Ignore unsupported files"
+
+ This reverts commit cd9e50ae4f3ded5a78d0cfb09a67684a9c15d726.
+
+ See bug#327224 for details.
+
+diff --git a/dolphin/src/dolphinmainwindow.cpp b/dolphin/src/dolphinmainwindow.cpp
+index 9da73f9..b477600 100644
+--- a/dolphin/src/dolphinmainwindow.cpp
++++ b/dolphin/src/dolphinmainwindow.cpp
+@@ -31,7 +31,6 @@
+ #include "panels/information/informationpanel.h"
+ #include "settings/dolphinsettingsdialog.h"
+ #include "statusbar/dolphinstatusbar.h"
+-#include "views/dolphinview.h"
+ #include "views/dolphinviewactionhandler.h"
+ #include "views/dolphinremoteencoding.h"
+ #include "views/draganddrophelper.h"
+@@ -244,20 +243,8 @@ void DolphinMainWindow::openDirectories(const QList<KUrl>& dirs)
+ return;
+ }
+
+- // dirs could contain URLs that actually point to archives or other files.
+- // Replace them by URLs we can open where possible and filter the rest out.
+- QList<KUrl> urlsToOpen;
+- foreach (const KUrl& rawUrl, dirs) {
+- const KFileItem& item = KFileItem(KFileItem::Unknown, KFileItem::Unknown, rawUrl);
+- item.determineMimeType();
+- const KUrl& url = DolphinView::openItemAsFolderUrl(item);
+- if (!url.isEmpty()) {
+- urlsToOpen.append(url);
+- }
+- }
+-
+- if (urlsToOpen.count() == 1) {
+- m_activeViewContainer->setUrl(urlsToOpen.first());
++ if (dirs.count() == 1) {
++ m_activeViewContainer->setUrl(dirs.first());
+ return;
+ }
+
+@@ -267,12 +254,12 @@ void DolphinMainWindow::openDirectories(const QList<KUrl>& dirs)
+
+ // Open each directory inside a new tab. If the "split view" option has been enabled,
+ // always show two directories within one tab.
+- QList<KUrl>::const_iterator it = urlsToOpen.begin();
+- while (it != urlsToOpen.end()) {
++ QList<KUrl>::const_iterator it = dirs.begin();
++ while (it != dirs.end()) {
+ openNewTab(*it);
+ ++it;
+
+- if (hasSplitView && (it != urlsToOpen.end())) {
++ if (hasSplitView && (it != dirs.end())) {
+ const int tabIndex = m_viewTab.count() - 1;
+ m_viewTab[tabIndex].secondaryView->setUrl(*it);
+ ++it;