summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2014-11-16 12:21:35 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2014-11-16 12:21:35 +0000
commit3f801aa646c6bf1e1d60d310da2302c2bd9fef66 (patch)
tree6e50112a7a8405c97655dde74a1c9e8217de71bd /kde-base/kalgebra/kalgebra-4.14.3.ebuild
parentremove old (diff)
downloadgentoo-2-3f801aa646c6bf1e1d60d310da2302c2bd9fef66.tar.gz
gentoo-2-3f801aa646c6bf1e1d60d310da2302c2bd9fef66.tar.bz2
gentoo-2-3f801aa646c6bf1e1d60d310da2302c2bd9fef66.zip
[kde-base] Add KDE SC 4.14.3
(Portage version: 2.2.14/cvs/Linux x86_64, RepoMan options: --force, signed Manifest commit with key F82F92E6)
Diffstat (limited to 'kde-base/kalgebra/kalgebra-4.14.3.ebuild')
-rw-r--r--kde-base/kalgebra/kalgebra-4.14.3.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/kde-base/kalgebra/kalgebra-4.14.3.ebuild b/kde-base/kalgebra/kalgebra-4.14.3.ebuild
new file mode 100644
index 000000000000..2ac89623f3ef
--- /dev/null
+++ b/kde-base/kalgebra/kalgebra-4.14.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kalgebra/kalgebra-4.14.3.ebuild,v 1.1 2014/11/16 12:21:30 alexxy Exp $
+
+EAPI=5
+
+KDE_HANDBOOK="optional"
+DECLARATIVE_REQUIRED="always"
+OPENGL_REQUIRED="optional"
+inherit kde4-base
+
+DESCRIPTION="MathML-based graph calculator for KDE"
+HOMEPAGE="http://www.kde.org/applications/education/kalgebra
+http://edu.kde.org/kalgebra"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug"
+
+DEPEND="
+ $(add_kdebase_dep analitza opengl?)
+ $(add_kdebase_dep libkdeedu)
+ opengl? ( virtual/glu )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_with opengl OpenGL)
+ )
+
+ kde4-base_src_configure
+}