summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2011-01-26 20:29:26 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2011-01-26 20:29:26 +0000
commitb55417d98c3ac6be2310a3971632cceac43c9378 (patch)
tree76ff040300cffb0bfdb60a4c1a785df48fbbf7cd /kde-base/kalgebra
parent[profiles] Mask marble with gps on ppc64 (diff)
downloadgentoo-2-b55417d98c3ac6be2310a3971632cceac43c9378.tar.gz
gentoo-2-b55417d98c3ac6be2310a3971632cceac43c9378.tar.bz2
gentoo-2-b55417d98c3ac6be2310a3971632cceac43c9378.zip
[kde-base] Add KDE SC 4.6.0
(Portage version: 2.2.0_alpha19_p2/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'kde-base/kalgebra')
-rw-r--r--kde-base/kalgebra/ChangeLog8
-rw-r--r--kde-base/kalgebra/files/kalgebra-4.5.73-solaris-graph2d.patch22
-rw-r--r--kde-base/kalgebra/kalgebra-4.6.0.ebuild49
3 files changed, 78 insertions, 1 deletions
diff --git a/kde-base/kalgebra/ChangeLog b/kde-base/kalgebra/ChangeLog
index 4bff520ae998..1198bd90e37a 100644
--- a/kde-base/kalgebra/ChangeLog
+++ b/kde-base/kalgebra/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kalgebra
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kalgebra/ChangeLog,v 1.77 2011/01/10 11:53:21 tampakrap Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kalgebra/ChangeLog,v 1.78 2011/01/26 20:29:25 alexxy Exp $
+
+*kalgebra-4.6.0 (26 Jan 2011)
+
+ 26 Jan 2011; Alexey Shvetsov <alexxy@gentoo.org>
+ +files/kalgebra-4.5.73-solaris-graph2d.patch, +kalgebra-4.6.0.ebuild:
+ Version bump KDE SC 4.6.0
*kalgebra-4.5.5 (10 Jan 2011)
diff --git a/kde-base/kalgebra/files/kalgebra-4.5.73-solaris-graph2d.patch b/kde-base/kalgebra/files/kalgebra-4.5.73-solaris-graph2d.patch
new file mode 100644
index 000000000000..d7fbcbfdb13b
--- /dev/null
+++ b/kde-base/kalgebra/files/kalgebra-4.5.73-solaris-graph2d.patch
@@ -0,0 +1,22 @@
+Desc: Fix missing isinf() for Solaris (same way as for kcalc).
+Author: Heiko Przybyl <zuxez@cs.tu-berlin.de>
+--- kalgebra-4.3.2/kalgebra/analitzagui/graph2d.cpp.orig 2009-10-16 15:31:29.804959916 +0200
++++ kalgebra-4.3.2/kalgebra/analitzagui/graph2d.cpp 2009-10-16 15:35:36.879338408 +0200
+@@ -38,6 +38,17 @@
+ #include "analitza.h"
+ #include "functionsmodel.h"
+
++// Stolen from kcalc.
++#if defined(Q_OS_SOLARIS)
++// Strictly by the standard, ininf() is a c99-ism which
++// is unavailable in C++. The IEEE FP headers provide
++// a function with similar functionality, so use that instead.
++// However, !finite(a) == isinf(a) || isnan(a), so it's
++// not 100% correct.
++#include <ieeefp.h>
++#define isinf(a) !finite(a)
++#endif
++
+ // #define DEBUG_GRAPH
+
+ using namespace std;
diff --git a/kde-base/kalgebra/kalgebra-4.6.0.ebuild b/kde-base/kalgebra/kalgebra-4.6.0.ebuild
new file mode 100644
index 000000000000..9765fb7ffaea
--- /dev/null
+++ b/kde-base/kalgebra/kalgebra-4.6.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kalgebra/kalgebra-4.6.0.ebuild,v 1.1 2011/01/26 20:29:25 alexxy Exp $
+
+EAPI="3"
+
+KDE_HANDBOOK="optional"
+KMNAME="kdeedu"
+OPENGL_REQUIRED="optional"
+inherit kde4-meta
+
+DESCRIPTION="MathML-based graph calculator for KDE."
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug +plasma readline"
+
+DEPEND="
+ readline? ( sys-libs/readline )
+"
+RDEPEND="${DEPEND}"
+
+KMEXTRACTONLY="
+ libkdeedu/kdeeduui/
+"
+KMEXTRA="
+ libkdeedu/qtmmlwidget/
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.5.73-solaris-graph2d.patch
+)
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with readline)
+ $(cmake-utils_use_with plasma)
+ $(cmake-utils_use_with opengl OpenGL)
+ )
+
+ kde4-meta_src_configure
+}
+
+src_test() {
+ # disable broken test
+ sed -i -e '/mathmlpresentationtest/ s/^/#DO_NOT_RUN_TEST /' \
+ "${S}"/"${PN}"/analitza/tests/CMakeLists.txt || \
+ die "sed to disable mathmlpresentationtest failed."
+
+ kde4-meta_src_test
+}