summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIngmar Vanhassel <ingmar@gentoo.org>2008-05-15 22:42:23 +0000
committerIngmar Vanhassel <ingmar@gentoo.org>2008-05-15 22:42:23 +0000
commitdd9013417c60e36f09cd5beb71beab8856a3e5ff (patch)
tree1ea8f8855b4b1dbcf6d35f19e8b79783f8729f3d /kde-base/kalzium
parentAdded KDE 4.0.4 version of kalgebra. Thanks to Jorge Manuel B. S. Vicetto. (diff)
downloadgentoo-2-dd9013417c60e36f09cd5beb71beab8856a3e5ff.tar.gz
gentoo-2-dd9013417c60e36f09cd5beb71beab8856a3e5ff.tar.bz2
gentoo-2-dd9013417c60e36f09cd5beb71beab8856a3e5ff.zip
Added KDE 4.0.4 version of kalzium. Thanks to Jorge Manuel B. S. Vicetto.
(Portage version: 2.1.5)
Diffstat (limited to 'kde-base/kalzium')
-rw-r--r--kde-base/kalzium/ChangeLog7
-rw-r--r--kde-base/kalzium/kalzium-4.0.4.ebuild66
2 files changed, 72 insertions, 1 deletions
diff --git a/kde-base/kalzium/ChangeLog b/kde-base/kalzium/ChangeLog
index 72a82895bcd6..6f86ee638fe8 100644
--- a/kde-base/kalzium/ChangeLog
+++ b/kde-base/kalzium/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kalzium
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kalzium/ChangeLog,v 1.94 2008/05/15 06:54:30 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kalzium/ChangeLog,v 1.95 2008/05/15 22:42:23 ingmar Exp $
+
+*kalzium-4.0.4 (15 May 2008)
+
+ 15 May 2008; Ingmar Vanhassel <ingmar@gentoo.org> +kalzium-4.0.4.ebuild:
+ Added KDE 4.0.4 version of kalzium. Thanks to Jorge Manuel B. S. Vicetto.
15 May 2008; Markus Rothe <corsair@gentoo.org> kalzium-3.5.9.ebuild:
Stable on ppc64; bug #221063
diff --git a/kde-base/kalzium/kalzium-4.0.4.ebuild b/kde-base/kalzium/kalzium-4.0.4.ebuild
new file mode 100644
index 000000000000..08ceb6d84ff5
--- /dev/null
+++ b/kde-base/kalzium/kalzium-4.0.4.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kalzium/kalzium-4.0.4.ebuild,v 1.1 2008/05/15 22:42:23 ingmar Exp $
+
+EAPI="1"
+
+KMNAME=kdeedu
+CPPUNIT_REQUIRED="optional"
+inherit kde4-meta
+
+DESCRIPTION="KDE: periodic table of the elements."
+KEYWORDS="~amd64 ~x86"
+IUSE="${IUSE} cviewer debug htmlhandbook solver"
+
+COMMONDEPEND=">=kde-base/libkdeedu-${PV}:${SLOT}
+ cviewer? ( >=dev-cpp/eigen-1.0.5
+ >=sci-chemistry/openbabel-2.1
+ || ( x11-libs/qt-opengl:4
+ >=x11-libs/qt-4.3.3:4 )
+ virtual/opengl )"
+DEPEND="${DEPEND} ${COMMONDEPEND}
+ solver? ( dev-ml/facile )"
+RDEPEND="${RDEPEND} ${COMMONDEPEND}"
+
+KMEXTRACTONLY="libkdeedu/kdeeduui libkdeedu/libscience"
+
+pkg_setup() {
+ if use cviewer && has_version '<x11-libs/qt-4.4.0_alpha:4'; then
+ QT4_BUILT_WITH_USE_CHECK="${QT4_BUILT_WITH_USE_CHECK} opengl"
+ fi
+
+ if use solver && ! built_with_use --missing true dev-lang/ocaml ocamlopt; then
+ eerror "In order to build the solver for ${PN}, you first need"
+ eerror "to have dev-lang/ocaml built with the ocamlopt useflag"
+ eerror "in order to get a native code ocaml compiler"
+ die "Please install dev-lang/ocaml with ocamlopt support"
+ fi
+ if use solver && ! built_with_use --missing true dev-ml/facile ocamlopt; then
+ eerror "In order to build the solver for ${PN}, you first need"
+ eerror "to have dev-ml/facile built with the ocamlopt useflag"
+ eerror "in order to get the native code library"
+ die "Please install dev-ml/facile with ocamlopt support"
+ fi
+
+ kde4-meta_pkg_setup
+}
+
+src_compile() {
+ if use solver ; then
+ # Compile the solver on its own as the cmake-based build is
+ # currently broken. Fixes bug 206620.
+ cd "${S}/${PN}/src/solver"
+ emake || die "compiling the ocaml resolver failed"
+ mkdir -p "${WORKDIR}/${PN}_build/${PN}/src/"
+ cp * "${WORKDIR}/${PN}_build/${PN}/src/"
+ fi
+
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with cviewer Eigen)
+ $(cmake-utils_use_with cviewer OpenBabel2)
+ $(cmake-utils_use_with cviewer OpenGL)
+ $(cmake-utils_use_with solver OCaml)
+ $(cmake-utils_use_with solver Libfacile)"
+
+ kde4-meta_src_compile
+}