summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2013-08-14 20:24:27 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2013-08-14 20:24:27 +0000
commit053fab4599b7a153575d6540f06f69fecd0d2740 (patch)
tree4f7d23e33c53b4249e734fa22c9151eae906afd0 /kde-base/kcheckpass
parentFixed and marked for ~x64-macos, bug #479554 (diff)
downloadgentoo-2-053fab4599b7a153575d6540f06f69fecd0d2740.tar.gz
gentoo-2-053fab4599b7a153575d6540f06f69fecd0d2740.tar.bz2
gentoo-2-053fab4599b7a153575d6540f06f69fecd0d2740.zip
Version bump KDE SC 4.11.0
(Portage version: 2.2.0_alpha196/cvs/Linux x86_64, signed Manifest commit with key EBE6A336BE19039C!)
Diffstat (limited to 'kde-base/kcheckpass')
-rw-r--r--kde-base/kcheckpass/ChangeLog8
-rw-r--r--kde-base/kcheckpass/kcheckpass-4.11.0.ebuild33
2 files changed, 40 insertions, 1 deletions
diff --git a/kde-base/kcheckpass/ChangeLog b/kde-base/kcheckpass/ChangeLog
index c07e13f44f94..39f283b0358e 100644
--- a/kde-base/kcheckpass/ChangeLog
+++ b/kde-base/kcheckpass/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kcheckpass
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kcheckpass/ChangeLog,v 1.283 2013/08/02 17:21:13 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kcheckpass/ChangeLog,v 1.284 2013/08/14 20:23:51 dilfridge Exp $
+
+*kcheckpass-4.11.0 (14 Aug 2013)
+
+ 14 Aug 2013; Andreas K. Huettel <dilfridge@gentoo.org>
+ +kcheckpass-4.11.0.ebuild:
+ Version bump KDE SC 4.11.0
02 Aug 2013; Johannes Huber <johu@gentoo.org> -kcheckpass-4.10.4.ebuild:
Remove KDE SC 4.10.4
diff --git a/kde-base/kcheckpass/kcheckpass-4.11.0.ebuild b/kde-base/kcheckpass/kcheckpass-4.11.0.ebuild
new file mode 100644
index 000000000000..84e6b8f069b2
--- /dev/null
+++ b/kde-base/kcheckpass/kcheckpass-4.11.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kcheckpass/kcheckpass-4.11.0.ebuild,v 1.1 2013/08/14 20:23:51 dilfridge Exp $
+
+EAPI=5
+
+KMNAME="kde-workspace"
+inherit kde4-meta
+
+DESCRIPTION="A simple password checker, used by any software in need of user authentication."
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug pam"
+
+RDEPEND="
+ pam? (
+ >=kde-base/kdebase-pam-7
+ virtual/pam
+ )
+"
+
+src_prepare() {
+ kde4-meta_src_prepare
+
+ use pam && epatch "${FILESDIR}/${PN}-4.4.2-no-SUID-no-GUID.patch"
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_with pam)
+ )
+
+ kde4-meta_src_configure
+}