summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2014-02-06 23:21:00 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2014-02-06 23:21:00 +0000
commit4cba78c8fcd56c326a180b231d15e11076652ab8 (patch)
tree2c17ca88ed78d7e028d5db315475f32581f8ef0d /kde-base/kcheckpass
parentVersion bump. (diff)
downloadgentoo-2-4cba78c8fcd56c326a180b231d15e11076652ab8.tar.gz
gentoo-2-4cba78c8fcd56c326a180b231d15e11076652ab8.tar.bz2
gentoo-2-4cba78c8fcd56c326a180b231d15e11076652ab8.zip
Version bump KDE SC 4.12.2
(Portage version: 2.2.8-r1/cvs/Linux x86_64, RepoMan options: --force, signed Manifest commit with key EBE6A336BE19039C!)
Diffstat (limited to 'kde-base/kcheckpass')
-rw-r--r--kde-base/kcheckpass/ChangeLog8
-rw-r--r--kde-base/kcheckpass/kcheckpass-4.11.6.ebuild33
2 files changed, 40 insertions, 1 deletions
diff --git a/kde-base/kcheckpass/ChangeLog b/kde-base/kcheckpass/ChangeLog
index 3a77b55f3162..9b4f04c247a9 100644
--- a/kde-base/kcheckpass/ChangeLog
+++ b/kde-base/kcheckpass/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kcheckpass
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kcheckpass/ChangeLog,v 1.302 2014/01/20 08:00:04 kensington Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kcheckpass/ChangeLog,v 1.303 2014/02/06 23:20:37 dilfridge Exp $
+
+*kcheckpass-4.11.6 (06 Feb 2014)
+
+ 06 Feb 2014; Andreas K. Huettel <dilfridge@gentoo.org>
+ +kcheckpass-4.11.6.ebuild:
+ Version bump KDE SC 4.11.6
20 Jan 2014; Michael Palimaka <kensington@gentoo.org>
kcheckpass-4.11.5.ebuild:
diff --git a/kde-base/kcheckpass/kcheckpass-4.11.6.ebuild b/kde-base/kcheckpass/kcheckpass-4.11.6.ebuild
new file mode 100644
index 000000000000..5cce25451a83
--- /dev/null
+++ b/kde-base/kcheckpass/kcheckpass-4.11.6.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kcheckpass/kcheckpass-4.11.6.ebuild,v 1.1 2014/02/06 23:20:37 dilfridge Exp $
+
+EAPI=5
+
+KMNAME="kde-workspace"
+inherit kde4-meta
+
+DESCRIPTION="A simple password checker, used by any software in need of user authentication."
+KEYWORDS=" ~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug pam"
+
+RDEPEND="
+ pam? (
+ >=kde-base/kdebase-pam-7
+ virtual/pam
+ )
+"
+
+src_prepare() {
+ kde4-meta_src_prepare
+
+ use pam && epatch "${FILESDIR}/${PN}-4.4.2-no-SUID-no-GUID.patch"
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_with pam)
+ )
+
+ kde4-meta_src_configure
+}