summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2011-10-06 18:11:13 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2011-10-06 18:11:13 +0000
commit9105207da0f7d5c2674846f47a99baf903903d3b (patch)
treed50899ea0ccfdaee04b35bfc24e0bc89b3d4c12a /kde-base/kcheckpass
parentInitial import. New dependency for forthcoming Rails 3.1 release. (diff)
downloadgentoo-2-9105207da0f7d5c2674846f47a99baf903903d3b.tar.gz
gentoo-2-9105207da0f7d5c2674846f47a99baf903903d3b.tar.bz2
gentoo-2-9105207da0f7d5c2674846f47a99baf903903d3b.zip
[kde-base] KDE SC 4.7.2
(Portage version: 2.2.0_alpha61/cvs/Linux x86_64)
Diffstat (limited to 'kde-base/kcheckpass')
-rw-r--r--kde-base/kcheckpass/ChangeLog7
-rw-r--r--kde-base/kcheckpass/kcheckpass-4.7.2.ebuild40
2 files changed, 46 insertions, 1 deletions
diff --git a/kde-base/kcheckpass/ChangeLog b/kde-base/kcheckpass/ChangeLog
index 2379f720dbb2..794d57c9a44b 100644
--- a/kde-base/kcheckpass/ChangeLog
+++ b/kde-base/kcheckpass/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kcheckpass
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kcheckpass/ChangeLog,v 1.196 2011/09/07 20:13:48 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kcheckpass/ChangeLog,v 1.197 2011/10/06 18:11:12 alexxy Exp $
+
+*kcheckpass-4.7.2 (06 Oct 2011)
+
+ 06 Oct 2011; Alexey Shvetsov <alexxy@gentoo.org> +kcheckpass-4.7.2.ebuild:
+ Version bump KDE SC 4.7.2
*kcheckpass-4.7.1 (07 Sep 2011)
diff --git a/kde-base/kcheckpass/kcheckpass-4.7.2.ebuild b/kde-base/kcheckpass/kcheckpass-4.7.2.ebuild
new file mode 100644
index 000000000000..94593d3f1146
--- /dev/null
+++ b/kde-base/kcheckpass/kcheckpass-4.7.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kcheckpass/kcheckpass-4.7.2.ebuild,v 1.1 2011/10/06 18:11:12 alexxy Exp $
+
+EAPI=4
+
+KMNAME="kde-workspace"
+inherit kde4-meta
+
+DESCRIPTION="A simple password checker, used by any software in need of user authentication."
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug pam"
+
+RDEPEND="
+ pam? (
+ >=kde-base/kdebase-pam-7
+ virtual/pam
+ )
+"
+DEPEND="${RDEPEND}
+ x11-libs/libxkbfile
+"
+
+PATCHES=(
+ "${FILESDIR}/kdebase-4.0.2-pam-optional.patch"
+)
+
+src_prepare() {
+ kde4-meta_src_prepare
+
+ use pam && epatch "${FILESDIR}/${PN}-4.4.2-no-SUID-no-GUID.patch"
+}
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with pam)
+ )
+
+ kde4-meta_src_configure
+}