summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWulf Krueger <philantrop@gentoo.org>2008-02-07 00:12:59 +0000
committerWulf Krueger <philantrop@gentoo.org>2008-02-07 00:12:59 +0000
commitb0cf2ebbfc7626d65b374788654d4e26028bda3f (patch)
tree473933e2eaf30d14938b24846be4b834a0d385d4 /kde-base/kcheckpass
parentrename check_apache_threads to has_apache_threads as suggested by dberkholz (diff)
downloadgentoo-2-b0cf2ebbfc7626d65b374788654d4e26028bda3f.tar.gz
gentoo-2-b0cf2ebbfc7626d65b374788654d4e26028bda3f.tar.bz2
gentoo-2-b0cf2ebbfc7626d65b374788654d4e26028bda3f.zip
Version bump to KDE 4.0.1.
(Portage version: 2.1.4.1)
Diffstat (limited to 'kde-base/kcheckpass')
-rw-r--r--kde-base/kcheckpass/ChangeLog8
-rw-r--r--kde-base/kcheckpass/files/kdebase-4.0.1-pam-optional.patch29
-rw-r--r--kde-base/kcheckpass/kcheckpass-4.0.1.ebuild25
3 files changed, 61 insertions, 1 deletions
diff --git a/kde-base/kcheckpass/ChangeLog b/kde-base/kcheckpass/ChangeLog
index bef093772478..fa0c3475090f 100644
--- a/kde-base/kcheckpass/ChangeLog
+++ b/kde-base/kcheckpass/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kcheckpass
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kcheckpass/ChangeLog,v 1.78 2008/01/31 15:30:22 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kcheckpass/ChangeLog,v 1.79 2008/02/07 00:11:22 philantrop Exp $
+
+*kcheckpass-4.0.1 (06 Feb 2008)
+
+ 06 Feb 2008; Wulf C. Krueger <philantrop@gentoo.org>
+ +files/kdebase-4.0.1-pam-optional.patch, +kcheckpass-4.0.1.ebuild:
+ Version bump to KDE 4.0.1.
31 Jan 2008; Brent Baude <ranger@gentoo.org> kcheckpass-3.5.8.ebuild:
Marking kcheckpass-3.5.8 ppc for bug 207634
diff --git a/kde-base/kcheckpass/files/kdebase-4.0.1-pam-optional.patch b/kde-base/kcheckpass/files/kdebase-4.0.1-pam-optional.patch
new file mode 100644
index 000000000000..6fb54f05c547
--- /dev/null
+++ b/kde-base/kcheckpass/files/kdebase-4.0.1-pam-optional.patch
@@ -0,0 +1,29 @@
+diff --git a/kdebase/workspace/cmake/modules/FindPAM.cmake b/kdebase/workspace/cmake/modules/FindPAM.cmake
+index 3499836..cd1c2bb 100644
+--- a/kdebase/workspace/cmake/modules/FindPAM.cmake
++++ b/kdebase/workspace/cmake/modules/FindPAM.cmake
+@@ -5,6 +5,8 @@
+ # PAM_INCLUDE_DIR - the pam include directory
+ # PAM_LIBRARIES - libpam library
+
++if (WITH_PAM)
++
+ if (PAM_INCLUDE_DIR AND PAM_LIBRARY)
+ # Already in cache, be silent
+ set(PAM_FIND_QUIETLY TRUE)
+@@ -72,3 +74,5 @@ else (PAM_FOUND)
+ endif (PAM_FOUND)
+
+ mark_as_advanced(PAM_INCLUDE_DIR PAM_LIBRARY DL_LIBRARY PAM_MESSAGE_CONST)
++
++endif (WITH_PAM)
+diff --git a/kdebase/workspace/cmake/modules/UnixAuth.cmake b/kdebase/workspace/cmake/modules/UnixAuth.cmake
+index ed8ab9e..ce3bcc2 100644
+--- a/kdebase/workspace/cmake/modules/UnixAuth.cmake
++++ b/kdebase/workspace/cmake/modules/UnixAuth.cmake
+@@ -1,4 +1,4 @@
+-find_package(PAM)
++macro_optional_find_package(PAM)
+
+ set(UNIXAUTH_LIBRARIES)
+ set(UNIXAUTH_INCLUDE_DIRS)
diff --git a/kde-base/kcheckpass/kcheckpass-4.0.1.ebuild b/kde-base/kcheckpass/kcheckpass-4.0.1.ebuild
new file mode 100644
index 000000000000..699d5f9d3d5e
--- /dev/null
+++ b/kde-base/kcheckpass/kcheckpass-4.0.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kcheckpass/kcheckpass-4.0.1.ebuild,v 1.1 2008/02/07 00:11:22 philantrop Exp $
+
+EAPI="1"
+
+KMNAME=kdebase-workspace
+inherit kde4-meta
+
+DESCRIPTION="A simple password checker, used by any software in need of user authentication."
+KEYWORDS="~amd64 ~x86"
+IUSE="pam"
+
+DEPEND="pam? ( >=kde-base/kdebase-pam-7
+ sys-libs/pam )"
+RDEPEND="${DEPEND}"
+
+PATCHES="${FILESDIR}/kdebase-${PV}-pam-optional.patch"
+
+src_compile() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with pam PAM)"
+
+ kde4-meta_src_compile
+}