summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2012-04-04 23:59:39 +0000
committerJohannes Huber <johu@gentoo.org>2012-04-04 23:59:39 +0000
commitb31cc0441f4628bad93065beae2d74cb436c08c6 (patch)
treeb946ea6b122ad7c1de4b8c58dc400606f74fb540 /kde-base/kcheckpass
parentdev-libs/uriparser: 0.7.7 (diff)
downloadgentoo-2-b31cc0441f4628bad93065beae2d74cb436c08c6.tar.gz
gentoo-2-b31cc0441f4628bad93065beae2d74cb436c08c6.tar.bz2
gentoo-2-b31cc0441f4628bad93065beae2d74cb436c08c6.zip
Version bump KDE SC 4.8.2
(Portage version: 2.2.0_alpha98/cvs/Linux i686)
Diffstat (limited to 'kde-base/kcheckpass')
-rw-r--r--kde-base/kcheckpass/ChangeLog7
-rw-r--r--kde-base/kcheckpass/kcheckpass-4.8.2.ebuild36
2 files changed, 42 insertions, 1 deletions
diff --git a/kde-base/kcheckpass/ChangeLog b/kde-base/kcheckpass/ChangeLog
index abd8f13c13ce..6677cdb2b47c 100644
--- a/kde-base/kcheckpass/ChangeLog
+++ b/kde-base/kcheckpass/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kcheckpass
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kcheckpass/ChangeLog,v 1.216 2012/04/04 17:04:34 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kcheckpass/ChangeLog,v 1.217 2012/04/04 23:59:05 johu Exp $
+
+*kcheckpass-4.8.2 (04 Apr 2012)
+
+ 04 Apr 2012; Johannes Huber <johu@gentoo.org> +kcheckpass-4.8.2.ebuild:
+ Version bump KDE SC 4.8.2
04 Apr 2012; Agostino Sarubbo <ago@gentoo.org> kcheckpass-4.8.1.ebuild:
Stable for amd64, wrt bug #409403
diff --git a/kde-base/kcheckpass/kcheckpass-4.8.2.ebuild b/kde-base/kcheckpass/kcheckpass-4.8.2.ebuild
new file mode 100644
index 000000000000..91183e88439d
--- /dev/null
+++ b/kde-base/kcheckpass/kcheckpass-4.8.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kcheckpass/kcheckpass-4.8.2.ebuild,v 1.1 2012/04/04 23:59:05 johu Exp $
+
+EAPI=4
+
+KMNAME="kde-workspace"
+inherit kde4-meta
+
+DESCRIPTION="A simple password checker, used by any software in need of user authentication."
+KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug pam"
+
+RDEPEND="
+ pam? (
+ >=kde-base/kdebase-pam-7
+ virtual/pam
+ )
+"
+DEPEND="${RDEPEND}
+ x11-libs/libxkbfile
+"
+
+src_prepare() {
+ kde4-meta_src_prepare
+
+ use pam && epatch "${FILESDIR}/${PN}-4.4.2-no-SUID-no-GUID.patch"
+}
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with pam)
+ )
+
+ kde4-meta_src_configure
+}